cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jim755
Paper Tape
Posts: 1
Registered: ‎09-01-2016
Location: US
Views: 1,050
Message 1 of 3

T520 Battery Firmware Update Failed

I tried to install a battery  update on my Lenovo T520.  The update fails with an "internal error" message being reported.  The battery does not fully charge and now lasts only a few minutes once the charger is unplugged.  The battery is a Lenovo replacement less then a year old.

captnbob
Paper Tape
Posts: 5
Registered: ‎12-19-2011
Location: NZ
Views: 875
Message 2 of 3

Re: T520 Battery Firmware Update Failed

I had a similar problem two days ago.

I have a Lenovo T530 with an original extended battery running Windows 10 Pro with the latest updates installed.

After applying the Lenovo battery firmware update to a working laptop and battery, the battery became absolutely useless. It would switch off immediately when disconnecting power and would not switch on at all without the power connected.

 

Lenovo Technical support attempted to help with no success, though friendly and eager to try.

 

The solution I found and probable cause may help you.

 

Suspected faulty upgrade process:

When installing the battery firmware update to 1.16, it detected old firmware and asked to proceed, stating that the laptop would switch off immediately after the update. The laptop switched off within seconds of me clicking “next”, which I later realised was incorrect. This happened each of the 5 times I tried the update. After rebooting each time, it would tell me the firmware update failed due to an “internal error”.

 

A number of posts report a similar problem in the past. Here is one example:

https://forums.lenovo.com/t5/ThinkPad-11e-Windows-13-E-and/Battery-Firmware-update-failed-and-now-wi...

 

Solution and successful upgrade:

In my searches, I came across these two posts, suggesting I remove the Battery device drivers (details below).

I did so, then retried the battery firmware upgrade which worked very differently this time. When acknowledging the message that the laptop will shutdown, instead of switching off immediately, it took about 5 minutes to actually upgrade the battery firmware.

 

After doing this, the battery status is correct and I can use the laptop with only the battery for a few hours without trouble.

 

Detailed solution:

These are the steps I followed:

  1. Click Start and type device manager in the search field, then select Device Manager .
    b.            Expand the Batteries category.
    c.            Under the Batteries category, right-click the Microsoft ACPI Compliant Control and Microsoft AC Adapter listings, and select Uninstall .

Re-apply the Lenovo Battery firmware update 1.16 (should take a few minutes and will show the progress as it applies the patch) then reboot when you're prompted to by the firmware update.

 

Reference articles used:

https://support.caiu.org/hc/en-us/articles/203687454-Lenovo-battery-not-charging-detected

also:

https://answers.microsoft.com/en-us/windows/forum/windows_7-performance/lenovo-battery-plugged-in-no...

 

 

I trust this helps someone in future.

m4k97
Paper Tape
Posts: 3
Registered: ‎06-23-2013
Location: TW
Views: 53
Message 3 of 3

Re: T520 Battery Firmware Update Failed

captnbob you really saved me and my newly bought battery.. Thank you! after the update failed, there is only a big red x in the lenovo vantage toolbar, then i searched and saw your post, followed your instruction and the battery became alive! Thank you!

Check out current deals!


Shop current deals

Top Kudoed Authors