Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Fanfold Paper
Posts: 4
Registered: ‎06-28-2011
Location: United States
0 Kudos

T520 Display Port Not Working in Windows or Ubuntu

I have a t520 and I am trying to hook it up to a display using a displayport to hdmi adapter and the computer wont recognize it in ubuntu or in windows7... VGA works flawlessly in both though


Any ideas? T.I.A.

Fanfold Paper
Posts: 9
Registered: ‎07-27-2011
Location: Canada
0 Kudos

Re: T520 Display Port Not Working in Windows or Ubuntu

im having smae problem but i downgraded to xp

Guru
Posts: 8,730
Registered: ‎12-26-2009
Location: Vancouver
0 Kudos

Re: T520 Display Port Not Working in Windows or Ubuntu

Do you have Optimus?

Is the graphics driver properly installed?
W520: i7-2720QM, Q2000M at 1080/688/1376, 21GB RAM, 500GB + 750GB HDD, FHD screen & MB168B+
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Y3P: 5Y70, 8GB RAM, 256GB SSD, QHD+ screen
Fanfold Paper
Posts: 9
Registered: ‎07-27-2011
Location: Canada
0 Kudos

Re: T520 Display Port Not Working in Windows or Ubuntu

yes the graphic drivers are properly installed ut whats optimus?

Highlighted
Blue Screen Again
Posts: 5
Registered: ‎11-01-2011
Location: Vancouver
0 Kudos

Re: T520 Display Port Not Working in Windows or Ubuntu

Hi,

 

I have a  brand new September 2011 T520. My display port works perfectly for AUDIO and VIDEO. It is very important that you get the right adapter. I bought the StarTech DisplayPort to HDMI Video AND Audio Adapter Converter. I was worried by all the negative posts about lenovo displayports, But now that I have tested it and it works fine. Make sure your adapter says AUDIO AND VIDEO and you Run the update tool in the lenovo tool box. (Blue ThinkVantage Button.)

Anyways if you have the right adapter it was super easy. All you have to do is connect it up and your good to go!