cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
oddbrawl
Paper Tape
Posts: 3
Registered: ‎06-24-2015
Location: Canada
Views: 2,035
Message 1 of 4

T530 - USB 3.0 not working

After installing a new image of Windows 7 64 bit the USB 3.0 does not work.

I'm using drivers from Lenovo Update Retriever and the eXtensible Host Controller - "This device cannot start Code 10" ...or it  fails to appear in the device manager.

 

Do I need to downgrade the Bios and then install the USB 3.0 drivers then upgrade the Bios?

Where can I download a bios downgrade?

 

I've even tried the Lenovo Update and Drivers.

I have also tried uninstalling all USB drivers and letting windows update apply the driver updates with the same result.

 

Any help would be appreciated.

oddbrawl
Paper Tape
Posts: 3
Registered: ‎06-24-2015
Location: Canada
Views: 2,005
Message 2 of 4

Re: T530 - USB 3.0 not working

Did a complete wipe and new image on the laptop.

Now the USB 3.0 ports are sorta working. The top USB port doesn't work but the bottom one does.
Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 1,987
Message 3 of 4

Re: T530 - USB 3.0 not working

If you put a flash drive in the top port, and use F12 at the BIOS splash screen to choose a boot device, does it show up? If not, the port itself might be bad.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
oddbrawl
Paper Tape
Posts: 3
Registered: ‎06-24-2015
Location: Canada
Views: 1,975
Message 4 of 4

Re: T530 - USB 3.0 not working

Thanks Colonel, it looks like the port is bad as it isn't showing up.

Check out current deals!


Shop current deals

Top Kudoed Authors