English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

5 Posts

05-10-2019

CA

9 Signins

47 Page Views

  • Posts: 5
  • Registered: ‎05-10-2019
  • Location: CA
  • Views: 47
  • Message 1 of 8

T530 does not turn off LAN at shutdown

2019-05-10, 18:33 PM

Recently purchased a used T530... seems like a decent machine. Did a fresh install of Windows 7 Pro, did the windows updates... went to the support site, had it scan the laptop for updated software... downloaded and installed everything. After several reboots and a few more windows update checks and installs, I started to look at various software and services.

 

Some of them were not needed, and they were removed. Checked around the task scheduler and did some tweaks there as well. Did the thing in the BIOS, disabled all of the wake on lan stuff, etc... flipped the switch on the wireless to turn it off totally because its never used here.

 

For some reason, when the laptop is shut down, the LAN port seems to remain active. For me, off means off.  How can I get the LAN port to turn off when the laptop is shut down?

 

Thanks :)

 

Gary

Reply
Options

456 Posts

08-02-2018

PH

422 Signins

2273 Page Views

  • Posts: 456
  • Registered: ‎08-02-2018
  • Location: PH
  • Views: 2273
  • Message 2 of 8

Re: T530 does not turn off LAN at shutdown

2019-05-11, 1:30 AM

Hi cmwDev!

 

Welcome to the community forums,

 

Computers will often leave the Ethernet port active to allow for wake-on-LAN. This is a function of most modern computers to allow one to remotely power on a machine by sending it a special packet, though laptops will usually completely power off the ports when shut down and running on battery. You can follow the steps below on hot to disable the Wake-On-LAN feature of the laptop.

 

1. Click Start > Settings > Control Panel.
2. Double-click System.
3. Click the Hardware tab and click Device Manager.
4. Expand the Network Adapters section.
5. Right-click on your adapter and select Properties.
6. Click the Advanced tab.
7. Select Wake-on-LAN Options and click Properties. Set the following: Enable PME: set to Enabled.

 

Let us know how it goes.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

5 Posts

05-10-2019

CA

9 Signins

47 Page Views

  • Posts: 5
  • Registered: ‎05-10-2019
  • Location: CA
  • Views: 47
  • Message 3 of 8

Re: T530 does not turn off LAN at shutdown

2019-05-11, 18:59 PM

Little different route.. right click my computer, manage, device manage.. meh.. anyway.

 

2 network adapters.. disabled the wireless, selected the lan driver., properties... advanced tab.

 

There are no "wake on lan" options in the pulldown list, but there are 3 "wake on"...

 

1) link settings - disabled

2) magic packet - enabled

3) pattern match - enabled.

 

Should I disable all of them?

Reply
Options

5 Posts

05-10-2019

CA

9 Signins

47 Page Views

  • Posts: 5
  • Registered: ‎05-10-2019
  • Location: CA
  • Views: 47
  • Message 4 of 8

Re: T530 does not turn off LAN at shutdown

2019-05-11, 19:50 PM
update:... made all 3 disabled, no change. Lan is still on after a power down.
Reply
Options

733 Posts

08-02-2018

US

410 Signins

10344 Page Views

  • Posts: 733
  • Registered: ‎08-02-2018
  • Location: US
  • Views: 10344
  • Message 5 of 8

Re: T530 does not turn off LAN at shutdown

2019-05-12, 9:49 AM

 

Access BIOS and disabled Wake on LAN. It could be under power or config then save and exit BIOS. Once done, press Windows + X to open device manager then expand network adapter. Right click on the LAN adapter  then select properties. Go to Power Management Tab --> Uncheck --> Allow this device to bring the computer out of standby. Let us know if this works. 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Options

5 Posts

05-10-2019

CA

9 Signins

47 Page Views

  • Posts: 5
  • Registered: ‎05-10-2019
  • Location: CA
  • Views: 47
  • Message 6 of 8

Re: T530 does not turn off LAN at shutdown

2019-05-17, 18:24 PM

Apologies on the delayed response, getting access to the laptop is a bit difficult at times. Anyway :)

 

UEFI bios version 2.75 dated 2019-03-27

 

As specified earlier, config-network - wake on lan and ethernet lan options are disabled. In Security, Ethernet lan enabled, wireless lan and wan disabled.

 

Booted, checked gigabit network connections, advanced tab... enable PME, wake on link, wake on magic packet, wake on pattern match are all disabled.

 

Shut system down, LAN still active. Went back into the BIOS and changed the config-startup option, which was set to default to boot on LAN, to boot from the HDD0 drive... saved settings, booted windows.. then shutdown.

 

LAN is no longer active. Kind of strange that with all of the 'wake' options turned off, that the boot option of starting on the LAN would keep the lan enabled. Anyway, seems like this has solved the problem. Thanks kindly for the hand holding.

 

Gary :)

Reply
Options

734 Posts

04-23-2019

US

419 Signins

13362 Page Views

  • Posts: 734
  • Registered: ‎04-23-2019
  • Location: US
  • Views: 13362
  • Message 7 of 8

Re:

2019-05-17, 18:46 PM

Hi cmwDev,

 

Glad that we were able to help you out. If you have anymore questions feel free to send us a message. Thanks.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

5 Posts

05-10-2019

CA

9 Signins

47 Page Views

  • Posts: 5
  • Registered: ‎05-10-2019
  • Location: CA
  • Views: 47
  • Message 8 of 8

Re: Re:

2019-05-17, 18:55 PM

arg...I had to unmark the solution.. After I did my changes, I had pulled the main power off the laptop and was running on the battery... and when I shut down, the LAN port stayed off.

 

Putting the laptop back into its normal location, putting the AC power back into it.. the LAN port is back to staying active when the system is turned off. Just FYI, there is no 'sleep' or 'hibernate' allowed. It's either on, or off... power button, lid... "time"... all of the low power state items are off. So if the lid closes, or "shutdown" is down, it turns off.

 

Guess I will have to keep looking...

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save