Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

T540p Sierra WWAN (EM7345) reliability

2014-09-05, 19:20 PM

Hi,

 

I am getting strange errors. Connection might work fine for hours but then it goes nuts. I can connect to my mobile internet provider but no data is moving.

 

Attached a picture of errors.

 

What is this?

 

 

Capture.PNG

Reply
Answer
Options

136 Posts

10-28-2008

Norway

548 Signins

5892 Page Views

  • Posts: 136
  • Registered: ‎10-28-2008
  • Location: Norway
  • Views: 5892

Re: T540p Sierra WWAN (EM7345) reliability

2015-05-03, 18:15 PM

I suggest installing the latest driver published by Lenovo and lean back.

No more firmware worrying, you get the latest and greatest without any additional hassle:

 

http://support.lenovo.com/no/nn/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t450s/downloads/DS101007

 

Reply

Replies(45)
Options

Re: T540p Sierra WWAN (EM7345) reliability

2014-09-05, 19:26 PM
Picture disappeared.

It says (the Windows 7 network diagnostics program):
The mobile broadband network connection operation (context activation) failed with error code 0

and

Problem with wireless adapter or access point
Reply
Options

12985 Posts

06-06-2011

Russian Federation

17947 Signins

178550 Page Views

  • Posts: 12985
  • Registered: ‎06-06-2011
  • Location: Russian Federation
  • Views: 178550
  • Message 3 of 46

Re: T540p Sierra WWAN (EM7345) reliability

2014-09-06, 9:04 AM
Hi,

please, specify - are you able to establish connection only, w/o internet connection itself, browsing, data transfer?
What's the OS version on your laptop?



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique config
ThinkPad 25 Special Anniversary Edition. #Retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Reply
Options

Re: T540p Sierra WWAN (EM7345) reliability

2014-09-06, 10:23 AM

Hello,

 

a little update for the situation.

 

I am using the Access Connections version 6.22 on Windows 7 SP1. At the same time I have the Windows´s own network connection software in use.

 

Currently I can connect to the internet normally most of the time. Sometimes after several hours of use all traffic stops but Access Connections 6.22 and Windows´s software shows that the connection is still active. No data is being moved.

 

Then I try to reconnect and Windows gives different error messages. Sometimes the message is something like "computer appears to be correctly configured but the device or resource is not responding"  (can´t have the message right now).

 

I saw some events in the Event Log and here is something suspicious from the log:

 

Log Name:      Microsoft-Windows-Dhcp-Client/Admin
Source:        Microsoft-Windows-Dhcp-Client
Date:          6.9.2014 13:02:01
Event ID:      1001
Task Category: Address Configuration State Event
Level:         Error
Keywords:      
User:          LOCAL SERVICE
Computer:      LENOVO
Description:
Your computer was not assigned an address from the network (by the DHCP Server) for the Network Card with network address 0xEA2AEA1F27CE.  The following error occurred: 0x79. Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Dhcp-Client" Guid="{15A7A4F8-0072-4EAB-ABAD-F98A4D666AED}" />
    <EventID>1001</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>3</Task>
    <Opcode>75</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2014-09-06T10:02:01.993411600Z" />
    <EventRecordID>62</EventRecordID>
    <Correlation />
    <Execution ProcessID="652" ThreadID="4852" />
    <Channel>Microsoft-Windows-Dhcp-Client/Admin</Channel>
    <Computer>LENOVO</Computer>
    <Security UserID="S-1-5-19" />
  </System>
  <EventData>
    <Data Name="HWLength">6</Data>
    <Data Name="HWAddress">EA2AEA1F27CE</Data>
    <Data Name="StatusCode">121</Data>
  </EventData>
</Event>

 

And another one:

 

Log Name:      System
Source:        NetBT
Date:          6.9.2014 13:00:03
Event ID:      4307
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      LENOVO
Description:
Initialization failed because the transport refused to open initial addresses.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="NetBT" />
    <EventID Qualifiers="49152">4307</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-09-06T10:00:03.806823400Z" />
    <EventRecordID>8284</EventRecordID>
    <Channel>System</Channel>
    <Computer>LENOVO</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Binary>000000000100320000000000D31000C001000000070200C000000000000000000000000000000000</Binary>
  </EventData>
</Event>

 

Here is a pic when it is working (I try to get another pic when it is not working)

Capture2.PNG

Reply
Options

12985 Posts

06-06-2011

Russian Federation

17947 Signins

178550 Page Views

  • Posts: 12985
  • Registered: ‎06-06-2011
  • Location: Russian Federation
  • Views: 178550
  • Message 5 of 46

Re: T540p Sierra WWAN (EM7345) reliability

2014-09-06, 14:23 PM
There might be several causes:

1. too old modem firmware. Open cmd prompt window, type in the following string:
netsh mbn sh cap int=*

...post output here (remove device ID value for your privacy).

2. unstable LTE connection and, so, the roaming to the 3g network. I assume you didn't change connection profile default settings in the AC. Open profile for editing, "mobile broadband settings" tab, change "select wwan settings" to the "custom settings", "edit settings", "additional settings". The most likely you'll see "auto mode", try "use LTE only".



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique config
ThinkPad 25 Special Anniversary Edition. #Retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Reply
Options

Re: T540p Sierra WWAN (EM7345) reliability

2014-09-06, 14:51 PM

Here is the relevant output. I have updated the driver but not sure about firmware.

 

Manufacturer : Sierra Wireless Inc.
Model : Sierra Wireless EM7345 4G LTE
Firmware Information : FIH7160_V1.1_MODEM_01.1349.12
Maximum activation contexts : 1

 

I have my operator´s connection profile. I think it came from the sim card or from the web. And there was no that kind of "auto mode" or "LTE only" in additional settings. Not in the tab called "additional settings" and not in custom settings.

 

Now I haven´t got this situation for many hours. But I don´t assume that it´s solved. Haven´t do anything remarkable since the last failure.

Reply
Options

12985 Posts

06-06-2011

Russian Federation

17947 Signins

178550 Page Views

  • Posts: 12985
  • Registered: ‎06-06-2011
  • Location: Russian Federation
  • Views: 178550
  • Message 7 of 46

Re: T540p Sierra WWAN (EM7345) reliability

2014-09-06, 15:47 PM
1. As I've guessed above firmware is old. That fw has symptom you are facing with - unstable connection.
What driver package did you download and install? The rest one is:
http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/gtwo12ww.exe

There is firmware updater and new firmware image inside of the package. The rest fw version after updating should be FIH7160_V1.2_WW_01.1415.07

2. regarding the profile I'd like to say the carrier doesn't change windows and modem settings for the network choosing. Usually they are default and/or auto, it means the more power signal the more chance appropriate network type will be selected.

Again, do you see "mobile broadband settings" tab in AC? Since I don't have AC with UI in English have a look at the screenshot below. Change "Automatic settings" to the "Custom" and press the "Edit" button.
http://support.lenovo.com/us/en/documents/~/media/Images/MigratedAssets/pc/support/site_wss/6/65301_image005.ashx

If some window will appear press the left lower button, new window should appear.



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique config
ThinkPad 25 Special Anniversary Edition. #Retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Reply
Options

Re: T540p Sierra WWAN (EM7345) reliability

2014-09-06, 16:16 PM

1. How do I install the firmware?I double clicked a file called "EM7345_MBIM_only.exe" and a cmd prompt flashes quickly saying something but the version is the same when I use then the command you gave.

 

2. I get the "Network settings" screen when doing this. Screenshot attached.

 

Capture3.PNG

Reply
Options

12985 Posts

06-06-2011

Russian Federation

17947 Signins

178550 Page Views

  • Posts: 12985
  • Registered: ‎06-06-2011
  • Location: Russian Federation
  • Views: 178550
  • Message 9 of 46

Re: T540p Sierra WWAN (EM7345) reliability

2014-09-06, 19:23 PM
1. MBIM_only tool is script shell for applying modem settings, capable to work in batch mode and use, for example, MBIM_interface_only.txt file as input file.

FW updater - FirmwareApp.exe - should be in the folder "Program Files\Sierra Wireless Inc\MBIM Toolkit"

Or press Windows Start button, All Programs, Intel, MBIM Toolkit, M.2 WWAN Firmware Updater. Refer updater help.

It works in command line (manual) or window mode.

2. You typed command aove..
netsh mbn sh cap int=*

...but didn't provide complete output, that should say, in particular, capabilty for manual network selection.

Note the settings you've painted over, don't violate your privacy, they are stored in AC profile .xml file.



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique config
ThinkPad 25 Special Anniversary Edition. #Retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Reply
Options

Re: T540p Sierra WWAN (EM7345) reliability

2014-09-07, 5:56 AM

1. Ok found it. But there is no the firmware file in the C:\DRIVERS\WIN\WWANSRG5 location. When I execute the EM7345_MBIM_only.exe a cmd-window opens and goes away quickly. Won´t help if I run it already in cmd.exe. After that I get disconnected.

 

Anyway I tried the GUI also but it can´t find new firmware (there is no .flz files on the gtwo12ww.exe package).

 

2. Cellular class : GSM
Voice class : No voice
Sim class : SIM is removable
Data class : GPRS, EDGE, UMTS, HSDPA, HSUPA
GSM band class : Unknown
SMS capability : PDU receive, PDU send
Control capability : Manual network selection is allowed

 

Thank you for your patience.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms