English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

13 Posts

07-30-2010

Belarus

22 Signins

187 Page Views

  • Posts: 13
  • Registered: ‎07-30-2010
  • Location: Belarus
  • Views: 187
  • Message 1 of 6

T540p WIFI Intel n7260 - stopped working after the driver update. win7 x64

2015-01-19, 20:32 PM

I made a mistake updating drivers with the new ones. My wifi connection is compleatly died. I tried to reinstal / downgrade, but its not working. 

 

I can connect to the wifi router if i disable/unable the adapter in the windows' device man. Sometimes it works, sometmes - not. Sometimes it is showing connection, but there is no access to the internet.

 

Access connections is usually failng on "waiting association".

 

Driver version is 17.13.2.2. Tried several. Some drivers works but only untill i reboot system.

 

Solved! See the solution
Lenovo T540p / Z570 / Y50-70 / S10-3
Reply
Options

12633 Posts

06-06-2011

RU

17711 Signins

174745 Page Views

  • Posts: 12633
  • Registered: ‎06-06-2011
  • Location: RU
  • Views: 174745
  • Message 2 of 6

Re: T540p WIFI Intel n7260 - stopped working after the driver update. win7 x64

2015-01-20, 11:37 AM

Hi

try to disable U-APSD settings of wifi adapter drivers.



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #Retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Browser Search to find the answers in the Lenovo and Moto Community
Использование поисковых сервисов Интернет, чтобы найти ответы на форуме Lenovo & Moto

Reply
Options

13 Posts

07-30-2010

Belarus

22 Signins

187 Page Views

  • Posts: 13
  • Registered: ‎07-30-2010
  • Location: Belarus
  • Views: 187
  • Message 3 of 6

Re: T540p WIFI Intel n7260 - stopped working after the driver update. win7 x64

2015-01-21, 12:23 PM

Hi,

thank you for your replay.

 

Tried U-APSD = disable, HT= disable, only "g" mode. It sometimes connects to wifi but only for a minute or so (sometimes works till i reboot or switch off thee wifi). Power saving options are disabled. Other Wifi spots tried doo.

 

I think I gonna have to reinstall windows, as seems to me it is already wrecked by multiple installations.

 

Im considering my N7260 replace to the 7260AC (top model).  

Lenovo T540p / Z570 / Y50-70 / S10-3
Reply
Options

12633 Posts

06-06-2011

RU

17711 Signins

174745 Page Views

  • Posts: 12633
  • Registered: ‎06-06-2011
  • Location: RU
  • Views: 174745
  • Message 4 of 6

Re: T540p WIFI Intel n7260 - stopped working after the driver update. win7 x64

2015-01-21, 13:27 PM
this is overall issue for 7260 series, OS installation method doesn't matter.

Solutions from the community members, are working:
- downgrade wifi drivers to v.16.6.x.
- install wifi drivers 17.1.0
- install drivers only, w/o PROSet apps. Find out drivers package on the intel downloadcenter site, package name should include symbols "Ds", w/o quotes, of course.



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #Retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Browser Search to find the answers in the Lenovo and Moto Community
Использование поисковых сервисов Интернет, чтобы найти ответы на форуме Lenovo & Moto

Reply
Options

706 Posts

11-21-2013

US

837 Signins

10702 Page Views

  • Posts: 706
  • Registered: ‎11-21-2013
  • Location: US
  • Views: 10702
  • Message 5 of 6

Re: T540p WIFI Intel n7260 - stopped working after the driver update. win7 x64

2015-01-21, 15:06 PM

I stayed with 16.6 throughout the updates into the 17s, always rolling back due to sleep issues.  Then they released 17.11 and 12, and those were stable, so I stayed with it.  Now there is 17.13 which is also mature, and that's the one I use with AC 7260. 

 

I agree to uninstall ProSet.  Do that from Control Panel. 

 

Settings for the Advanced tab for the adapter:

Channel width auto for both bands

802.11n mode enabled

Ad hoc channel:  I use 11

Qos Mode:  WMM enabled.  Also set this in your router.

ARP Offload enabled

Bluetooth AMP enabled

Fat Channel Intolerant disabled

GTK Rekeying enabled

Mixed mode:  CTS-to-Self enabled

NS Offload enabled

Preferred band, I have no preference

Roaming aggressivenes medium-low

Sleep on WoWLAN disabled

Transmit power highest

UAPSD Support enabled.  This setting doesn't seem to matter to my adapter.

Wake  on Magic Packet and Pattern Match both enabled

Wireless mode 802.11a/b/g

 

Under Power, "Allow computer to turn off this device" is enabled.  Otherwise it won't wake from sleep. 

 

In the Windows Power settings, Maximum Performance, battery and AC.

 

I am also working from a fresh install of Windows, not a Lenovo image.  Access Connections might be part of the problem, and, again, ditch ProSet.  I also have an AC modem, which I think is a big factor in getting the AC to work fully.  

 

Install the generic driver 17.13 from here, and give it a try.

 

 Final word of caution/experience:  If you use Lenovo Update to do drivers for you, be advised that it does NOT create restore points.  If you don't like the outcome, you'll have to use your own restore point to roll back, and, also, the "Roll Back" button in the driver properties may be greyed out after using LU.  That button relies on restore points set during driver installs, but it doesn't pick up anything from LU. 

Reply
Options

13 Posts

07-30-2010

Belarus

22 Signins

187 Page Views

  • Posts: 13
  • Registered: ‎07-30-2010
  • Location: Belarus
  • Views: 187
  • Message 6 of 6

Re: T540p WIFI Intel n7260 - stopped working after the driver update. win7 x64

2015-01-27, 9:45 AM

Ok, sorry for the delay ... I was busy fighting with this. :)

 

Looks like I managed to fix this. That’s what I did (should be treated as an instruction):

 

1) Disabled and removed old drivers from device manager.

2) Removed related directories from: c:\ program Files, c:\ program files (x86) c:\%user%\appdata\roaming\intel

3) Removed adapter from registry HCLM\system\currentcontolset\contol\class\... \0012\ (just seek N-7260).

4) Removed adapter related registry entries (using regedit -> edit -> find -> "7260"). If anybody desided to do so, please do not del everything !!! Use brains.

5) Ran ccleaner. 

 

On this stage windows should completely forget about the adapter.

 

6) Removed access connections and cleaned registry for it (THIS STEP IS A MUST IF U HAVE AC INSTALLED!!!)

 

7) Installed generic driver from Intel site, no PRO/Set soft !!!! (Clean install, no older drivers installed before that)

8) Installed access connections. Rebooted if prompted.

 

My wifi internet started working. Connection is 144mps (this is a bit strange since router is dual banded with AC support, I was hoping for 300mps)

 

9) Reinstalled other things since this is damaged my vpn settings. So vpn reinstall is possibly needed. 

 

 

 

 

 

 

 

Lenovo T540p / Z570 / Y50-70 / S10-3

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete