English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

11-21-2019

US

4 Signins

88 Page Views

  • Posts: 2
  • Registered: ‎11-21-2019
  • Location: US
  • Views: 88
  • Message 1 of 2

T590 Dock Issue

2019-11-21, 18:57 PM

Hello, 

 

I've been experiencing some issues when using my T590 with the ThinkPad Thunderbot 3 Dock Gen 2 (40AN0135US.) I'll list all I've been experiencing and dock setup. 

 

Dock Setup

  • 2x Lenovo P24h-10 connected to HDMI Dock outputs 
  • Ethernet
  • 3.5mm cable to speakers
  • 135W power adapter supplied with dock
  • USB-C cable connected to T590

1. When I connect the USB-C cable to the first USB-C port (first from the left with the power cable icon) one monitor displays at 2560x1440 but the other maxes out at 1920x1080 and has some distortion. 

 

2. When I connect the USB-C cable to the Thunderbolt 3 port (second from the left with Thunderbolt icon) both monitors display at 2560x1440. The problem then is that sometimes my machine doesn't want to charge. Additionally, when using this port i have experienced the 1920x1080 max out and distortion once or twice. I was able to get around this by opening my laptop as a third display which then started displaying the correct resolutions on all displays. Eventualy I was able to close my laptop and the two monitors displayed correctly when using this setup. 

 

Lastly, as I was writing this I connected the dock to the T590 in each scenario I wrote up above to ensure I had everything correct. When I connected into scenario 2, my machine recognized the dock but neither of my two monitors displayed anything. I re-connected back to the first USB-C port and my monitors came back (same resolution settings as scenario 1.) I disconnected and reconnected to the Thunderbolt 3 port and everything is appearing normally. 

 

Has anyone else experienced anything above? Am I missing something? The dock I'm using is the supported dock for the T590. I'm not doing anything that would draw power beyond the 135W power adapter with the dock. I tried talking to Lenovo Support via chat but they could only confirm the dock I'm using is the supported dock. Only thing I can really think of is that this could be a hardware issue with the T590. 

 

I appreciate any feedback. 

 

 

 

Reply
Options

2 Posts

11-21-2019

US

4 Signins

88 Page Views

  • Posts: 2
  • Registered: ‎11-21-2019
  • Location: US
  • Views: 88
  • Message 2 of 2

Re: T590 Dock Issue

2019-11-21, 19:02 PM

I forgot to mention all FW is up to date via Lenovo Vantage. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save