cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jezmendoza
What's DOS?
Posts: 1
Registered: ‎07-13-2019
Location: US
Views: 99
Message 1 of 1

Thinkpad T460p 6820HQ can't reach 100% CPU Utilization and maximum turbo speed & BIOS load time slow

Hello,

 

I currently have a Thinkpad T460p with the following configuration:

 

- i7 6820HQ @ 2.7 GHz

- 2 TB Samsung 850 EVO

- 32 GB 2133 MHz DDR4 RAM (2x16 GB sticks rated for up to 2400 MHz)

- NVIDIA GeForce 940MX

- WQHD Display

- No WWAN and no Smart Card Reader

- Fingerprint Scanner

- Backlit Keyboard 

- 72 WH Battery

- 135 W AC Adapter

 

I am running the latest version of Windows (1903) and my BIOS is at R07ET89W 2.29, also the latest version according to Lenovo Vantage. All my drivers are up to date. Windows is also up to date. 

 

I have noticed that my computer never reaches 100% CPU Utilization and it never turbos to 3.6 GHz. If I recall correctly, Lenovo locked the TDP of this processor to 35W as opposed to the 45W it could also run on. Is this why my computer is never able to utilize the CPU at 100% nor is it able to reach 3.6 GHz? Upon observation, I have never seen this laptop go above 3.4 GHz, and that's very rare. 

 

I applied synthetic load to the computer via prime95. The program is able to max out my RAM, but it cannot even get my processor to utilize above 75%. It's usually just at around 56-68% utilization during the stress test, but it's mostly at the lower side. Clock speeds don't go above 1.78 GHz during the prime95 stress test, usually even closer to 1.50 GHz.  

 

I tried using a simpler stress test via CPUID. I could only get the processor close to 65% and clocks speeds are around 1.74-1.79 GHz. 

 

I also used Intel Extreme Tuning Utility's CPU Stress Test. I could never get utilization above 75% and clock speeds above 1.99 GHz. These aren't consistent numbers either, the figures are normally lower. 

 

I tried similar benchmarking tools on my other laptops. They could all utilize up to 100% of their CPUs. The most recent one I benchmarked was a Dell G5 running with an i5 8300H, 500 GB Samsung 970 EVO Plus, NVIDIA GeForce 1050, and 8 GB of RAM. This laptop was able to consistently maintain a 100% CPU Utilization and have speeds very close to its processor's 4.0 GHz maximum. I think the maximum during my tests was 3.98 GHz.  

 

All tests on all laptops were done at High Performance.

 

Is something wrong with my Thinkpad or is this expected due to the 35W limit? Is the said limit the cause of my laptop's inability to reach 100% CPU Utilization and 3.6 GHz turbo speeds? Last time I checked the interior of my laptop, there aren't any dust particles clogging airpath. It was quite clean on the inside. 

 

Lastly, when I access my laptop BIOS when I turn on the laptop, it takes a couple seconds before it loads. Is this normal? "Enter" also does not pause bootup. I am able to access the BIOS via the function keys. Enter does nothing. My BIOS has been updated to the latest version. What do you think is wrong here?

 

Thanks in advance. 

Check out current deals!


Shop current deals

Top Kudoed Authors