Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3 Posts

06-28-2013

bulgaria

6 Signins

21 Page Views

  • Posts: 3
  • Registered: ‎06-28-2013
  • Location: bulgaria
  • Views: 21
  • Message 1 of 3

Thinkpad T510 problem with the CPU frequency

2013-06-28, 8:32 AM

Hi,
I have e a problem with the CPU frequency - in DC or in battery it works 1/2 frequency (1196 MHz), but when my thinkpad plugged in and is with battery it works O.K (2400 MHz).
Do you have any suggestions how to resolve this problem.

Thinkpad T510 (4384) intel core i5, 6 GB Ram.
Thank you.
Best Regards Nikolay

Reply
Answer
Options

95 Posts

04-23-2013

NH

263 Signins

2960 Page Views

  • Posts: 95
  • Registered: ‎04-23-2013
  • Location: NH
  • Views: 2960

Re: Thinkpad T510 problem with the CPU frequency

2013-06-28, 12:15 PM

What your seeing is actually normal and a result of power management settings. When on battery, the CPU reduces its clock speed to improve battery life and only increases in speed if a program needs more processing power (games, adobe photoshop, CAD, etc.). If you want, you can disable this feature by setting the "maximum performance" option in the Lenovo power manager program and by going into the bios and disabling "Intel Speedstep" and adjusting similar power options. Hope this helps.

 

-Brian

My Thinkpads: T42 (GPU failure), T60, W530
W530: Windows 7 Pro | i7-3720qm | FHD screen | 256gb Samsung 840 Pro SSD | 500GB Ultrabay HDD | 16gb Crucial RAM | Nvidia K1000m
Reply

Replies(2)
Answer
Options

95 Posts

04-23-2013

NH

263 Signins

2960 Page Views

  • Posts: 95
  • Registered: ‎04-23-2013
  • Location: NH
  • Views: 2960
  • Message 2 of 3

Re: Thinkpad T510 problem with the CPU frequency

2013-06-28, 12:15 PM

What your seeing is actually normal and a result of power management settings. When on battery, the CPU reduces its clock speed to improve battery life and only increases in speed if a program needs more processing power (games, adobe photoshop, CAD, etc.). If you want, you can disable this feature by setting the "maximum performance" option in the Lenovo power manager program and by going into the bios and disabling "Intel Speedstep" and adjusting similar power options. Hope this helps.

 

-Brian

My Thinkpads: T42 (GPU failure), T60, W530
W530: Windows 7 Pro | i7-3720qm | FHD screen | 256gb Samsung 840 Pro SSD | 500GB Ultrabay HDD | 16gb Crucial RAM | Nvidia K1000m

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

06-28-2013

bulgaria

6 Signins

21 Page Views

  • Posts: 3
  • Registered: ‎06-28-2013
  • Location: bulgaria
  • Views: 21
  • Message 3 of 3

Re: Thinkpad T510 problem with the CPU frequency

2013-06-28, 12:27 PM
thank you very much.
Best Regards Nikolay
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms