Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

11 Posts

08-05-2010

Boise ID

12 Signins

91 Page Views

  • Posts: 11
  • Registered: ‎08-05-2010
  • Location: Boise ID
  • Views: 91
  • Message 1 of 6

Thinkvantage detected wrong GPU, installed wrong drivers, can't undo?

2010-08-05, 3:05 AM

So I have a T400.  P9400, Radeon HD3xxx (forget specifically), 4gb ram, other what nots.

 

I recently installed win7 over vista, and when I ran thinkvantage to automatically grab all my drivers for me it installed drivers for the intel chipset graphics, rather than the better ati graphics.

 

When I go totry and install any ati graphics it constantly tells me its not there, and under device manager it says only the intel chipset is present.  There is nothing under the install/uninstall menu for me to get rid of the drivers, so I can't uninstall those and install the ati ones over it.

 

What makes this ridiculous is that when I first checked thinkvantage it told me that I had an ati card without drivers, and that I should get them.

 

However it never installed them, now it cant find it, it says everything is great, and this is REALLY starting to piss me off.  What do?

Reply
Answer
Options

11 Posts

08-05-2010

New York

36 Signins

256 Page Views

  • Posts: 11
  • Registered: ‎08-05-2010
  • Location: New York
  • Views: 256

Re: Thinkvantage detected wrong GPU, installed wrong drivers, can't undo?

2010-08-05, 4:46 AM
I had this problem when I upgraded to Windows 7. After I did system update, I manually installed the driver from lenovo and it worked fine for me after a restart. This should be the driver

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-73641
Reply

Replies(5)
Options

21115 Posts

12-20-2008

Australia, Melbourne

20622 Signins

444194 Page Views

  • Posts: 21115
  • Registered: ‎12-20-2008
  • Location: Australia, Melbourne
  • Views: 444194
  • Message 2 of 6

Re: Thinkvantage detected wrong GPU, installed wrong drivers, can't undo?

2010-08-05, 3:07 AM

did you have the intel gpu activated rather than the ati graphics card activated?

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Reply
Options

11 Posts

08-05-2010

Boise ID

12 Signins

91 Page Views

  • Posts: 11
  • Registered: ‎08-05-2010
  • Location: Boise ID
  • Views: 91
  • Message 3 of 6

Re: Thinkvantage detected wrong GPU, installed wrong drivers, can't undo?

2010-08-05, 3:08 AM
I can't say I have any idea of how to enable either one.
Reply
Options

21115 Posts

12-20-2008

Australia, Melbourne

20622 Signins

444194 Page Views

  • Posts: 21115
  • Registered: ‎12-20-2008
  • Location: Australia, Melbourne
  • Views: 444194
  • Message 4 of 6

Re: Thinkvantage detected wrong GPU, installed wrong drivers, can't undo?

2010-08-05, 3:09 AM

you can change the gpu through the Thinkvantage Power Manager, under the different power plan. 

 

http://www-307.ibm.com/pc/support/site.wss/MIGR-70495.html#s1

 

have a read of the document provided in the link. 

 

 

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Reply
Options

11 Posts

08-05-2010

Boise ID

12 Signins

91 Page Views

  • Posts: 11
  • Registered: ‎08-05-2010
  • Location: Boise ID
  • Views: 91
  • Message 5 of 6

Re: Thinkvantage detected wrong GPU, installed wrong drivers, can't undo?

2010-08-05, 3:35 AM

Okay, so, installed power management, didnt help with anything, went into bios and disabled switchable graphics

 

It picked up my 3400 just fine and it works, so now the problem is that the switchable graphics arent working?

Reply
Answer
Options

11 Posts

08-05-2010

New York

36 Signins

256 Page Views

  • Posts: 11
  • Registered: ‎08-05-2010
  • Location: New York
  • Views: 256
  • Message 6 of 6

Re: Thinkvantage detected wrong GPU, installed wrong drivers, can't undo?

2010-08-05, 4:46 AM
I had this problem when I upgraded to Windows 7. After I did system update, I manually installed the driver from lenovo and it worked fine for me after a restart. This should be the driver

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-73641

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms