cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ConsolSpam
Fanfold Paper
Posts: 7
Registered: ‎08-02-2018
Location: US
Views: 2,092
Message 1 of 3

Touchpad and TrackPoint stoped working

Hello,

My touchpad and TrackPoint stoped working after installing the 8/30/18 Synaptics driver from the t480 driver downloads.

Before that, i had installed build 18204 from the Windows Insiders skip ahead and noticed that the TrackPoint did not work, but the touchpad did, so i decided to go install the newest drivers. Low and behold now both devices do not work.

 

I took the issue to a large Tech Support discord found here: https://discord.gg/B8P97Fh

The person helping me could not find a solution and pointed me to the Microsoft Community discord server

The Microsoft Community server did do or say anything about my issue so i moved onto https://support.microsoft.com/

After starting a thread on there I got help from someone, but all of the solutions given to me did not work, my ms answers thread is here: httpsbit.ly2LNnTf7

 

At this point, after installing or reseting windows at least 5 times, this is no longer a Microsoft problem, so i decided to come here.

Everything after this point is happening on a stable public release of windows like version 1703 or 1803, not an Insider build

Note that the Touchpad has not worked on public version 1803 & 1703, and does not work on Insider builds 17723, 17713, & 18204 so far.

 

Even with the propper drivers installed, any and all touchpad input is not registered

Window as seen here, but even though it says the touchpad is on the touchpad does not work

After seeing that Settings is lying to me, I decide to check device manager, and it says the Touchpad and TrackPoint are working properly as seen here

 

This is irritating, because it is not working propperly, seeing as i am unable to enable the TrackPoint as seen here

 

 

Both the TrackPoint and the touchpad are enabled in the bios, and i have tried installing the latest drivers.

If someone has a link to a June release of the BIOS and Synaptics driver that would be great, as currently i susspect it is one of the two causing issues.

 

I have checked the hardware and nothing looks out of place. All the ribbon cables are plugged in properly and there isnt any dirt or dust or grime on anything. I plan on trying a different operating system alltogether like Ubuntu or a copy of Windows 7 Home Premium, seeing as i have a spare ISO for both.

 

My current system information can be found here:

 

At this point any help is highly appreciated

ConsolSpam
Fanfold Paper
Posts: 7
Registered: ‎08-02-2018
Location: US
Views: 2,070
Message 2 of 3

Re: Touchpad and TrackPoint stoped working

Booted into Ubuntu off of a USB drive and now the Touchpad works in both Ubuntu and Windows. TrackPoint still doesn't work and it would be great if someone could help me with that, but it's no big deal, the touchpad was the big one. I will mark this as the answer for now.

duch11
Paper Tape
Posts: 6
Registered: ‎08-04-2018
Location: DK
Views: 1,906
Message 3 of 3

Re: Touchpad and TrackPoint stoped working

I have the same Issue, my trackpoint worked all of the sudden yesterday. But now it's gone again.
I have tried many of the things you are describing! But nothing!
Help would be appreciated, this issue is NOT solved!

Check out current deals!


Shop current deals

Top Kudoed Authors