English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

15 Posts

08-17-2012

CH

11 Signins

139 Page Views

  • Posts: 15
  • Registered: ‎08-17-2012
  • Location: CH
  • Views: 139
  • Message 1 of 6

UltraBay HD missing on wake up with Windows 10, T530

2016-05-23, 14:19 PM

Hi

 

Since I changed to Windows 10 (completely new installation), sometimes the HDD in the Ultrabay gets detached after wake up from sleep. First I can hear it turn on, then it goes off and a notification tells me that the HDD was removed.

 

I've tried all sort of drivers (Lenovo, Microsoft, Intel RST 12.5-12.9) with no luck.

It worked without any problems in Windows 7 (with Intel RST 12.5 driver).

 

Is it a known problem?

What can I do?

 

Regards

Vone

Solved! See the solution
Reply
Options

5554 Posts

06-27-2008

US

28465 Signins

1626807 Page Views

  • Posts: 5554
  • Registered: ‎06-27-2008
  • Location: US
  • Views: 1626807
  • Message 2 of 6

Re: UltraBay HD missing on wake up with Windows 10

2016-05-23, 23:51 PM

Good day.

Please provide your system model name/number (don't post your serial number, though), otherwise it will be difficult for the community to assist you. We will also be able to confirm that your post is in the proper forum.

Regards.


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKTRMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.

I am not a Lenovo employee

Reply
Options

15 Posts

08-17-2012

CH

11 Signins

139 Page Views

  • Posts: 15
  • Registered: ‎08-17-2012
  • Location: CH
  • Views: 139
  • Message 3 of 6

Re: UltraBay HD missing on wake up with Windows 10

2016-05-24, 19:32 PM

Thanks. I've added the model name, lenovo ThinkPad T530, to the title.

Reply
Options

1 Posts

08-01-2016

US

2 Signins

18 Page Views

  • Posts: 1
  • Registered: ‎08-01-2016
  • Location: US
  • Views: 18
  • Message 4 of 6

Re: UltraBay HD missing on wake up with Windows 10, T530

2016-08-01, 17:15 PM

 

On my T530, the disk does missing on Windows 10 after sleep (I think), at which point I cannot see it in even in disk management. I have tried rescan for hardware and other such solutions. It comes back only if I restart my machine.

 

[Edit 1]:

I found out that I can get back the HDD, if I let the computer sleep again and then login. Seems like sleep toggles between letting the HDD show up or not.

 

[Edit 2]:

Even on Windows 7 I had done registry edit to fix this issue

http://www.overclock.net/t/974023/fix-ahci-sata-drives-showing-in-safely-remove-hardware

 

For Window 10 this fix needs to be modified as shown here http://superuser.com/a/961242

 

Also see the latest posts on the Win 7 thread 

www.overclock.net/t/974023/fix-ahci-sata-drives-showing-in-safely-remove-hardware/50

 

I think this has fixed my issue. Will update again if that's not the case.

Reply
Options

15 Posts

08-17-2012

CH

11 Signins

139 Page Views

  • Posts: 15
  • Registered: ‎08-17-2012
  • Location: CH
  • Views: 139
  • Message 5 of 6

Re: UltraBay HD missing on wake up with Windows 10, T530

2016-09-26, 18:52 PM

All of this didn't help on my machine.

But the recent Windows 10 Anniversary Update seems to have solved the problem somehow.

0 person found this solution to be helpful.

This helped me too

Reply
Options

15 Posts

08-17-2012

CH

11 Signins

139 Page Views

  • Posts: 15
  • Registered: ‎08-17-2012
  • Location: CH
  • Views: 139
  • Message 6 of 6

Re: UltraBay HD missing on wake up with Windows 10, T530

2016-10-02, 16:14 PM

The problem is back again, without having changed anything manually. :smileysad:

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save