cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JoeAus
Paper Tape
Posts: 2
Registered: ‎08-07-2014
Location: Australia
Views: 66,170
Message 1 of 6

Unable to select UEFI/Legacy Boot in BIOS / Startup - ThinkPad T540p

I bought a ThinkPad 540p that comes with preloaded Windows 8.1. As I want to dual boot the machine I tried to select the Legacy Boot option in the BIOS/Startup tab, but I can't do anything as the option UEFI/Legacy Book is greyed out and locked in "UEFI Only". Below it there is an option called: -CSM Support that is also greyed out and selected as [No]. (below  these options there is a little note with an asterisk saying "Unselectable for Secure Boot").

 

How can I enable the UEFI/Legacy Boot option again in order to dual boot the computer? I want to be able to boot from USB or from the CD Drive.

 

 

 

Thank you very much for helping me out!

 

 

 

 

 

Community SeniorMod
Community SeniorMod
Posts: 7,035
Registered: ‎01-13-2008
Location: US
Views: 66,153
Message 2 of 6

Re: Unable to select UEFI/Legacy Boot in BIOS / Startup - ThinkPad T540p

Hello and welcome,

 

I'm not sure where it is in your BIOS (security tab maybe) but there should be an option to turn off secure boot.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

  Communities:   English    Deutsch    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Polski    Moto English

Highlighted
JoeAus
Paper Tape
Posts: 2
Registered: ‎08-07-2014
Location: Australia
Views: 66,113
Message 3 of 6

Re: Unable to select UEFI/Legacy Boot in BIOS / Startup - ThinkPad T540p

Hi Zoltanthegypsy,

 

You are an absolute wizard!

 

I followed your advice and in the Security tab I went to Secure Boot option at the bottom, Selected Disabled for the Secure Boot and that did the trick for me, then on the Startup tab the UEFI/Legacy Boot was enabled again.

 

 

Thank you very much for your help, that's really appreciated!

 

 

Cheers.

 

 

Joe 

mehtashailee2
What's DOS?
Posts: 2
Registered: ‎09-10-2015
Location: Ahmadabad
Views: 29,082
Message 4 of 6

Re: Unable to select UEFI/Legacy Boot in BIOS / Startup - ThinkPad T540p

didn't work for me
GailOleaga
Fanfold Paper
Posts: 10
Registered: ‎04-03-2017
Location: US
Views: 17,727
Message 5 of 6

Re: Unable to select UEFI/Legacy Boot in BIOS / Startup - ThinkPad T540p

Hi. I am not a computer pro but I just did this today. You have to change the secure boot to unsecured and then those options will appear. Hope this helps

 

Gail

positiveshishir
What's DOS?
Posts: 1
Registered: ‎08-14-2018
Location: NP
Views: 16,725
Message 6 of 6

Re: Unable to select UEFI/Legacy Boot in BIOS / Startup - ThinkPad T540p

it didnt work for me in Yoga 730 . Help me out i have lot of works to be done but couldnt do it 

Check out current deals!


Shop current deals

Top Kudoed Authors