cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
oktyp
Fanfold Paper
Posts: 3
Registered: ‎02-15-2019
Location: PL
Views: 3,579
Message 1 of 4

Unable to select UEFI/Legacy Boot in BIOS ThinkPad T480

I've been trying to select "Legacy Boot" bios option in my brand new T480 to no avail.

What i tried:

-setting Secure Boot Disabled,

-setting Reset to Setup Mode,

-setting OS Optimized Defaults Disabled / Load Setup Defaults,

-updated BIOS to 1.21 version.

 

UEFI/Legacy Boot is still greyed out and locked to UEFI Only so I cannot boot my usb disks.

 

My system came with Intel Optane installed and controller mode is set to RST mode.

 

 

oktyp
Fanfold Paper
Posts: 3
Registered: ‎02-15-2019
Location: PL
Views: 3,483
Message 2 of 4

Re: Unable to select UEFI/Legacy Boot in BIOS ThinkPad T480

When I contacted the lenovo service, they suggested that the BIOS in some recently manufactured ThinkPads could recognize whether the main system disk is formatted with GPT or MBR partition and lock the UEFI/Legacy option accordingly.
I cannot change the partion without loosing the installed system. Could anybody confirm that such BIOS behavior is possible? I think it makes no sense.
Lenovo Staff
Lenovo Staff
Posts: 5,851
Registered: ‎10-29-2009
Location: NC
Views: 3,472
Message 3 of 4

Re: Unable to select UEFI/Legacy Boot in BIOS ThinkPad T480


@oktyp wrote:

 

 

My system came with Intel Optane installed and controller mode is set to RST mode.


I think this is the reason.  Optane doesn't work in legacy mode, so you have to unconfigure Optane (and switch to SATA/AHCI mode) before you can turn on legacy mode.

DRSBharath
What's DOS?
Posts: 1
Registered: ‎08-31-2019
Location: IN
Views: 1,113
Message 4 of 4

Re: Unable to select UEFI/Legacy Boot in BIOS ThinkPad T480

In BIOS go to Config > Storage > Controller Mode > change to AHCI mode from RST mode

Now you can able to change secure boot setting and able to enable Legacy Mode.

Check out current deals!


Shop current deals

Top Kudoed Authors