cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
nuncio
Fanfold Paper
Posts: 10
Registered: ‎06-21-2008
Location: US
Views: 4,858
Message 1 of 7

Windows 8 Installation Disc Won't Load UEFI-only (T420s). Also does T420S support Secure Boot?

Question 1:

I am unable to load the Windows 8 Installation DVD in UEFI (only) mode on my T420s. As a result, I can only run the installer in Legacy mode (or both UEFI/Legacy which effectively means the same thing). This in turn means Windows 8 is installed in Legacy BIOS mode.  Any idea how to install it in UEFI mode?

 

I am using a DVD burned using the Windows utility from the Windows 8 64-bit ISO and have followed the instructions in HT073269, however I am unable to get to step 1 of the Windows 8 install after updating the BIOS, resetting to defaults, and switching to UEFI-only. On boot, after switching to UEFI-only, I am presented with a bootloader and prompted to select which drive to boot (DVDRAM or SSD). Selecting either makes the screen go blank for a moment and then returns back to the same screen with no result.

 

Since then I have searched these forums extensively and Googled Technet, Notebook Review, and other sites to no avail. I've tried several several ideas, including using diskpart > clean to get the SSD in raw status (per HT051844). That did not make a difference. I also tried converting a Legacy-BIOS install of Windows 8 to UEFI using CharlyAR's instructions on TechNet (linked from another thread here). That seemed to get me to a Windows Boot Loader but still errored out and Windows Repair was unable to fix it.

 

Any suggestions?

 

Also, question 2:  Does anyone know if the T420S support secure boot? If not, any idea if it's slated for a future firmware update?

ThorsHammer
Bit Torrent
Posts: 2,423
Registered: ‎04-08-2011
Location: US
Views: 4,853
Message 2 of 7

Re: Windows 8 Installation Disc Won't Load UEFI-only (T420s). Also does T420S support Secure Boot?

The T420s does not support secure boot.

 

What BIOS version is your T420s on?

Highlighted
nuncio
Fanfold Paper
Posts: 10
Registered: ‎06-21-2008
Location: US
Views: 4,847
Message 3 of 7

Re: Windows 8 Installation Disc Won't Load UEFI-only (T420s). Also does T420S support Secure Boot?

1.35, which I believe is the current release.

nuncio
Fanfold Paper
Posts: 10
Registered: ‎06-21-2008
Location: US
Views: 4,841
Message 4 of 7

Re: Windows 8 Installation Disc Won't Load UEFI-only (T420s). Also does T420S support Secure Boot?

So I've figured out a simple workaround to this -- installing from USB -- that appears to be working. But I'm still perplexed as to why the DVD installer wouldn't load. So I'll leave this open in case anyone can help me out with that, since I'd like to have the option to boot from DVD to reinstall or repair in the event of any future problems.

pleon
802.11n
Posts: 305
Registered: ‎12-01-2009
Location: Czech Republic
Views: 4,817
Message 5 of 7

Re: Windows 8 Installation Disc Won't Load UEFI-only (T420s). Also does T420S support Secure Boot?

I use Win8 on my T420s in UEFI mode. True is i installed from USB key, as i do not use DVD anymore. In BIOS i have UEFI only boot selected. I do not understand, what do you mean that secure boot does not work? In BIOS there is no special switch for that, but "UEFI only" works without any problems.
----------------------------------------------------
Lenovo T440s, 20AQ0067MC, Windows 8.1 Pro x64 UEFI, Samsung 840 EVO SSD 250 GB, 8 GB RAM
Lenovo T430s, 2356LQG, Windows 8.1 Pro x64 UEFI, Intel 520 SSD 180 GB, 8 GB RAM
Lenovo T420s, 4171-6SG, Windows 8 Pro x64 UEFI, Intel 320 SSD 120 GB, 8 GB RAM
Lenovo T400s, 2808-CYG, Windows 7 Ultimate x64
nuncio
Fanfold Paper
Posts: 10
Registered: ‎06-21-2008
Location: US
Views: 4,802
Message 6 of 7

Re: Windows 8 Installation Disc Won't Load UEFI-only (T420s). Also does T420S support Secure Boot?


@pleon wrote:
I use Win8 on my T420s in UEFI mode. [...] I do not understand, what do you mean that secure boot does not work? In BIOS there is no special switch for that, but "UEFI only" works without any problems.

Secure Boot is a certificate-based approach to preventing rootkits, not the same thing as UEFI. Although Secure Boot requires UEFI, having UEFI does not mean having the additional Secure Boot feature. If Secure Boot is available, typically there will be an option to enable it in the firmware configuration. Since the latest firmware for the T420S (ver. 1.35) does not have such an option, I suspect ThorsHammer is correct that Secure Boot is not (yet) supported on the T420S. I'm keeping my fingers crossed that Lenovo will tell us that a firmware update is on its way though.

ThorsHammer
Bit Torrent
Posts: 2,423
Registered: ‎04-08-2011
Location: US
Views: 4,773
Message 7 of 7

Re: Windows 8 Installation Disc Won't Load UEFI-only (T420s). Also does T420S support Secure Boot?


@nuncio wrote:

@pleon wrote:
I use Win8 on my T420s in UEFI mode. [...] I do not understand, what do you mean that secure boot does not work? In BIOS there is no special switch for that, but "UEFI only" works without any problems.

Secure Boot is a certificate-based approach to preventing rootkits, not the same thing as UEFI. Although Secure Boot requires UEFI, having UEFI does not mean having the additional Secure Boot feature. If Secure Boot is available, typically there will be an option to enable it in the firmware configuration. Since the latest firmware for the T420S (ver. 1.35) does not have such an option, I suspect ThorsHammer is correct that Secure Boot is not (yet) supported on the T420S. I'm keeping my fingers crossed that Lenovo will tell us that a firmware update is on its way though.


My understanding is that it will never support secure boot.  The secure boot support starts at Ivy Bridge and the T430s.

 

Check out current deals!


Shop current deals

Top Kudoed Authors