cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
valiant8086
Fanfold Paper
Posts: 23
Registered: ‎04-09-2018
Location: US
Views: 2,043
Message 1 of 3

new t480s is stuck at 3.4ghz when plugged in

Hi all.

 

I got a new T480s, i5 8350u. When I first set it up, the clock speed would bounce from 0.8ghz to 3.4ghz. However, somewhere between then and now I have it stuck at 3.4ghz even though minimum processor state when plugged in for my balanced power plan is set to 0 percent.

 

What did I do that might have caused this?

1. changed my power plans so that they're the typical power saver, balanced and max performance. They were previously power saver, airplane and balanced. Balanced has minimum processor state at 0 0, maximum at 100 100. Power saver has minimum processor state at 0 0, maximum at 0 85, max performance has minimum processor state at 100 100, maximum at 100 100.

 

note that the first number is battery in all these examples. As configured, when on power saver it should be able to go at about 1.4 to 1.7ghz or so while on power saver, but only go at 0.4ghz on power saver. Balanced is the only other one I really use much, I would expect it to max out at 2.4ghz or what ever on battery do to lenovo's voltage change while on battery, but 3.4ghz while plugged in. I'm not expecting to see it sitting right at 3.4ghz even with 0 percent cpu load though. It causes the processor to sit at around 113 degrees f, when it used to be 95 or so. I done broke it!

 

I also uninstalled the lenovo PM device a few times with windows configured not to install device drivers in order to try and prevent it from being reinstalled, attempting to get the processor voltage to not be limited to 22w thereby limiting the multi threaded cpu performance quite a bit. I did see an improvement doing that, I got 3.4ghz on all 8 threads until it got too hot, which honnestly didn't take long, but then it bounced between 2.6 and 2.9ghz rather than sitting firmly at 2.4ghz like it was doing before this change.

 

I did however, when noticing this issue, try to reinstall lenovo pm device, even though it was already showing up again in device manager in spite of my having disabled windows driver installations. I downloaded lenovo power management device from the Lenovo website and installed it. No improvement.

 

Maybe this'll help, fn+q doesn't seem to do anything? Apparently that should switch it back and forth between performance and power saver mode. Also, I had a thing in Lenovo Vamtage right out of the box that had a Lenovo Thermal cooling adjustment thing. It's gone now. did I accidentally uninstall it? I know I accidentally uninstalled Lenovo vantage and had to reinstall it form the app store. The **bleep** apps section in pc settings is allowing my screen reader to read the wrong item. I was trying to nuke a bunch of games I don't want and got a couple of things that weren't anything to do with games before I noticed it.

 

I'm blind and I use a screen reader, although that's not really going to make any difference with my questions.

 

 

 

 

Thanks all, hopefully I can just install something again and fix it. I did try the system update in Lenovo vantage though, I installed everything from the critical, recommended and optional categories, for a total of 12 items, don't know if system update would re-install something that was just completely removed though?

 

Thanks again

 

Geek_InsiDe
Punch Card
Posts: 19
Registered: ‎03-20-2018
Location: CH
Views: 1,997
Message 2 of 3

Re: new t480s is stuck at 3.4ghz when plugged in

Hi Valiant,

 

See this thread and the solution, I had the exact same bug when I bought my T580 some months ago. This bug also appears with the X1 Carbon.

 

https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/New-i7-8550U-T580-Cpu-always-at-full-clo...

 

And this is the X1 thread:

 

https://forums.lenovo.com/t5/ThinkPad-X-Series-Laptops/X1-Yoga-3rd-gen-CPU-frequency-pegged-at-max/t...

 

As you'll see, you have 2 solutions. One is faster, the other one seems, IMHO, proper so I chose this one and install a Vanilla Windows 10.

valiant8086
Fanfold Paper
Posts: 23
Registered: ‎04-09-2018
Location: US
Views: 1,956
Message 3 of 3

Re: new t480s is stuck at 3.4ghz when plugged in

Hi.

 

Thanks for your links. They were broken, but I was able to find the target of the second one with a google search. I didn't get around to looking at the first yet, but the second contains a solution that worked.

 

It seems Lenovo messed with the Windows default balanced power plan. On the thread the second link goes to, @someotherguy posted this as a possible fix

 

powercfg.exe /setACvalueindex OVERLAY_SCHEME_MAX SUB_PROCESSOR PERFEPP 0
powercfg.exe /setACvalueindex SCHEME_BALANCED SUB_PROCESSOR PERFEPP 33
powercfg.exe /setACvalueindex OVERLAY_SCHEME_MIN SUB_PROCESSOR PERFEPP 60

 

Pasting those 3 lines into cmd and hitting enter immediately solved my problem completely. Note that the problem is specifically with the balanced power plan or any plan derived from it. As such, the power saver plan I created myself and based on the power saver plan was working, but any plan I generated before this fix and based it on balanced still had the stuck at 3.4ghz problem.

 

After this fix, the balanced power plan itself behaves as expected. My cpu loves to putter along at 0.8ghz until I do something then it bounces all over the place as needed.

 

Worth noting, the power saver plan I generated myself to get stepping back until I found out about a better fix was very sluggish with my screen reader. It made my badass t480s feel like my little Atom cpu based windows tablet. And that was even after I set the max processor state to 100 percent on the power saver plan. However, the balanced plan that is now able to step the clock is more responsive even so, I don't know how to understand that.

 

Even if I move the power slider I only just learned about in the thread your second link goes to for best battery, I still have more responsiveness than I was getting with power saver based plans that had max processor state at 100 percent.

 

I'll try and mark your post as the solution after I send this reply. If I don't do it, it's because I can't figure out how to.

 

What's more, I think my computer is running even cooler than it was on power saver while bieng more responsive than the power saver based plan, weird. 108 degrees f while sitting on my lap and with me typing away at full speed and a word processor open, two sype for desktop chat windows, 4 tabs in chrome and my screen reader. Before this , I was around 113f just sitting on the desktop not doing anything, with 0 and 1 percent cpu load.

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors