cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cxzchen
Paper Tape
Posts: 4
Registered: ‎09-14-2011
Location: Toronto,Canada
Views: 5,173
Message 1 of 12

t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G

Hi Folks,

 

I just got my thinkpad t420s (4170CTO) two weeks ago. one of the features I am exicted about this wonderful laptop is USB 3.0 support. I just bought Hitach TOURO MOBILE PRO 750G with USB 3.0 . But Windows 7 explorer does not recongnized the usb hard drive when I plugged it into the USB 3.0 port. It works with other two USB 2.0 ports. I updated the USB 3.0 driver and restarted the system. the problem still stays there. Windows explorer does not detect it !Smiley Sad

any help is appreciated.

 

ThorsHammer
Bit Torrent
Posts: 2,423
Registered: ‎04-08-2011
Location: US
Views: 5,165
Message 2 of 12

Re: t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G

It seems the number of reports of drive and drive enclosure incompatibilities keeps going up.  Someone needs to get to the bottom of this.  Is it the chipset in the ThinkPad or the industry?

 

 

cxzchen
Paper Tape
Posts: 4
Registered: ‎09-14-2011
Location: Toronto,Canada
Views: 5,155
Message 3 of 12

Re: t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G

thanks for the reply. The hard drive is 7200 RPM. When I connected my IPod (USB 2.0) to the USB 3.0 port, it works very well

withnail
Ctrl-Alt-Del
Posts: 20
Registered: ‎05-27-2011
Location: UK
Views: 5,144
Message 4 of 12

Re: t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G

I've had similar issues, but USB3 works great with this enclosure: http://www.maplin.co.uk/probox-usb-3.0-portable-enclosure-506618. See the other thread I started on this: http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T420s-USB-3-port-operating-at-USB-2-speed/m...

 

Good luck getting a solution!

cxzchen
Paper Tape
Posts: 4
Registered: ‎09-14-2011
Location: Toronto,Canada
Views: 5,141
Message 5 of 12

Re: t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G

my case is different from yours. my HitachI USB 3.0 could not be detectd by Windows when I connecte to the USB 3.0 port.

what is the RPM of your hard drive you put into the enclosure ?

thanks for the reply

withnail
Ctrl-Alt-Del
Posts: 20
Registered: ‎05-27-2011
Location: UK
Views: 5,121
Message 6 of 12

Re: t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G

I'm not certain (using the drive now so can't open it up) but I'm pretty sure it's a WD Blue 7200. I've also used a little 100GB 5400 drive successfully.

richardliu52
What's DOS?
Posts: 1
Registered: ‎10-08-2011
Location: Canada/China
Views: 5,027
Message 7 of 12

Re: t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G

I just got  the Hitachi TOURO MOBILE PRO 750G today and it had the same issue on my T420s.

Just got it fixed.

 

This is what you need to do:

1. Download the newest firmware: GO TO

http://www.station-drivers.com/page/nec.htm

get the"Version 2.1.25.0 Pour Windows Xp/Vista/7 32/64bits"

 

2.  Config USB 3.0 Host Controller to make USB 3.0 work properly:

After installing the updated driver, you will find a new program in start-> all programs->Renesas Electronic which is called USB 3.0 Host Controller Utility.

 

Open it up, you should be able to see an unchecked box "Disable USB 3.0 power management functions"

 

Check that box.

Done

 

Good luck.

 

 

 

 

cxzchen
Paper Tape
Posts: 4
Registered: ‎09-14-2011
Location: Toronto,Canada
Views: 5,013
Message 8 of 12

Re: t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G

just tried. it works. thank you so much. by the way, how fast is ur USB 3.0 ? it is about 110MB/Sec on my T420s. it is much faster than USB 2.0, but not as fast as I expected.

thanks again

JRHARLOW
What's DOS?
Posts: 3
Registered: ‎06-21-2011
Location: UK
Views: 4,931
Message 9 of 12

Re: t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G

Wow, this totally works.

Thanks

bogatyr
802.11n
Posts: 225
Registered: ‎04-20-2011
Location: UNITED STATES
Views: 4,909
Message 10 of 12

Re: t420s USB 3.0 port does not work with Hitach TOURO MOBILE PRO 750G


@cxzchen wrote:

just tried. it works. thank you so much. by the way, how fast is ur USB 3.0 ? it is about 110MB/Sec on my T420s. it is much faster than USB 2.0, but not as fast as I expected.

thanks again



That is most likely hitting the drives max speed which is the bottleneck now and not the port. Replace the drive in the external enclosure with a SSD drive and you would most likely see a performance boost.

Check out current deals!


Shop current deals

Top Kudoed Authors