English Community

ThinkPad NotebooksThinkPad; T61 and prior T series plus Other Legacy ThinkPads
All Forum Topics
Options

3 Posts

10-27-2009

United States

4 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎10-27-2009
  • Location: United States
  • Views: 35
  • Message 1 of 14

Bluetooth radio defaults to Off state

2009-10-27, 14:56 PM

I just updated my Thinkpad T61 from Windows Vista to Windows 7. I followed these steps:

  1. Update BIOS
  2. Install Windows 7
  3. Install Update Manager and run it to get all the current drivers.
     

Most things are working fine, except for an annoyance with the Bluetooth radio.

 

When the computer is rebooted or waken from sleep, the Bluetooth radio is off. We have to use Fn-F5 to turn it back on. We use a Bluetooth mouse with the notebook. Having to manually turn on the radio every time the laptop goes to sleep is a real pain.

 

With Windows Vista, the radio was on by default. I cannot find where to fix this problem. Can anybody help me?

Reply
Options

455 Posts

04-05-2008

US

799 Signins

10488 Page Views

  • Posts: 455
  • Registered: ‎04-05-2008
  • Location: US
  • Views: 10488
  • Message 2 of 14

Re: Bluetooth radio defaults to Off state

2009-10-27, 18:19 PM

Did you check to see if the BIOS default is off?  Not sure why swithching OS should have changed this but worth checking.

Keith
Currently 2xT460, 4xT430, Ideapad K1, H520S,
Formerly 1x600E, 1xT40, 1xT41, 2xT42, 2xT61p, 1xT420




Reply
Options

24 Posts

04-21-2008

USA

261 Signins

3163 Page Views

  • Posts: 24
  • Registered: ‎04-21-2008
  • Location: USA
  • Views: 3163
  • Message 3 of 14

Re: Bluetooth radio defaults to Off state

2009-10-28, 0:13 AM

I have the same issue. Bluetooth defaults to off and I have to turn it on every single time. Also running a T61p x64.

 

Thanks,

 

Michel

Reply
Options

3 Posts

10-27-2009

United States

4 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎10-27-2009
  • Location: United States
  • Views: 35
  • Message 4 of 14

Re: Bluetooth radio defaults to Off state

2009-10-30, 4:17 AM

 


wrote:

Did you check to see if the BIOS default is off?  Not sure why swithching OS should have changed this but worth checking.


 

The BIOS has a security setting for the bluetooth radio, which is enabled. I think that setting, if disabled, would prevent the radio from being turned on. I can turn the radio on, it just reverts to being off every time the computer is rebooted or wakes from sleep.

 

Reply
Options

4 Posts

11-13-2009

United States

10 Signins

89 Page Views

  • Posts: 4
  • Registered: ‎11-13-2009
  • Location: United States
  • Views: 89
  • Message 5 of 14

Re: Bluetooth radio defaults to Off state

2009-11-13, 22:13 PM

Not sure if you found a solution to this problem yet but I have a work around that might help:

 

Step 1.  Ensure you have the Lenovo Hotkey software installed and functioning properly (i.e., if you press Fn-F5 are you presented with the Lenovo wireless settings for power radios window?)

 

Step 2.  Locate the file, TpFnF5.exe on your system.  On my system, the file was located in:

 

"C:\Program Files\Lenovo\HOTKEY"

Copy this path as you will need it later on.

 

Step 3.  Open the Windows Task Scheduler.

 

Step 4.  Create a new basic task by selecting the "Action->Create Basic Task..." menu item.

 

Step 5.  When the new task wizard appears, enter a name like:

 

"Enable Bluetooth Radio"

 and  a description like:

 

"This task will automatically turn on the Bluetooth radio."

Then click the "Next" button.

 

Step 6.  The next screen will ask you for the trigger and will say, "When do you want the task to start?"  Select the "When the computer starts" option and click the "Next" button.

 

Step 7.  The next screen will ask, "What action do you want the task to perform?"  Select the:

 

"Start a program"

option and click the "Next" button.

 

Step 8.  You'll be presented with an edit control that will ask you to specify the program/script.  Enter the path that you copied in step 2 and append:

 

\TpFnF5.exe 

to the path.  The value in the box should look something like this (it may vary slightly depending on where you installed the Lenovo Hotkey software):

 

"C:\Program Files\Lenovo\HOTKEY\TpFnF5.exe"

(Be sure to put the quotes around the file path)

 

In the "arguments" box, enter the following:

 

/BTON

Now click the "Next" button.

 

Step 9.  On the next screen, check the:

 

"Open properties dialog for this task when I click finish"

option and then click "Finish"

 

Step 10.  When the properties dialog appears, select the radio button labeled,

 

"Run whether user is logged in or not"

Step 11.  Under the "Configure for" option, select,

 

"Windows 7, Windows Server 2008 R2"

and then click "Ok".

 

Reboot and your bluetooth radio should be active.

 

I had originally put this into the registry under HKLM\Software\Microsoft\Windows\CurrentVersion\Run but those programs don't launch until the user logs into the system.  I wanted the bluetooth radio active for my logon strictly so I could use my bluetooth mouse.

 

Also, there are other command line arguments that can be used with the TpFnF5.exe executable.  According to Lenovo, they are as follows:

 

/WLON, /WLOFF    Turn on/off internal 802.11.
/BTON, /BTOFF Turn on/off internal Bluetooth.
/WANON, /WANOFF Turn on/off internal WAN.
/UWBON, /UWBOFF Turn on/off internal UWB.
/ALLON, /ALLOFF Turn on/off any radio at once

Anyhow, I hope this helps.

 

Additional note:

I just realized, you'll need to add the "On workstation unlock of any user" trigger for this task.  This is required if you want the bluetooth radio to be enabled after awakening the machine from sleep.

Reply
Options

4 Posts

11-16-2009

San Jose

6 Signins

71 Page Views

  • Posts: 4
  • Registered: ‎11-16-2009
  • Location: San Jose
  • Views: 71
  • Message 6 of 14

Re: Bluetooth radio defaults to Off state

2009-11-16, 16:36 PM

Thanks WickedAx! That worked perfectly.

 

Instructions were clear except the very last bit.

 

"Additional note:

I just realized, you'll need to add the "On workstation unlock of any user" trigger for this task.  This is required if you want the bluetooth radio to be enabled after awakening the machine from sleep."

 

Here is my lengthier explanation:

1. After creating the task, click on "Task Schedule Library" menu item on the left.

2. Your new task should be there. Double click on it.

3. Click on the "Triggers" tab in the pop-up window.

4. Click the "New.." button near the bottom.

5. Choose "On Workstation unlock" from the drop-down at the top.

6. I left the default settings. Click "OK"

7. The new trigger should be there. Click "OK"

8. I needed to type in my password for the user. You may or may not need to do this.

 

Thanks again.

 

Reply
Options

4 Posts

11-13-2009

United States

10 Signins

89 Page Views

  • Posts: 4
  • Registered: ‎11-13-2009
  • Location: United States
  • Views: 89
  • Message 7 of 14

Re: Bluetooth radio defaults to Off state

2009-11-16, 20:54 PM

Hehehe...Yeah, I realized that last part as I was getting ready to head out so I had to make it quick.  Thanks for updating the thread with more thorough instructions!  I'm glad it worked for you.

 

I believe the root of this problem is a Lenovo driver issue.  I've been noticing that after my machine resumes from sleep that I'm getting a notification in the system log from BTHUSB that reads,

 

 

The local Bluetooth adapter has failed in an undetermined manner and will not be used. The driver has been unloaded.

I'm guessing the TpFnF5 executable checks for the presence of the driver module and reloads it if necessary, which is why the above fix works.  This may be a combination of the latest BIOS update coupled with faulty drivers.  I really hope Lenovo continues to improve the Windows 7 drivers for the T60 and T60p series and doesn't drop support.

 

Reply
Options

4 Posts

11-16-2009

San Jose

6 Signins

71 Page Views

  • Posts: 4
  • Registered: ‎11-16-2009
  • Location: San Jose
  • Views: 71
  • Message 8 of 14

Re: Bluetooth radio defaults to Off state

2009-11-16, 23:18 PM

 


I believe the root of this problem is a Lenovo driver issue.  I've been noticing that after my machine resumes from sleep that I'm getting a notification in the system log from BTHUSB that reads,

 

 

The local Bluetooth adapter has failed in an undetermined manner and will not be used. The driver has been unloaded.

I'm guessing the TpFnF5 executable checks for the presence of the driver module and reloads it if necessary, which is why the above fix works.  This may be a combination of the latest BIOS update coupled with faulty drivers.  I really hope Lenovo continues to improve the Windows 7 drivers for the T60 and T60p series and doesn't drop support.

 


 

 

I get the same error.

 

As for the Drivers? It seems as if they (Lenovo) are still fixing drivers.

I still see plenty of updated drivers and considering the popularity of Win 7 and the T series, I would think they keep up with the support.

(Oops, my optimism is showing)

Reply
Options

3 Posts

11-20-2009

London

13 Signins

57 Page Views

  • Posts: 3
  • Registered: ‎11-20-2009
  • Location: London
  • Views: 57
  • Message 9 of 14

Re: Bluetooth radio defaults to Off state

2009-11-24, 16:21 PM

I'm getting the same problem too with my T61.

 

If I restart the computer or put it into sleep mode, then there's no Bluetooth when I start back up.

 

I have to use Fn+F5 to turn it on again.

 

It's also creating an error in Event Viewer: "The local Bluetooth adapter has failed in an undetermined manner and will not be used. The driver has been unloaded."

 

If I shut the computer down, then boot it up, it appears to be ok.

Reply
Options

2 Posts

12-31-2009

Albuquerque

9 Signins

42 Page Views

  • Posts: 2
  • Registered: ‎12-31-2009
  • Location: Albuquerque
  • Views: 42
  • Message 10 of 14

Re: Bluetooth radio defaults to Off state

2009-12-31, 3:29 AM

Same problem with my T60. Worked fine with XP Pro, worked fine with Win 7 Beta, worked fine with Win 7 RC, worked fine after I did clean install of Win 7 Pro. Sometime during the past few weeks I started having this problem. It is a pain because I use a bluetooth mouse. I tried reverting back to an older backup, but still have problem. I don't know what I did to cause it.....certainly something!

Will try workaround next

T60 Win 7, Think Centre XP Pro, Intellistation M Pro XP Pro, PC300PL Linux Ubuntu 9.04
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms