English Community

ThinkPad NotebooksThinkPad; T61 and prior T series plus Other Legacy ThinkPads
All Forum Topics
Options

14 Posts

03-24-2012

USA

17 Signins

145 Page Views

  • Posts: 14
  • Registered: ‎03-24-2012
  • Location: USA
  • Views: 145
  • Message 1 of 5

How to force the "Bluetooth Communications Port" to be one of COM1 to COM8 ports?

2012-12-21, 23:28 PM
Dear Lenovo Community, Happy Holidays to you all and wish you a great happy new year. Recently purchased a Bluetooth OBDII device and have difficulty making it to work with its provided software on my T61 (running original XP Home). My short story and question/problem is that I can open "My Bluetooth Places" and pair with the OBDII device as an "OBDII SPP Dev", but my T61 assigns serial port COM19 to it. The OBDII software which came with the device only can let user set to one of the COM1 to COM8 ports and in the properties of Bluetooth pairing, there is no way that I can select which COM port to use. I looked at the Device Manager and I do see these COM port assignments: COM4,5,6,7: Sierra Wireless (the HSDA modem in the laptop which I have never used BTW) COM 9,10,11,12,13,14,15,16,17: Bluetooth Serial Port COM 18, 19: Bluetooth Communications Port and I don't see anything for COM1,2,3, and 8 My question is how to force the computer/OS to assign one of the COM1 to COM8 ports to my device upon pairing? Can I disable the Sierra Wireless model from the COM ports list and hope this will happen? Thanks for your help and inputs beforehand. Regards, AL
Reply
Options

1302 Posts

12-06-2012

Raleigh, NC

545 Signins

33643 Page Views

  • Posts: 1302
  • Registered: ‎12-06-2012
  • Location: Raleigh, NC
  • Views: 33643
  • Message 2 of 5

Re: How to force the "Bluetooth Communications Port" to be one of COM1 to COM8 ports?

2012-12-26, 14:50 PM

Hi, AL_K

 

Have you attempted to change the port number in device manager itself? If you navigate to Device Manager and open the list of Ports, you can right-click on the device you wish to assign a different port number. After right-clicking, click Properties. There should be a tab called Port Settings. In here, you should find a setting to manually assign a port number.

 

Good luck, and let me know how it goes,

Adam

______________________________________________________________________________________________________________
Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution!" This will help the rest of the community with similar issues identify the verified solution and benefit from it.
Reply
Options

14 Posts

03-24-2012

USA

17 Signins

145 Page Views

  • Posts: 14
  • Registered: ‎03-24-2012
  • Location: USA
  • Views: 145
  • Message 3 of 5

Re: How to force the "Bluetooth Communications Port" to be one of COM1 to COM8 ports?

2012-12-27, 4:38 AM
Hi Adam,
Thanks for your help, I saw this while desperately trying all options, I guess I tried to play with it, but I'll give it another try when I am inside the car. The equipment that I am trying to connect to is an ODBII reader through Bluetooth inside the car. Will report back here. Thanks again for your help.
Reply
Options

1302 Posts

12-06-2012

Raleigh, NC

545 Signins

33643 Page Views

  • Posts: 1302
  • Registered: ‎12-06-2012
  • Location: Raleigh, NC
  • Views: 33643
  • Message 4 of 5

Re: How to force the "Bluetooth Communications Port" to be one of COM1 to COM8 ports?

2012-12-27, 20:17 PM

Hi again, AL_K

 

You're greatly welcome for the help. Let me know how it goes!

 

Adam

______________________________________________________________________________________________________________
Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution!" This will help the rest of the community with similar issues identify the verified solution and benefit from it.
Reply
Options

71 Posts

08-26-2008

USA

72 Signins

1342 Page Views

  • Posts: 71
  • Registered: ‎08-26-2008
  • Location: USA
  • Views: 1342
  • Message 5 of 5

Re: How to force the "Bluetooth Communications Port" to be one of COM1 to COM8 ports?

2013-07-29, 21:25 PM

I have the same problem on a T61p and W500.  Did you ever find out how to do this?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete