Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad; T61 and prior T series plus Other Legacy ThinkPads
All Forum Topics
Options

6 Posts

12-16-2008

USA

16 Signins

108 Page Views

  • Posts: 6
  • Registered: ‎12-16-2008
  • Location: USA
  • Views: 108
  • Message 1 of 28

Intel(R) 82566MM Gigabit Network Connection turmoil

2008-12-16, 2:31 AM

I just purchase a T61 with the Intel(R) 82566MM Gigabit Network adapter and it works if I reboot the machine or manually reset the adapter, but if the machine goes into sleep mode or suspend mode - when it wakes up it doesn't connect. I have to reset the adapter manually again. I'm using a 5-Port Gigabit Ethernet switch into a 100M cable/dsl router. The T61 is running Windows Vista Business SP1. Wireless works okay so it's just limited to the hard connection.

 

Thanks for any help

Reply
Options

280 Posts

11-11-2008

Canada

629 Signins

35617 Page Views

  • Posts: 280
  • Registered: ‎11-11-2008
  • Location: Canada
  • Views: 35617
  • Message 2 of 28

Re: Intel(R) 82566MM Gigabit Network Connection turmoil

2008-12-16, 2:37 AM

Welcome to the forum!

 

Try the following procedure: Open the Control panel --> Click on System --> Hardware --> Device manager --> Right-click on your network adapter --> Properties --> Power management --> uncheck "Allow the computer to turn off this device to save power"

 

Thank you

__________________________________________
John B @ forum.notebookreview.com
Reply
Options

6 Posts

12-16-2008

USA

16 Signins

108 Page Views

  • Posts: 6
  • Registered: ‎12-16-2008
  • Location: USA
  • Views: 108
  • Message 3 of 28

Re: Intel(R) 82566MM Gigabit Network Connection turmoil

2008-12-16, 2:46 AM

Thanks, John. But I already covered that one. I've been around computers since the 80s (DOS) so I know the OS fairly well. It's either a bad card or something new that I'm just not seeing with Vista.

 

Tom

Reply
Options

280 Posts

11-11-2008

Canada

629 Signins

35617 Page Views

  • Posts: 280
  • Registered: ‎11-11-2008
  • Location: Canada
  • Views: 35617
  • Message 4 of 28

Re: Intel(R) 82566MM Gigabit Network Connection turmoil

2008-12-16, 2:49 AM
What if you open the Event viewer to see if you can find some errors there ?
__________________________________________
John B @ forum.notebookreview.com
Reply
Options

6 Posts

12-16-2008

USA

16 Signins

108 Page Views

  • Posts: 6
  • Registered: ‎12-16-2008
  • Location: USA
  • Views: 108
  • Message 5 of 28

Re: Intel(R) 82566MM Gigabit Network Connection turmoil

2008-12-16, 3:12 AM

I received a series of warnings about not obtaining an IP address from the DHCP and the following (2) Errors listed below. The DHCP is the cable/router which is serving other computers on the network and they are working fine. The situation is limited to just the T61. I'm thinking it is the gigabit ethernet card not playing nice with the 100M router, but that's just a guess.

 

 

Log Name:      System
Source:        TPM
Date:          12/15/2008 10:05:36 PM
Event ID:      13
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Thomas-PC
Description:
The device driver for the Trusted Platform Module (TPM) encountered a non-recoverable error in the TPM hardware, which prevents TPM services (such as data encryption) from being used. For further help, please contact the computer manufacturer.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="TPM" />
    <EventID Qualifiers="49158">13</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2008-12-16T03:05:36.411Z" />
    <EventRecordID>40231</EventRecordID>
    <Channel>System</Channel>
    <Computer>Thomas-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Binary>1B00000001000000000000000D0006C0000000000208000000000000000000000000000000000000</Binary>
  </EventData>
</Event>

 

Log Name:      System
Source:        Microsoft-Windows-TBS
Date:          12/15/2008 10:05:36 PM
Event ID:      516
Task Category: None
Level:         Error
Keywords:     
User:          LOCAL SERVICE
Computer:      Thomas-PC
Description:
An error occurred while communicating with the TPM.  The driver returned 0x8007045d.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-TBS" Guid="{51480c1a-90aa-416e-98fd-4c11f735349b}" />
    <EventID>516</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8000000000000000</Keywords>
    <TimeCreated SystemTime="2008-12-16T03:05:36.411Z" />
    <EventRecordID>40232</EventRecordID>
    <Correlation />
    <Execution ProcessID="1524" ThreadID="4064" />
    <Channel>System</Channel>
    <Computer>Thomas-PC</Computer>
    <Security UserID="S-1-5-19" />
  </System>
  <EventData>
    <Data Name="ErrorCode">0x8007045d</Data>
  </EventData>
</Event>

Reply
Options

280 Posts

11-11-2008

Canada

629 Signins

35617 Page Views

  • Posts: 280
  • Registered: ‎11-11-2008
  • Location: Canada
  • Views: 35617
  • Message 6 of 28

Re: Intel(R) 82566MM Gigabit Network Connection turmoil

2008-12-16, 3:15 AM
When you start your computer, does it freeze for approx. 1 minute while loading the desktop (or is there a period of time during which you can't access Internet)?
__________________________________________
John B @ forum.notebookreview.com
Reply
Options

6 Posts

12-16-2008

USA

16 Signins

108 Page Views

  • Posts: 6
  • Registered: ‎12-16-2008
  • Location: USA
  • Views: 108
  • Message 7 of 28

Re: Intel(R) 82566MM Gigabit Network Connection turmoil

2008-12-16, 3:25 AM
On boot, once the password is entered, the desktop comes up fairly quickly. I have the sidebar accessing the internet gadgets and they come online within 1 minute. So, no, there are no freeze-ups on startup. This problem only rears it's ugly head upon coming out of a sleep or suspend mode.
Reply
Options

6 Posts

12-16-2008

USA

16 Signins

108 Page Views

  • Posts: 6
  • Registered: ‎12-16-2008
  • Location: USA
  • Views: 108
  • Message 8 of 28

Re: Intel(R) 82566MM Gigabit Network Connection turmoil

2008-12-17, 23:03 PM
How can I escalate this to get a definitive answer?
Reply
Options

5 Posts

02-02-2009

Newark

9 Signins

26 Page Views

  • Posts: 5
  • Registered: ‎02-02-2009
  • Location: Newark
  • Views: 26
  • Message 9 of 28

Re: Intel(R) 82566MM Gigabit Network Connection turmoil

2009-02-02, 19:34 PM

I too have an Intel 82566MM Gigabit ethernet card -- on my system, it refuses to communicate to the network - it will not receive a DHCP address, or anything else meaningful.  My Lenovo X60 has no trouble communicating on the same network & cable. 

 

I have gone through a driver update (both on the Lenovo site, as well as on Intel's site) to no avail. 

 

Last week, I returned my system, and they swapped out the systemboard (or so says the ticket) - I didn't have the opportunity to record the mac address, so I'm not entirely certain whether or not they did swap it out.  Symptoms are the same - no network assignments, no network communication. 

 

Another oddity is that the ethernet link light (green) remains active regardless of whether or not the network cable is inserted.  Support immediately recognized this as an issue, but I'm finding it hard to believe that two system boards will have the same issue here!  Is there a systemic problem with this card or what?

 

Lenovo has no cross-shipping apparently, so this will be the second week I am without my hardware. Is there anyone in support reading this???

 

Golan.

Reply
Options

156 Posts

12-17-2008

canada

300 Signins

2205 Page Views

  • Posts: 156
  • Registered: ‎12-17-2008
  • Location: canada
  • Views: 2205
  • Message 10 of 28

Re: Intel(R) 82566MM Gigabit Network Connection turmoil

2009-02-02, 20:29 PM

i had the same problem on Vista Ultimate x64, ie, wired nic would not reconnect after resuming from suspend (unless it was manually disabled, then re-enabled, either via the device manager or network connections).

i fixed the problem by downloading/installing the 82566 Gigabit Ethernet drivers via Windows Update (instead of using the drivers from Lenovo).  to receive driver updates via WU or MU, you have to enable the Recommended updates checkbox in Windows Update, Change Settings.

 

you can also try the latest 82566MM drivers from Intel

the driver version that is working ok on my system is: Intel 9.7.255.0, dated: 2008-03-05
(open windows device manager, network adapters, 82566MM, driver tab)

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms