Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad; T61 and prior T series plus Other Legacy ThinkPads
All Forum Topics
Options

26 Posts

11-17-2008

Poland

47 Signins

326 Page Views

  • Posts: 26
  • Registered: ‎11-17-2008
  • Location: Poland
  • Views: 326
  • Message 1 of 7

T60 - volume buttons not working after last system update

2014-04-29, 7:44 AM

Hi,

 

after the last system update, volume buttons in my ThinkPad T60 (Win XP) just stopped working, but the blue ThinkVantake button is all ok. I think this problem is quite common, but none of solutions I've found worked on my laptop. I've tried running System Update a few times, manually installing HotKey Utilities with some patch, Power Management Driver - nothing works. Any idea?

//Bartek
//Y530 owner
Reply
Options

2253 Posts

01-02-2011

United States of America

8347 Signins

51782 Page Views

  • Posts: 2253
  • Registered: ‎01-02-2011
  • Location: United States of America
  • Views: 51782
  • Message 2 of 7

Re: T60 - volume buttons not working after last system update

2014-04-29, 10:21 AM

did you install driver updates provided by windows update?  if so, I recommend you remove them and only use updates provided by lenovo. Windows update often provides drivers from the manufacture of the components used which would be fine if it was for an independent piece of hardware, but on a laptop the components are often customized and integrated with others so you need drivers specifically designed for the laptop you're using.

 

Another suggestion would be to use system restore to revert to a date before this problem appeared then carefully apply each update  making a restore point before each and if this problem happens again you'll know exactly what caused it.

ThinkPad W-510 i7-820QM(1.73-3.06GHz) Quad Core... ThinkPad T500, T9900, 8gb SSD...FrankNpad T-60p/61p (X9000 2.8ghz) 8gb SSD ips FlexView...ThinkPad T-61p (T9300 2.5ghz) 8gb ram...Thinkpad X-61 Tablet 8gb ram.
Reply
Options

26 Posts

11-17-2008

Poland

47 Signins

326 Page Views

  • Posts: 26
  • Registered: ‎11-17-2008
  • Location: Poland
  • Views: 326
  • Message 3 of 7

Re: T60 - volume buttons not working after last system update

2014-04-29, 10:26 AM

Thanks for your reply.

 

I believe this is not a windows update problem, rather Lenovo software. as "System Update" above I mentioned running the ThinkVantage System Update Utility, which installed some upgraded drivers and software.

 

Meantime, I've reinstalled Lenovo Power Management Driver again and the three volume buttons started working, but the OSD showing volume status is not displayed...

//Bartek
//Y530 owner
Reply
Options

2253 Posts

01-02-2011

United States of America

8347 Signins

51782 Page Views

  • Posts: 2253
  • Registered: ‎01-02-2011
  • Location: United States of America
  • Views: 51782
  • Message 4 of 7

Re: T60 - volume buttons not working after last system update

2014-04-29, 11:20 AM

 

I havn't personally used XP in quite some time so I can't say if there was any new bugs in a driver update but I have seen similar issues where conflicting updates were installed. If you haven't installed anything outside of lenovo system update then my advice wouldn't apply to you. 

 

Diagnosing in a forum post isn't easy but maybe you'll get lucky and another member will have experienced the same problem. Otherwise the only thing I can suggest is to revert back to a restore point when it worked properly and then proceed with caution with each update installing only one at a time.

 

 

ThinkPad W-510 i7-820QM(1.73-3.06GHz) Quad Core... ThinkPad T500, T9900, 8gb SSD...FrankNpad T-60p/61p (X9000 2.8ghz) 8gb SSD ips FlexView...ThinkPad T-61p (T9300 2.5ghz) 8gb ram...Thinkpad X-61 Tablet 8gb ram.
Reply
Options

26 Posts

11-17-2008

Poland

47 Signins

326 Page Views

  • Posts: 26
  • Registered: ‎11-17-2008
  • Location: Poland
  • Views: 326
  • Message 5 of 7

Re: T60 - volume buttons not working after last system update

2014-05-05, 11:11 AM

So far, reinstalling the latest audio, power management, system interface drivers and on-screen display changed nothing. volume buttons do work, but have no connection with system tray volume icon and nothing is displayed on the screen when changing volume...

//Bartek
//Y530 owner
Reply
Options

146 Posts

05-09-2008

Germany, Stuttgart

367 Signins

2012 Page Views

  • Posts: 146
  • Registered: ‎05-09-2008
  • Location: Germany, Stuttgart
  • Views: 2012
  • Message 6 of 7

Re: T60 - volume buttons not working after last system update

2014-05-25, 15:07 PM

Hi.

 

You need two things (drivers): the Lenovo System Interface Driver (1.05) and the On Screen Display Driver (6.67.10).

I provide in brackets, above, the version numbers that I use on a T60 and work just fine.

 

My advice would be to search the package containing these, under the Lenovo Support portal and update your system to these, even if it means uninstalling the current versions that you have now (even if they are newer).

 

.. remember - newer does not mean always better .. AND

.. don't try to "fix" it, if it works  ;)

 

Best of luck.

W500 / T61p / T61 / R60
Reply
Options

26 Posts

11-17-2008

Poland

47 Signins

326 Page Views

  • Posts: 26
  • Registered: ‎11-17-2008
  • Location: Poland
  • Views: 326
  • Message 7 of 7

Re: T60 - volume buttons not working after last system update

2014-07-18, 12:52 PM

I've already had the System Interface Driver in correct version, but my On-Screen Display Driver was newer (6.71.00).

 

I've found a 2.30i version of the OSDD for some old ThinkPads (theoretically not for T60) and it works just fine.

 

Thanks!

//Bartek
//Y530 owner
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms