cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mikeh23
What's DOS?
Posts: 1
Location: New York
Views: 29,817
Message 1 of 9

BIOS error 2010 at startup of T43 after installing new Western Digital hard drive

Just bought a used Thinkpad T43  model 2668-Y4F from IBM. Did an image backup of the hard disk and replaced it with a new Western Digital 80GB hard drive.When machine boots, I get a BIOS error 2010:

 

"The hard disk drive you have installed has not been qualified for use in this computer or does not have the latest firmware.  Using a drive that is not qualified may cause compatibility issues and potential data loss." 

 

The hard disk is fine. Spinrite liked it. After booting Linux off a CD, I can see all the files on the hard disk.

 

After ignoring this message, the OS won't boot, it hangs at a blank screen, but that may be another issue relating perhaps to the disk image utility. 

 

Is this BIOS message important? 

What does it mean? 

 

Bios is version 1.24 from November 7, 2005. Also IDed as 1YET59WW. 

Thanks

Guru
Posts: 7,626
Location: USA
Views: 29,778
Message 2 of 9

Re: BIOS error 2010 at startup of T43 after installing new Western Digital hard drive

Welcome to the forum!

 

If you have the latest BIOS, you can choose the option for the machine to continue booting after the error message.

 

More on this subject here:

 

 http://forum.thinkpads.com/viewtopic.php?f=2&t=11059

 

Hope this helps.

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.
shady123
What's DOS?
Posts: 1
Location: NH
Views: 28,109
Message 3 of 9

Re: BIOS error 2010 at startup of TTT after installing new Western Digital hard drive

I had the same problem with XP all I had to do was run the a MBA fix and boot fix. After I did this I still got the 2010 error but once I got passed that error screen the system did startup I am still trying fix the 2010 error but I can continue pass it.  

Guru
Posts: 7,626
Location: USA
Views: 28,097
Message 4 of 9

Re: BIOS error 2010 at startup of TTT after installing new Western Digital hard drive

There is no known "one size fits all" fix for "2010 error".


If you have an older but IBM-issued drive, a firmware update might work.


On certain other drives, a BIOS downgrade (not recommended) to version 1.03 or older might work as well.


On most newer WD, Seagate or Hitachi drives none of the above helps.


Good luck.

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.
sw40rpalm
What's DOS?
Posts: 2
Location: NY city
Views: 23,552
Message 5 of 9

Re: BIOS error 2010 at startup of TTT after installing new Western Digital hard drive

I started with a job model 600 and have worked my way up by buying rebuildable T series on ebay and fixing or replacing bad part so that I have several of each model. I can't seem to want to put them back on ebay for sale after their fixed and working.  :banana:

Now puting in the WD 320Gig HD in the T43's, T42's and T41's and I run into the 2010 error only in the T43's. It has a 6/9/2006 Bios the latest listed. Guess What- The T42's and T41's have a later 9/2007 Bios and I have no such error in those machines. The T43 Bios allows us to bypass the stop with a pause and the automatic continue of startup. :roll:

Didn't expect the stupid error in the T43's and didn't think it has been such a huge thing for so long. I suspect that aside for the anoyance of seeing and hearing it that the T43's will function as well with the new larg drive as with smaller drives or the T42's and T41's that don't seem to mind them.

Finally you think that if I try to relosd the Bios over itself or start installing all the firmware patches I see in downloads that the problem will stop :?

Community SeniorMod
Community SeniorMod
Posts: 6,253
Location: US
Views: 23,546
Message 6 of 9

Re: BIOS error 2010 at startup of TTT after installing new Western Digital hard drive

The only thing that will make that warning go away is to use a sanctioned drive (made of unobtainium and kept on a planet far, far away) or revert to an earlier BIOS that doesn't check the drive.  Or maybe a hacked BIOS...

 

Problem with non-ThinkPad hard disks

 

The reason your '41 and '42 don't complain is the internal architecture.  The T43 chipset expects a SATA drive internally.  The planar has logic on it that translates that to IDE for the drive connection.  Some issue/error/bug/oversight/fancy feature of that translation chip requires (or thinks it requires...) certain drive firmware features to insure correct operation.

 

IIRC, the consensus is that the BIOS warning can simply be ignored.  I can't say myself, since I gave away the T43 along w/an extra IBM-sanctioned drive before it became an issue.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored. ... GeezBlog

 

Communities:    English English   Deutsche Deutsche    Español Español    Português Português    ru.gif Русскоязычное





teamster151
What's DOS?
Posts: 1
Location: Cooper City, FL 33026
Views: 19,994
Message 7 of 9

Re: BIOS error 2010 at startup of T43 after installing new Western Digital hard drive

There are certain model IBM's that require a "specially designed" hard drive. I don't know the particulars, but my "go to" guy, who specializes in the repair of IBM Thinkpads, told me when I confronted this same error, that regardless of my attempts to install the original OS (XP Home) from the Recovery Disc(s), that I'll never properly install ALL the necessary files needed to install completely. Bypassing the error message is simple enough, but your Recovery Partition which is created during set up, will NOT transfer correctly to the hard drive, leaving you NO option but to purchase the PROPER RECOMMENDED Hard Drive. I'm sorry, I don't have the Sku # of the correct hard drive. They ARE NOT large, partly because their interface is IDE, but very pricey! Get the right one, and you'll get many more years of service, from this work-horse of a business laptop, the IBM Thinkpad T43 and T43p!

Guru
Posts: 7,626
Location: USA
Views: 19,982
Message 8 of 9

Re: BIOS error 2010 at startup of T43 after installing new Western Digital hard drive


teamster151 wrote:

There are certain model IBM's that require a "specially designed" hard drive. I don't know the particulars, but my "go to" guy, who specializes in the repair of IBM Thinkpads, told me when I confronted this same error, that regardless of my attempts to install the original OS (XP Home) from the Recovery Disc(s), that I'll never properly install ALL the necessary files needed to install completely. Bypassing the error message is simple enough, but your Recovery Partition which is created during set up, will NOT transfer correctly to the hard drive, leaving you NO option but to purchase the PROPER RECOMMENDED Hard Drive. I'm sorry, I don't have the Sku # of the correct hard drive. They ARE NOT large, partly because their interface is IDE, but very pricey! Get the right one, and you'll get many more years of service, from this work-horse of a business laptop, the IBM Thinkpad T43 and T43p!


Welcome to the forum!

 

Your "go to" guy is clueless about ThinkPads.

 

I've installed XP from recovery media on well over a thousand T43/p units, most of them with non-whitelisted drives, and everything worked as it should.

 

For the record, a modded BIOS is available now which hasn't been the case a couple of years ago, which completely eliminates the error,  along with a couple of other "goodies".

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.
lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Location: Australia, Melbourne
Views: 19,978
Message 9 of 9

Re: BIOS error 2010 at startup of T43 after installing new Western Digital hard drive

George is the go to Guy for all ThinkPads.....

I am using the modded bios on the T43 that i got, i have also modded the hdd controller to accept a SATA hdd.
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Top Kudoed Authors