cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jsmith10
Paper Tape
Posts: 6
Registered: ‎10-14-2010
Location: Raleigh,NC, USA
Views: 1,660
Message 1 of 5

Can't boot Rescue and Recovery on new hard disk in T42p

 
PoPSiCLe
Greps Everything
Posts: 137
Registered: ‎12-08-2010
Location: Bergen, Norway
Views: 1,649
Message 2 of 5

Re: Can't boot Rescue and Recovery on new hard disk in T42p

A bit non-descript that message there... New hard disk, you say. Did you clone the old one? If so, which cloning-program? How are you trying to get to Rescue and Recovery? What happens? A bit more info would probably help...
--------------------------------------------------------------------------------
IT-technician, running my own company in Bergen, Norway
Thinkpad T61, 8895CTO C2D 2Ghz/4GB/120GB SSD/1400x1050
jsmith10
Paper Tape
Posts: 6
Registered: ‎10-14-2010
Location: Raleigh,NC, USA
Views: 1,622
Message 3 of 5

Re: Can't boot Rescue and Recovery on new hard disk in T42p

For some reason, text I type in the body in IE 9 isn’t making it when I post. I'm trying quick reply. The original disk crashed, but service partition was intact. I got new hard disk, used a linux boot cd to image the IBM_Service partition to a USB drive, then used gParted to format the drive for FAT32 and partition the new drive into a bootable partition and the IBM_Service partition. Installed the image in the new service partition. Can't get the service partition to boot, Both partitions have teh LBA flags set. I have set the boot flags and hidden flags to all the combinations for both partitions and none works. Made a bootable CD with the rnr31_rrd.iso file and tried to replace the MBR, but I get "Error - Filters returned an empty menu".

I don't have the old disk with me or I'd try to save the MBR from it and load it on the new drive.
jsmith10
Paper Tape
Posts: 6
Registered: ‎10-14-2010
Location: Raleigh,NC, USA
Views: 1,614
Message 4 of 5

Re: Can't boot Rescue and Recovery on new hard disk in T42p

Looks like I may have gotten it working, downloaded Super Grub2 Cd and bot Rescue and Recovery booted and it is recovering to factory original state.
Community SeniorMod
Community SeniorMod
Posts: 7,159
Registered: ‎01-13-2008
Location: US
Views: 1,605
Message 5 of 5

Re: Can't boot Rescue and Recovery on new hard disk in T42p

Hey,

That Super Grub2 CD looks interesting. I just about went up in smoke a couple of years ago trying to accomplish what you just did.

Legacy grub wouldn't boot the R&R partition unless I changed the ID to something it knew it could boot - and R&R wouldn't run properly unless it had its magic ID.

Thanks for the tip,
Z.

The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

  Communities:   English    Deutsch    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Polski    Türkçe    Moto English

Check out current deals!


Shop current deals

Top Kudoed Authors