Showing results for 
Search instead for 
Do you mean 
Retired SuperMod
Posts: 9,293
Registered: ‎11-27-2007
Location: SK
Message 11 of 22 (6,997 Views)

Re: Fingerprint Enrollment in constant endless loop

jidus, welcome to the forum,


try disabling cssauth.exe, hopefully this will do the trick also.



Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points

Did you find a post helpfull? You can thank the member by clicking on the star to the left awarding them Kudos

Please add your type, model number and OS to your signature, it helps to help you.

Forum Search Option

T430 2347-G7U W8 x64, Yoga 10 HD+, Tablet 1838-2BG, T61p 6460-67G W7 x64, T43p 2668-G2G XP, T23 2647-9LG XP, plus a few more.

FYI Unsolicited Personal Messages will be ignored.

de.gif  Deutsche Community   es.gif  Comunidad en Español  uk.gif  English Community ru.gif Русскоязычное Сообщество

PepperonI blog 

What's DOS?
Posts: 3
Registered: ‎09-12-2008
Location: Ohio, USA
Message 12 of 22 (6,972 Views)

Re: Fingerprint Enrollment in constant endless loop

Unfortunately, neither disabling the exe with msconfig, nor changing its name helped the problem. The fingerprint software still loads at the login screen, and I still have the loop error.

What's DOS?
Posts: 1
Registered: ‎02-20-2009
Location: PA
Message 13 of 22 (6,720 Views)

Re: Fingerprint Enrollment in constant endless loop

Did anyone ever resolve this?  I've been trying to fix the same issue on a T61.
Serial Port
Posts: 78
Registered: ‎01-10-2009
Location: Germany
Message 14 of 22 (6,678 Views)

Re: Fingerprint Enrollment in constant endless loop

i was just having the same dumb problem with my T60 -- endless enrollment loop.  spent like 2 hours renaming and disabling stuff, no use.


eventually i managed to open the "ThinkVantage Fingerprint Control Center" in Safe Mode.  Open Settings -> Logon -> switch to Standard Windows Logon.  That should do it.    Nothing else needed to be disabled.

Paper Tape
Posts: 3
Registered: ‎01-28-2009
Location: Redwood City, CA
Message 15 of 22 (5,842 Views)

Re: Fingerprint Enrollment in constant endless loop

This has been happening to me on a T61 off and on.  I have found that if I do not try to log in for, say, 8 minutes after getting the logon prompt, it is more likely towork.  However, this morning, not even that works.


I try to logon with either fingerprint or username/password, and end up on the "Enroll" panel for fingerprints.  My username is already entered on the form, read-only, with a apassword prompt.  I enter my password and get the error "that passport cannot be used..." and then get logged off.


I have not yet tried the Safe Mode/rename/disable approaches, but these just turn off the feature.  How do I fix it?


It's amazing to me that Lenovo has shipped a product that won't let me log into my own laptop.  And incredibly frustrating that I cannot log in at all.


How can this be fixed, short of respinning the whole disk, which I just did a couple of months ago.  Is it necesary to do this every few months?

Posts: 5
Registered: ‎01-21-2010
Location: UK
Message 16 of 22 (4,785 Views)

Re: Fingerprint Enrollment in constant endless loop



I seem to be in the same situation as well now?

My IT people have been out to see my lap (T61) and have had no luck.

They want to try a full rebuild, but I have important project information on board that has not been backed up anywhere else yet.

I really need to gain access again to this lap.



Paper Tape
Posts: 1
Registered: ‎04-19-2010
Location: North America
Message 17 of 22 (4,113 Views)

ounRe: Fingerprint Enrollment in constant endless loop

I'm running into the sam issue as well.


I've found a few work arounds.  First and easiest method is pull the battery for a minute, Second go into the BIOS goto Security Fingerprint and reset all fingerprint data.  If these methods don't work hit f8 on boot go into safe mode and log on as local administrator.  After your in safe mode goto start>run>regedit.


Drill down to: HKEY_LOCAL MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon


Set the following keys to:




This should get you around the loop.  I'm still interested in a real fix not a work around if anyone has any further information.

What's DOS?
Posts: 1
Registered: ‎05-12-2010
Location: USA
Message 18 of 22 (3,892 Views)

Re: ounRe: Fingerprint Enrollment in constant endless loop

I don't know if will fix everyone's issue, but I dealt with this problem today.  I went through all the same things listed here.  The last resort was pulling the hard drive out for a while to get some files I needed on my desktop and then plugging it back in.  Went to the bios and disabled fingerprint at start function in security.  Bam!  fixed. 


Disabled the software once I was in windows and now I'm back in business.  I'm done with this stupid thing.


I don't know if it was a fluke, but give it a shot.

What's DOS?
Posts: 1
Registered: ‎06-21-2010
Location: California
Message 19 of 22 (3,654 Views)

Re: Fingerprint Enrollment in constant endless loop

Boot into Safe Mode


Go to Start->run type in regedit


In the registry go to HKEY_LOCAL_MACHINE\software\Microsoft\windows nt\currentversion\winlogon make sure key baseGina needs to point to msgina.dll


If the Base Gina String is not the registry add it: create a string under the Win login Key called basegina and the value should be set to msgina.dll

Also locate and change the GinaDLL string valve to msgina.dll


Then go to:



Set MonitorInterval to all "f"s


Once you have changed both reg keys close out of the registry and reboot.


Now you can login like normal, uninstall the fingerprint software and reinstall\update to a newer version or roll without it.

Fanfold Paper
Posts: 12
Registered: ‎03-27-2008
Location: USA
Message 20 of 22 (3,625 Views)

Re: Fingerprint Enrollment in constant endless loop

We have seen this happen after deploying full drive encryption and single sign on with the fingerprint software on T60/T61's. (Fingerprint software version 5.8.2 ) We remote into the registry and change the ginadll to msgina.dll (from vrlogon.dll). This will get you back to the Microsoft logon prompt and you can login. Then open the fingerprint software to check the settings and the key will revert back to vrlogon.dll, the looping will stop and you can use the fingerprint sign on.