Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Ctrl-Alt-Del
Posts: 15
Registered: ‎07-03-2011
Location: Chicago
0 Kudos
Accepted Solution

Intel 2200BG Wireless Adaptor Not Working in T42

Somehow in my zeal to download and install every applicable device driver for my ThinkPad T42 (2378-FVU) from the Lenovo driver website, I managed to destroy WiFi capability.

Here's what I'm doing:

Download the appropriate device driver from Lenovo:

  http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/6hwc05ww.zip?

Extracting the device driver, etc., to:

  C:\Drivers\Win\WLANINT\XP\x32\

Run

  C:\Drivers\Win\WLANINT\XP\x32\Install\Setup.exe

The installer completes registering the device driver:

  Intel(R) PRO/Wireless 2200BG Network Connection

And then, this error message appears:

Intel(R) Wireless Management Service has encountered a problem and needs to close.  We are sorry for the inconvenience.

Here are the details:

EventType : BEX     P1 : S24EvMon.exe     P2 : 12.4.0.10     P3 : 49a7f0c4   
P4 : S24EvMon.exe     P5 : 12.4.0.10     P6 : 49a7f0c4     P7 : 0004a920   
P8 : c0000409     P9 : 00000000   


After rebooting, Device Manger reports that both the wired and wireless network adaptors are working. 

If I plug a Ethernet cable into the LAN port, I'm registered on the network and am assigned an IP address, which is how I'm able to post this message.

If I leave the LAN port empty and open Wireless Internet Connections, several networks appear as they should.  But, when I try to connect to one of them I don't get an IP address. 


Moreover, when I run ipconfig in a DOS window after apparently making a connection, I get an error message that seems to explain that there's something wrong with the wireless adaptor:

C:\Documents and Settings\Nello Lucchesi> ipconfig

Windows IP Configuration

An internal error occurred: A device attached to the system is not functioning.

Please contact Microsoft Product Support Services for further help.

Additional information: Unknown media status code.

 

 

Yes, I've tried removing the driver, rebooting and re-installing it.  Same thing happens.  I'm having the same problem with the device driver downloaded directly from Intel too.

 

 

So, does anyone have some ideas of how I can get WiFi working again?

 

Thank you for your help.

 

  - nello


 

Highlighted
Posts: 1,892
Topics: 69
Kudos: 210
Solutions: 108
Registered: ‎12-02-2007
Location: Sydney, Australia - Best Address on Earth
0 Kudos

Re: Intel 2200BG Wireless Adaptor Not Working in T42

Try this driver.....

 

http://support.lenovo.com/en_AU/downloads/detail.page?&LegacyDocID=MIGR-54956

 

Cheers,

 

Bill

 

------------------------------
I don't work for Lenovo
Ctrl-Alt-Del
Posts: 15
Registered: ‎07-03-2011
Location: Chicago
0 Kudos

Re: Intel 2200BG Wireless Adaptor Not Working in T42

Thank you for posting your recommendation.

 

I installed the driver.

 

Good news:  Installation completed without error; Device Manager says that the wireless adaptor has a driver that is workiing; Network Connections sees wireless access points.

 

Bad news:  Still can't connect to any of the wireless access points.  The wireless symbol in the system tray has a red x at it's bottom.  The yellow ball indicating a DHCP request/connection never comes on.  The red x never goes off.

 

Any more ideas?

Ctrl-Alt-Del
Posts: 15
Registered: ‎07-03-2011
Location: Chicago
0 Kudos

Re: Intel 2200BG Wireless Adaptor Not Working in T42

I should also note that I've been removing the ThinkPad and Intel wireless "programs" that appear in the Add/Remove Programs Control Panel. I've made sure that I have only one or the other since I thought they might conflict.
Ctrl-Alt-Del
Posts: 15
Registered: ‎07-03-2011
Location: Chicago
0 Kudos

Re: Intel 2200BG Wireless Adaptor Not Working in T42

I gave up and re-installed Windows XP Professional and then applied drivers: networking works fine now.l