cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 102,237

Question

Relevant omly to ThinkPad systems prior to the *30 series, with the 7 row keyboard.


When I type the letters M, J, K, L, U, I, O on my keyboard, numbers are appearing on the screen instead of the letters. Other keys seem to be working fine.

Answer

This is most likely caused by the NumLock function being enabled .  Then Num lock remaps these keys to function as a virtual numeric keypad, causing numbers to appear when buttons such as M, J, K, L, U, I, O is pressed.

 

This feature is not found on all systems.  Here is an example keyboard, illustrating the numbers on letters.

 

keyboard virtual numpad.jpg

 

In order to disable the NumLock function just press Shift + ScrLk button on your keyboard.

 

numlock.jpg

 

 

Keyboard layouts by system may vary by system generation and some may be Shift-ScrLk and some might be accessed as a combination of FN key.

 

Later versions of the hotkey driver and Lenovo display drivers will display an indicator icon on the lower right side of the screen to show status of numlock & capslock.  Here is the numlock icon showing it is disabled.  When you toggle, the icon will display for a few seconds and then disappear.

 

numlock.JPG

 

You can use the Shift + ScrLk also does the same function to disable NumLock.

Was this information helpful?

Comments
niloc

I tried as you suggest .. no luck

 

Shift and ScLk (  this is the button for PgUp  )