Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Fanfold Paper
Posts: 6
Registered: ‎03-15-2009
Location: Poland
0 Kudos

Re: New T61. Dead slow wireless

I think this out and I'm guessing that on every sets of the drivers doing the same. I mean that when you set on max battery the drivers shout down WiFi connection and they suppose to fire it up, but they do not or do but not in normal time. On the other hand in max performance they work in this way but much faster. So when you use connection continuously the speed is dropping and rising. That's why you have got this problem.

So I do not know if it is drivers or it is wireless itself, but some thing is f... up. So my advise is to buy some new better card, I will do that as soon I get some money.


Ps. Do not get me start on behavior when it is connect in "N" mode.

What's DOS?
Posts: 1
Registered: ‎12-12-2009
Location: USA
0 Kudos

Re: New T61. Dead slow wireless

Fixed this issue by disabling the wireless adapter's "802.11n Mode"!


I just got a new Thinkpad T400 with the Intel WiFi Link 5100 AGN card running Windows 7 Pro. Using as a guage of Internet peformance, I was getting ~700kpbs download. By comparison, I have also have a Thinkpad Z60t with Windows XP Pro getting wireless speeds of ~12,000kpbs.


I tried a variety of options, including updating drivers, disabling "Remote Differential Compression" --- none of these worked. What did work was disabling the wireless adapter's "802.11n Mode".


From 'Network Connections', right-click on 'properties'. Click the button to 'Configure..." the wireless adapter. Go to the 'Advanced' tab, which is the second tab after 'General'. In the 'Properties' box, the third option down for me is '802.11n Mode' which I set to 'disabled'. After rebooting, I was getting wireless speeds of ~12,000kpbs.

What's DOS?
Posts: 1
Registered: ‎02-07-2010
Location: Illinois

Re: New T61. Dead slow wireless

I had the same problem with my T400, and found that if I changed the 5th option Ad Hoc QoS Mode to WMM Disabled  it  allowed me to get the full throughput on my 802.11N and not have to drop to 802.11g as previsously stated.  Seems that the QoS stuff causes alot of bursty performance issues.



Fanfold Paper
Posts: 9
Registered: ‎09-26-2011
Location: Denver, CO

Re: New T61. Dead slow wireless

[ Edited ]

OMG!!!!!  Thank you SO, SO much for this solution!  I changed the 802.11n Mode = "Disabled" and it fixed my INCREDIBLY SLOW download speeds.  I've spent 8 hrs on the phone with Lenovo... AFTER PAYING $89 TO EVEN TALK TO THEM!!!!  And, they don't know about this solution.  For now, I'll give up any extra speed n-mode might have given me.  Before this fix, I had a very intermittent wireless connection that would occasional freeze for 20 seconds to 2 minutes!  My download speed tests were running at 200-500 Kbps.  As soon as I disabled 802.11N Mode, I jumped back up to 9-10 Mbps!!!!  And, I no longer have the intermittent wireless freezes!  Thank you!  Thank you!!!!!!!


Lenovo wanted me to either send my laptop back (10 business day wait!!!) and/or re-install Window 7 (thus wiping out all of my weeks of installs on this new computer!!!) and I wasn't convinced that would even fix the problem.  They were just grasping for a solution.  I was about to buy a new Intel Centrino wireless 6150 N card and try installing the new hardware myself.  But, I kept searching around and found your solution.  It worked!!!!!






Details on this simple fix are:  Open Control Panel, click on: Device Manager->Network Adapters->Intel Centrino Wireless N 6150 (or your card).  Then, right-click and open Properties.  Click Advanced tab.  Then, click "802.11n Mode" and click "Disabled".  Then, click "OK".


You saved me HUGE headaches by not having to return my computer or having to reinstall Windows!


- Steve

What's DOS?
Posts: 1
Registered: ‎08-04-2014
Location: Norway
0 Kudos

Re: New T61. Dead slow wireless

Hi Smiley Happy
If i disable this I get no wireless option at all, so what do I put instead?