cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
RexDynasty
Punch Card
Posts: 23
Registered: ‎09-03-2008
Location: Germany
Views: 3,084
Message 1 of 8

T23 WLAN connection problem

Hi all,

 

i've fomatted the T23 of my brother 'cause he'd a trojan which wasn't removeable. I've installed Windows with SP2 and also System Update and Access Connections. I'm able to connect to the Internet via cable but not via WLAN. Tried everything but nothing works!

Isn't this the right driver for the laptop? I even installed the Bios Update "High Rate Wireless LAN Mini PCI firmware update", but the result was the same.

 

What can i do to make it work?

 

I thank all in advance.

 

 

ThinkPad T23 2647-KNG

Guru
Posts: 7,626
Registered: ‎11-23-2007
Location: USA
Views: 3,068
Message 2 of 8

Re: T23 WLAN connection problem

Welcome to the forum!

 

Have you extracted the driver from the appropriate directory after downloading it, it should be something like C>Drivers>Win>Wlan something or the other...

 

Good luck and let us know.

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.
RexDynasty
Punch Card
Posts: 23
Registered: ‎09-03-2008
Location: Germany
Views: 3,050
Message 3 of 8

Re: T23 WLAN connection problem

Yep, extractet to the specified folder "C->Drivers". Then i installed the two progs "System Update" and "Access Connections". But the System Update says, that the server is not reachable for now and i shall try again later. And Access Connections finds other WLAN Routers but not ours. Strange.

Our WLAN Router has no WEP or WPA/2. We just turned on MAC-Filtering but the MAC-Adress of the T23 is saved in the Router. So there shouldn't be a problem with that. Right?

 

I'm so frustrated!

Guru
Posts: 7,626
Registered: ‎11-23-2007
Location: USA
Views: 3,039
Message 4 of 8

Re: T23 WLAN connection problem

Try turning the MAC filtering off and see what happens...

 

Is your router b/g or something else?

 

Good luck and let us know.

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.
RexDynasty
Punch Card
Posts: 23
Registered: ‎09-03-2008
Location: Germany
Views: 3,038
Message 5 of 8

Re: T23 WLAN connection problem

Ok, will do. Our router is b/g. But before i do that, i'll start System Update again. The Servers are accessible again. I updated my own Lenovo 3000 N200 just 10 minutes ago. Who konws, maybe if i do that, the WLAN will work properly again.

Message Edited by RexDynasty on 09-04-2008 02:07 PM
RexDynasty
Punch Card
Posts: 23
Registered: ‎09-03-2008
Location: Germany
Views: 3,005
Message 6 of 8

Re: T23 WLAN connection problem

I deactivated the MAC-Adress filtering but the result was the same: No connection via WLAN.

 

Maybe i have the wrong driver? 'Cause i had the same problem with my 3000 N200; i installed  a driver of Broadcom but it didn't work either. Then i saw on the same support/download page that there is another WLAN driver of Intel. I installed the one of Intel and voila: It works now.

 

Maybe the T23 has also 2 drivers and i installed the wrong one. But i can't see a second driver on the download page. Oo Maybe someone else does?

RexDynasty
Punch Card
Posts: 23
Registered: ‎09-03-2008
Location: Germany
Views: 2,984
Message 7 of 8

Re: T23 WLAN connection problem

Noone any suggestions?
RexDynasty
Punch Card
Posts: 23
Registered: ‎09-03-2008
Location: Germany
Views: 2,962
Message 8 of 8

Re: T23 WLAN connection problem

Ok, i solved the problem.

 

For those, who have or will have the same problem:

 

(!! Some names can exhibit differences because i translated the names from the german Windows XP !!)

 

Here are the steps i did to solve the problem:

 

First make sure, that you run the "System Update" minimum once via Ethernet cable.

Now you go to the driver options of your WLAN Network Adapter. To do that, right click on "Workstation" then "Preferences -> Hardware -> Devicemanager" and under "Network adapters" you should see your WLAN adapter then right click and "Preferences". And somewhere in the preferences should be the option to choose the WLAN speed (11 or 54Mbit or Automatic). Select the speed, which your WLAN adapter supports the highest.

 

For me it was 11Mbit and i changed it from "Automatic" to 11Mbit and my WLAN works fine now.

 

Hope, that this helps.

 

Regards

Rex D.

Check out current deals!


Shop current deals

Top Kudoed Authors