Showing results for 
Search instead for 
Do you mean 
Posts: 16
Registered: ‎09-16-2010
Location: US
Message 1 of 13 (8,216 Views)

T41 2373-8SU Wireless Problem


Here is my situation:

I have received 4 T41 and 1 T42 laptops from a MS authorized refurbisher.  Upon initial boot, they boot like brand new out of the box machines.  I set them up for our network and install software needed by our organization.  On first setup, the Windows XP detected area wireless networks and I was able to connect them to our network wirelessly.  After a few days however, when I try to list the available wireless networks I get "No wireless networks were found in range".  The odd part is that they remain connected to the wireless network I connected them to when I set them up but to switch networks (say between work and home) is not possible because no wireless networks (even the one they connect to automatically) show in the wireless networks list.  All 5 of them do this so, I can only assume this is some kind of problem with Windows XP or the laptop.  I have tried the following to fix this situation to no avail:

1. Reinstalling the adapter driver with a more current version from both Intel and Lenovo.  The Intel one says there is no compatible wireless device (though I downloaded and installed what they say to for a Intel PRO/Wireless 2200bg) and the Lenovo one says the driver I already have installed is more current though the dates on the download say otherwise).
2. Reinstalling XP SP3.
3. Trying the adapter drivers for every type of adapter the T41 ever came with thinking the wrong adapter type had been identified by the refurb company.
4. Installing various 3rd party wireless network management software (including IBM Access and LucidLink).  They do not work properly for some reason.
5. Installing Microsoft Hotfix KB942288-v3-x86.  This works briefly.  I install it, restart the computer, the networks list fine, but then a day or two later they are gone again and I'm back to square one.  Reinstalling the patch may or may not work again temporarily but does not provide any kind of lasting solution.  I've done this by trying both just the patch and then trying the patch and reapplying SP3 after the patch.  Neither works permanently.

6. I have tried installing an external USB wireless adapter and it does not work either.  Same thing, says there are wireless networks available but when I click to list them the list says there are no networks in range.

7. Uninstalling the adapter and letting Windows reinstall it.  It identifies it as a Intel PRO/Wireless 2200bg and installs a 12/2007 dated driver.

8. Making sure the wireless signal is on.

9. Disabling any power saving settings that may be putting the adapter to sleep.

I do not believe this is hardware related as the adapter works fine as far as connecting and picking up signal and other adapters do not work either.  It is just that the software does not show the networks available.


Additional ideas from what I've already attempted would be greatly appreciated.  It is not an option for me to replace these things for another 2-3 years and I'd really like to be able to give my employees something they can actually use on a portable basis outside our building.


I have had little success in finding someone else with this problem.  I've been searching for a year for a solution and no one else seems to have this problem which I really find hard to believe since I have 5 of them that do this it can't be an anomaly to me and I can't believe I am the only person still using T41s/T42s out of likely thousands of them that were ever made.

Posts: 16
Registered: ‎09-16-2010
Location: US
Message 2 of 13 (8,213 Views)

Re: T41 2373-8SU Wireless Problem

I have also noted the following message in the device properties when I click the Advanced tab.  "Adapter state not found in registry."  I don't recall having seen this message before during troubleshooting this problem but it could have been there and I just never checked the advanced tab before (it usually opens to that tab).

Posts: 7,626
Kudos: 759
Solutions: 804
Registered: ‎11-23-2007
Location: USA
Message 3 of 13 (8,204 Views)

Re: T41 2373-8SU Wireless Problem

Welcome to the forum!


I've bumped into this with a couple of different machines using 2200BG cards. My solution was (and still is) Inte's PRO/SET wireless utility.


Works like a charm on three ThinkPads in my household that wouldn't connect any other way in XP. YMMV.


Good luck.



In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W

Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
Posts: 16
Registered: ‎09-16-2010
Location: US
Message 4 of 13 (8,201 Views)

Re: T41 2373-8SU Wireless Problem

When I install the Intel PRO/Wireless Utility it says "No supported WiFi adapters available in the system."


I'm really starting to think I have a bad dll or something in the Windows system software.  I really don't want to reinstall Windows though because I will lose my Office 2003 software because it will overwrite files needed for that that are installed when you install Office 2003.  The software was installed by the refurbisher and is legal (MS sticker on the bottom of the laptop), but I have no way to reinstall Office 2003 because I have no discs for it.  I do have discs for Windows because we use it on other computers that are not refurbs.

Posts: 16
Registered: ‎09-16-2010
Location: US
Message 5 of 13 (8,175 Views)

Re: T41 2373-8SU Wireless Problem

Eureka!  I believe I have finally solved the problem (and if I haven't I'm pretty much out of things to try).


After looking at all I have tried and everything that has been suggested the thing that really stood out what that even a USB adapter would not work properly.  This lead me to believe that there was a defective Windows file somewhere (which would also explain why all of the ones I have didn't work since they were all imaged from the same image).


I did a repair from an XP CD-ROM.  However, because the the Windows Genuine Advantage software installed at one point in the past year during a Windows Update activating the copy of Windows was somewhat tricky.  The solution to that was to upgrade IE to 8 on first boot after running the repair install of Windows.  Once IE 8 was installed it was able to activate successfully.  I then reinstalled SP3 (the CD of XP was only SP2).


So far, this seems to have taken care of the problem.  With luck it will hold and all will be well.

Posts: 16
Registered: ‎09-16-2010
Location: US
Message 6 of 13 (8,151 Views)

Re: T41 2373-8SU Wireless Problem

[ Edited ]

As the saga continues:

The answer turned out to be even simpler than what I thought.

Turns out that if SP3 is installed while anti-virus software is running entries my be made incorrectly to the registry which cause the available wireless networks list to disappear. There is a MS hotfix for it at . It requires you to boot into safe mode, double click the fix file (needs to be extracted from the download first), and then you can reboot into normal mode and botta-bing, the network list is back. No need to reinstall Windows or anything.  Reinstalling Windows worked on the first one I tried it on because I disabled the AV when it was downloading SP3 so it installed properly.  But when I went to do the next one I forgot to do that and was very frustrated when I applied SP3 to it and the list disappeared again.  However, that was the key I needed to find the solution so it all worked out in the end.

The fix opens a command window and closes it so fast you wonder if it really did anything but it does work.


I feel dumb that it took me a year to figure this out, but I didn't really know the problem started after installing SP3 because by the time Windows Update did that the computers were with my users and I had no idea that updates had been run prior to the problem appearing. However, after reinstalling Windows and it working fine in the SP2 install and then not once SP3 was applied things started falling into place as to the problem. Hope this saves someone else a year of pulling their hair out.

Posts: 2,421
Topics: 20
Kudos: 418
Solutions: 190
Registered: ‎12-01-2007
Location: California, USA
Message 7 of 13 (8,136 Views)

Re: T41 2373-8SU Wireless Problem



Can I ask what antivirus programs(s) were used on the computer?  That might be helpful to know in case anyone else in the forum ever comes across the same problem.




Aryeh Goretsky


I am a volunteer and neither a Lenovo nor a Microsoft employee. • Dexter is a good dog • Dexter je dobrý pes
S230u (3347-4HU)X220 (4286-CTO)W510 (4318-CTO)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)T61p (6459-CTO)T43p (2678-H7U)T42 (2378-R4U)T23 (2648-LU7)
  Deutsche Community   Comunidad en Español Русскоязычное Сообщество
Posts: 16
Registered: ‎09-16-2010
Location: US
Message 8 of 13 (8,124 Views)

Re: T41 2373-8SU Wireless Problem

It is running Norton Anti-Virus (not the best choice, I know, but it is cheap for our non-profit) and SpyBot.


The problem has taken on a new dimension after applying that fix.  While I can now see wireless networks in the list, I cannot connect.  I get an endless "Acquiring IP Address" loop.  It is something in MS Windows XP SP3 that is doing this because when I uninstall that it works fine in SP2 and as soon as I install SP3 things go wrong.  The most common advice people give is to get a update driver for the wireless card, however, it appears that the most recent driver for that is dated in 2007 and I have installed that and it does nothing to fix the problem.  This is most frustrating as I need SP3 for other software that is used on these.  There has got to be a way to make this work.

Token Ring
Posts: 19
Registered: ‎08-09-2009
Location: Scottsdale, AZ
Message 9 of 13 (7,850 Views)

Re: T41 2373-8SU Wireless Problem

I had this problem right after Windows XP SP3 was downloaded on my T41 in 2009.  I traced it to the SP3 upgrade and bought several adapters to try and find one that was compatible to the XP SP3 OS.  The one that finally "worked" was the Belkin N Wireless Notebook Card.  Even then, the software that came with the card did not work but the Windows Wireless utility was able to find the card and the network and the system "worked".  Because of this, however, I decided to upgrade the OS to WIndows 7 and had to buy another card that would work with WIndows 7 on an N based wireless network.  I now use the Belkin card on another legacy 600X Thinkpad that operates with WIndows XP SP3 without any problems except as discussed above concerning the Belkin Software/WIndows Wireless utility issue.  When I was trying to solve the problem, I found a website that said that the SP3 upgrade was not compatible with PMCIA cards in general and Microsoft was not planning to make any changes to the OS nor were any of the adapter manufacturers planning to make upgrades to their software or cards.  That was probably because WIndows 7 was well on its way to being introduced and there really was no need for them to upgrade an OS that was in the process of being replaced. 


Hope this helps but frankly, the pain of trying reinstalling OS' and other software was relieved once I decided to upgrade to Windows 7.

Posts: 16
Registered: ‎09-16-2010
Location: US
Message 10 of 13 (7,837 Views)

Re: T41 2373-8SU Wireless Problem

That is interesting.  Can the T41/42/43 even handle Windows 7?  Not that I'll be in the market to upgrade them.  We have software that won't run on 7 and would cost tens of thousands to upgrade that plus the expense of 10 copies of 7 (which that alone will prohibit upgrading to 7 for us).  It really sucks to be a non-profit with no money.


I was hoping to avoid the USB stick adapters if I could because they would be prone to loss and breakage.  Not to mention it is rather awkward having something sticking out of a laptop like that.  A PCMCIA card does also but not as bad and it is anchored more firmly in its connection to the laptop.

top kudoed authors
User Kudos Count