Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 2,853


Whenever I resume my ThinkPad T42 from Sleep/ Standby the bluetooth radio is off and I have to go into ThinkVantage Access Connections to turn it back on before I can use my bluetooth mouse.


 All my IBM/Lenovo drivers are up-to-date, and I have tried turning off and back on the wireless radios in the BIOS. 



Check to see if the Bluetooth state is also set to off when the system is shut down and restarted, or if this only happens after resume from sleep / standby.


  • If Bluetooth works after a shutdown and cold boot, and also after resume from hibernate, then try to uninstall, reboot, reinstall the Lenovo power manager.


  • If Bluetooth also is reset to off after a cold boot, the problem may be with some values in BIOS.


Try to reset this by any of these methods:


- Booting into BIOS and reloading defaults (this is an option), then select save and exit.


-Clearing capacitance - power off system, remove main battery and AC.  Press and hold the power button several times for several seconds each time.  Now re-attach battery and AC and restart and check Bluetooth.  Set to ON with power manager and confirm operation, then shutdown and reboot and verify it is on by defaul.

-Lastly, you can also try clearing CMOS by opening the system and accessing the round yellow CMOS battery under the keyboard.  With the system off, unplug this for 5 mins, then restart, reload BIOS defaults, confirm bluetooth is on in the BIOS, reboot, confirm Bluetooth is on in power manager and functions normally.  Confirm this setting remains after a shutdown and reboot.


Was this information helpful?


I have something similar

My T420 will recognize and pair with both a bluetooth mouse and external speaker.  But it won't send any music to the speaker.  And the mouse worked until the first time the computer went to sleep and after that won't work at all, even though it's still recognized and the device manager says it's functioning.  I've downloaded latest driver, rebooted, reinstalled all to to avail.  What could be wrong? Thanks.