English Community

ThinkPad NotebooksThinkPad; T61 and prior T series plus Other Legacy ThinkPads
All Forum Topics
Options

2 Posts

08-31-2013

Tartu

5 Signins

13 Page Views

  • Posts: 2
  • Registered: ‎08-31-2013
  • Location: Tartu
  • Views: 13
  • Message 1 of 6

T60 video or memory problem

2013-08-31, 15:56 PM

I got a T60 with win xp sp3 and on startup i get a few stripes on the thinkpad and the winlogo. After it the desktop shows no artefacts or stripes and everything looks normal except the video driver is missing.

It has the ati X1300 card and when i let the system search the driver in device manager - it finds it and installs it.

After reboot it shows up a blue screen with the NMI: Parity check / Memory Parity Error.

If i start windows using last known good configuration - it starts normally but the video driver is also missing as well.


I tryed to download the ati catalyst center with the driver from the official site and after downloading it says that i even dont have any ati video card?

 

Any ideas what is causing all that? 

Solved! See the solution
Reply
Options

2225 Posts

01-02-2011

US

8328 Signins

51712 Page Views

  • Posts: 2225
  • Registered: ‎01-02-2011
  • Location: US
  • Views: 51712
  • Message 2 of 6

Re: T60 video or memory problem

2013-08-31, 20:17 PM

Are you certain it has the ati graphics?  it's conceivable that the board could have been changed so don't go only by the model number of the laptop.

 

Of course it could also be a bad system board.

ThinkPad W-510 i7-820QM(1.73-3.06GHz) Quad Core... ThinkPad T500, T9900, 8gb SSD...FrankNpad T-60p/61p (X9000 2.8ghz) 8gb SSD ips FlexView...ThinkPad T-61p (T9300 2.5ghz) 8gb ram...Thinkpad X-61 Tablet 8gb ram.
Reply
Options

2 Posts

08-31-2013

Tartu

5 Signins

13 Page Views

  • Posts: 2
  • Registered: ‎08-31-2013
  • Location: Tartu
  • Views: 13
  • Message 3 of 6

Re: T60 video or memory problem

2013-08-31, 20:58 PM

I also looked it with astra32 and it sayd the same - X1300
I talked to my friend and he sayd it could be the video chip malfunctioning cause as soon as i install the driver  - the problem occurs.

Reply
Options

2225 Posts

01-02-2011

US

8328 Signins

51712 Page Views

  • Posts: 2225
  • Registered: ‎01-02-2011
  • Location: US
  • Views: 51712
  • Message 4 of 6

Re: T60 video or memory problem

2013-08-31, 21:13 PM

wrote:

it could be the video chip malfunctioning cause as soon as i install the driver  - the problem occurs.


 

That's why I said you could need a new system board. You can try booting from a linux liveCD, see if the graphics works with linux, if not you'll probably need a board, otherwise it could be software.

ThinkPad W-510 i7-820QM(1.73-3.06GHz) Quad Core... ThinkPad T500, T9900, 8gb SSD...FrankNpad T-60p/61p (X9000 2.8ghz) 8gb SSD ips FlexView...ThinkPad T-61p (T9300 2.5ghz) 8gb ram...Thinkpad X-61 Tablet 8gb ram.
Reply
Options

7638 Posts

11-24-2007

USA

5818 Signins

103093 Page Views

  • Posts: 7638
  • Registered: ‎11-24-2007
  • Location: USA
  • Views: 103093
  • Message 5 of 6

Re: T60 video or memory problem

2013-09-01, 0:05 AM

Yes, that does sound like an early stage of VRAM corruption that T60/p units with ATi chips sometimes succumb to.

 

The good news is that there's no shortage of motherboards for these machines, and the prices have gone down to ridiculous levels over the past year or so.

 

Good luck.

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.

0 person found this solution to be helpful.

This helped me too

Reply
Options

2225 Posts

01-02-2011

US

8328 Signins

51712 Page Views

  • Posts: 2225
  • Registered: ‎01-02-2011
  • Location: US
  • Views: 51712
  • Message 6 of 6

Re: T60 video or memory problem

2013-09-01, 0:38 AM

wrote:

Yes, that does sound like an early stage of VRAM corruption that T60/p units with ATi chips 


 

You just heard from the T60 expert and I bet if you ask him nicely he could even get you a board, or if I cannot I'm sure I could find you one. Last I checked I can get the x1300 boards for $50 or less compared to $600-700 not that long ago.

ThinkPad W-510 i7-820QM(1.73-3.06GHz) Quad Core... ThinkPad T500, T9900, 8gb SSD...FrankNpad T-60p/61p (X9000 2.8ghz) 8gb SSD ips FlexView...ThinkPad T-61p (T9300 2.5ghz) 8gb ram...Thinkpad X-61 Tablet 8gb ram.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save