Showing results for 
Search instead for 
Do you mean 
Posts: 64
Registered: ‎09-19-2011
Location: Raleigh, NC - United States
Message 1 of 416 (8,914 Views)

GPS - TPT Acquiring Satellites Bug

[ Edited ]

04/12/2012 Update: TPT is back home, innards intact and GPS acquire and lock improved:

I have to say that I have based my entire outlook on this GPS issue as being a problem with AGPS data not being downloaded for a Wifi only network connection (and to a lesser extent the NTP_Server setting).


To me it was logical;

  • I'm connected via Wifi (usually via phone tether)
  • I can't aquire or lock on Satelittes 
  • They must only be obtaining AGPS data for 3G/4G/GSM connections. 

In short, I was blaming the assumed lack of AGPS data, but not considering the standalone GPS it's self. Suffice to say it wouldn't be the first time I've been wrong Smiley Wink


After meeting with someotherguy and Mark_Lenovo earlier in the week and leaving my TPT for probing, I went back to pick it up yesterday. 


While I'm still unsure whether the TPT recognizes a Wifi connection as a valid trigger for obtaining AGPS data, I have to say there is a definite improvement in aquiring and lock after getting my TPT back. Not jumping up and down cheering better, but better. My TPT may not have been the smoking gun they needed, but hopefully provided some clues. They are still investigating and out of respect to them, I didn't even want to know what they may or may not have learned as I don't trust my loose lips. Smiley Wink I'm sure they will have some information for us once they have concluded their investigation.


I have to apologize if my ragging or rethoric on this issue cast any of the Lenovo forum monitors in a bad light. After meeting with someotherguy and Mark_Lenovo it was obvious that they were engaged, concerned, motivated and proud to stand behind the TPT. Not to be all sappy but talking with them renewed my faith in Lenovo (of which I have been a big fan of since the early IBM days).



04/10/2012 Update: Maybe it is a hardware issue?!

For months now I've been adamant that this was a software issue, based mostly on my experience with the Acer A500 Tablet, comments from other forum Users and my own rudimentary testing. I may have to prepare myself to eat crow.

Yesterday I met with "someotherguy" (a Lenovo employee forum participant) and while sitting in the very beautiful Lenovo courtyard I was shocked to see his TPT acquire and lock-on satellites with 90 seconds or so. His TPT did not appear to be extra special (no big receiver dish hanging off the side Smiley Wink and had no 3G/4G.


I didn't time it but my own TPT took approximately 8-10 minutes or so for a weak lock, which it promptly lost.


I left my beloved TPT with "someotherguy" (I hope he was a Lenovo employee?! Smiley Wink ) so they could take a closer look at it, maybe even delving into it innards.


I'm anxious to see what they find and prepared to issue a sincere apology if I have lead Users down the wrong path with my software issue theory.



02/02/2012 UPDATE - Some Fight Left, Partial GPS Fix in OTA2?:

Many thanks to bsnf for agressively championing and possibly single-handedly getting the NTP_Server portion of the GPS bug in OTA2 (due out next week for US). Without knowing the details of what was fixed, it's hard to determine what affect it will have but it's a start.


Here's why the NTP_Server fix alone may not help: There is an additional problem with the AGPS data, 3G/4G/GSM and WIFI configuration that unless it was fixed could overshadow the NTP_Server change. I am not a GPS expert (I only play one in forums) but typically  manufacturers of mobile devices that have GPS will use AGPS (Assisted GPS) functionality to speed up TTFF (Time To First Fix) and Satelitte lock times. This functionality will recognize a network connection and then download satelittle postion data from the internet in order to speed up the process, hence the "assisted" Smiley Wink


I won't go into it here as it has been covered in this post and others, but suffice to say that the TPT seems to either not have AGPS functionality or does have it and it's not working properly.


Initally I thought that the TPT had AGPS but was not recognizing the wifi network connection as a viable transport for downloading the AGPS data. Since my TPT only has wifi (no 3G/4G/GSM), I would be connected to the internet and would have a GPS TTFF and/or Satellite lock time of over 10 minutes (if at all). When I manually download AGPS Data using a 3rd party App prior to using the TPT GPS, these times dramically improved to 5 minutes or less. The conclusion was simple, the TPT was not downloading AGPS when there was a valid wifi network connection (this was supported by early reports that Customers calling Lenovo Support were told their unusally long GPS times were due to the fact that they didn't have 3G/4G/GSM). I had always assumed that AGPS would function properly on a TPT that had 3G/4G/GSM.


Now, I'm not sure if AGPS is even working for 3G/4G/GSM, please see the later posts on this thread for details.


The FTW solution? Fix the NTP_Server setting in GPS.conf (fixed in OTA2?) and get AGPS working for any type of valid network/internet connection i.e. wifi or 3G/4G/GSM.



01/25/2012 UPDATE - I Surrender, my will has been broken:

My gratitude and appreciation to Lenovo staff JameZ and bsnf for doing what they could to resolve this for us, it obvious that it wasn't their lack of caring or effort, but rather the Lenovo "system" that is broken.


I was shocked to see that there were no plans to include any of GPS bug fixes mentioned here (and in many other posts) in the upcoming OTA2 update. Shocked isn't even strong enough of a word. There have been countless reports of TPT having a greater than 10 minute Time to First Fix (TTFF) on this forum. Industry studies indicate that for every one person reporting a valid issue, there's likely hundreds experiencing the same issue.


Myself and others here have spent hours/months researching and diagnosing this problem, we've provided feedback, test results, logs, comparisons to competitor Android tablets and even video. Only to have Lenovo "engineering" stall and deny. 


There is at least one very obvious and easily fixable contributing factor to the the TPT's non-functioning GPS which is the improper configuration of the GPS.conf file NTP_Server attribute (the fix for which I will post below, again.). I was astonished that after waiting this long this simple fix WAS NOT SLATED FOR OTA2. I understand that bsnf is trying to get it in now if (and only if) OTA2 needs a new build done, and while I'm appreciative, that's not the point. This simple fix should have been pushed to us when it was discovered, over 3 months ago.


The TPT, in addition to the GPS.conf issue above, has another obvious problem with the AGPS data, 3G/4G/GSM and WIFI configuration that has been covered  here ad nauseum. Both ACER and ASUS addressed this very same issue with their Android tablets in a very timely manner. Why we are getting the run around, I am at a loss to explain.


As you may know, I ended up purchasing a Bluetooth GPS Receiver which has solved my TPT GPS issue completely, it saddens me that it was necessary after spending over $700 on the TPT and accessories.


My fight here is over......


Once again, the proper GPS.conf NTP_Server configuration for a US_Build TPT is as follows:


For the United States


At a minimum:


Or even better/more accurate:



12/01 UPDATE - JameZ with Lenovo is requesting information:

For those who are having this issue, appreciate if you can Private Message JameZ with your MTM (Machine Type & Model from "Settings > About Tablet") AND Serial Number. 


Please don't post here, PM JameZ: and click "send private message" link in the upper right.


If you are having GPS issues, please take a minute to provide this info so we can get this fixed! Thx.



11/15 UPDATE - JameZ with Lenovo is investigating:

Finally was able to track down the co-worker that is using the Acer Iconia A500 tablet that my company had evaluated prior to the TPT. Unfortuanately the video is of poor quality, but anyone familiar with the "GPS Test" app can clearly see the satellite "bars" and when a fix is obtained and the accuracy. (the brief flash of many satellite bars on the TPT at the beginning was cached from running the app previously).


  • Prior to recording, I had cleared the AGPS data on both units (using the "GPS Test" app) to simiulate a cold location & TTFF.
  • Wifi was OFF for both units.
  • Neither unit has 3G/4G/GSM capability.



11/15 UPDATE - JameZ with Lenovo is investigating:

Please see JameZ's post on page 5... He need's some model and build numbers for U.S. Users that are having GPS/Satellite fix issues



11/02 UPDATE - No Fix in "0075" OTA Update:

Sad to say that apparently the _0075 update has no GPS fix, or if it does it's not working.


I updated and tried it on my way home from work, 7+ minutes went by without a satellite lock and that was with a wireless internet connection active. I then used the free "GPS Test" app to download AGPS (Assisted GPS) data and had a lock/fix within a minute or so.


The NTP_Server IS STILL pointing to Asia in the GPS.conf file which is enough on it's own to keep the TPT from having a workable TTFF (Time To First Fix)... Now I'm starting to think that Lenovo included no AGPS functionality at all right from the launch. If they did, it's definitely not working judging from all the GPS complaints (here and on other forums).


Is it inconcivable to think that perhaps they left AGPS functionality out from the very beginning since there was no GSM capability? Certainly not something I would have done considering people/businesses will, and can tether their tablets wirelessly.


Anyway, GPS still pretty much useless in _0075 as far as I can tell.



10/18/2011 UPDATE:

As I have noted, this TPT was purchased by my company for evaluation by field represenitives, used mostly for GPS navigation (automobile) and data collection.


This past weekend, I attempted to use the TPT (wirelessly tethered to my phone for Internet) and Google Navigation for GPS directions from Raleigh NC to Stafford VA. I also brought my personal Tom-Tom GPS since I know the TPT GPS in it's current state is practically useless.


I had the TPT, my phone and the Tom-Tom all within 6 inches of each other on the dash (the TPT is in a mount). 

The TPT spent more than half of the 4 hour trip "Searching for a Satelitte Signal" while the Tom-Tom and my HTC Android phone had 5 satelitte's locked in the enitre trip, never losing the fix once. Just for the heck of it I tried the "fix" listed in this post when I stopped for gas, it had no effect. Not that I'm disrespecting the User that posted the fix, but even if it had worked, we shouldn't have to fumble around with a third party app workaround for a temporary fix on our "Business Class Lenovo Tablets".


As I stated before, we also evaluated the Acer A500 Android Tablet which also had the same GPS issues early on. Acer acknowledged the problem and  fixed the issue via an OTA update. 


It's disconcerning to me that Lenovo still hasn't acknowledged this defect.





This is my official post announcing an issue with the TPT and aquiring satellites.

I have posted this before, mostly in the "System Update Requests" thread and was instructed by Lenovo personnel to start a separate thread since this issue was left off the list of issues they are going to take a look at.


Some Background:

Six months ago my company decided to test some Android tablets for employees that travel a lot via car. One of the main purposes was the GPS and using Google Navigation. They installed tablet mounts in the cars and purchased a couple of Acer A500 Android Tablets to test (at the time Acer was the only tablet with a full size USB port). The Acer's were wirelessly tethered to our phones while on the road.

At launch the Acer tablet had an issue aquiring satelittes were it would take upwards of 5 minutes to get a lock at a "cold location" (meaning the GPS was turned on at a location it had never been before). Acer corrected this via a OTA update, after the update satelitte aquistion was under a minute even at "cold locations".


We are now trying TPT's and are seeing the very same GPS issue that we had with the Acer before they fixed it.  My point is; this is a fixable issue via software.


The TPT Issue:

The TPT is taking upwards of 5 minutes to get a satelitte fix in a "cold location" (and sometimes even in a know location). This is not an issue of satellites or line of sight as I have tested the TPT, the Acer 500, my HTC EVO phone and a Tom-Tom GPS all side by side and monitored their aquistion time. All had internet access, except for the Tom-Tom. All had GPS fixes in about a minute (or less) in know and cold locations, except for the TPT which clocked in at almost 5 minutes (with a shoddy fix at that).


When I finally do get a fix on the TPT, if I stop, turn off Navigation and then turn it back on without moving, the aquistion is quick. However move to a new location and turn it on.... 3 to 5 minutes or sometimes more to get a fix.


You may think this is nit-picky, but having to sit stopped for 5 minutes in your car waiting for a lock is annoying, especially when I could get a fix in under a minute (while moving) with the Acer. Sorry, but I got used to a working GPS fix with an Android tablet so now it sticks out like a sore thumb on the TPT.


This is fixable as Acer proved months ago and is not acceptable in a tablet being touted as "Business Class"


There is a helpful forum user here that has posted a workaround using a 3rd party app, with all due respect; also unacceptable that we have to resort to periodic running of a 3rd party app in an attempt to get a GPS fix that other tablets are having no issue with. For the record I tried the workaround, and noticed little or no improvement especially for "cold locations".


More unacceptable things;

  1. Calls to Lenovo support result in customers being told that it's because the TPT has no GSM or Internet? I'm aware of some devices downloading satelitte help via the internet, note my test above, the TPT had internet access and still took 5 minutes for a fix.
  2. Lenovo refusing to recognize this as an issue... It may not be as high a priority as other TPT issues, but it is an issue. Please at least acknowledge it so we know you are aware of it. Seriously, it's not hard to test. 




Please, if you have experienced the same or similar GPS issues as I have, with lack of and/or very weak satelittle locks/fixes post your experiences here in the hopes that Lenovo will take notice.


Thank You

Punch Card
Posts: 8
Registered: ‎10-04-2011
Location: Central Illinois
Message 2 of 416 (8,873 Views)

Re: GPS - TPT Acquiring Satellites Bug

I heartily agree with OP!  The GPS lock-on problem is unacceptable, I have been using GPS devices and devices with GPS for over 15 years and have never had this much trouble getting a satellite fix out in the open. Chipsets are not all that different, this must be a software issue.  Please fix. 

Posts: 62
Registered: ‎10-03-2011
Location: USA
Message 3 of 416 (8,840 Views)

Re: GPS - TPT Acquiring Satellites Bug


I posted this to the "Re: GPS Accuracy - Fix"  thread yesterday about my experience with the problem and the Lenovo reponse, but it seem worthwhile to make the connection here...



This fix worked for me!  My 1 week-old tablet could not find any satellites, although my Droid found 6 in the same place.

I thought there must be something wrong with the GPS so I called Lenovo support....   Beware,  the guy I got in Atlanta I do not think had even touched a tablet before, and barely had a clue how GPS worked.  After lengthly times on hold (puctuated with I suspect calls for help)  he confindently annouced that the GPS would not work because it did not have a WAN card.  When I explained that WAN or wireless had nothing to do with it, he remained unconvinced, and would not go any farther.  When I politely asked to speak to a supervisor, I was disconnected, and no one called me back.

Rather than waste my time again, I found this post, and voila... 6 satellites.  I'm not sure why this should be a problem, but seems to follow the same pattern as "why does the tablet report high battery use from cellular standby, when there is no phone."

Posts: 560
Registered: ‎09-29-2011
Location: * Alemania
Message 4 of 416 (8,741 Views)

Re: GPS - TPT Acquiring Satellites Bug

[ Edited ]



I hope we will get also a fix if the acer could get one

____Pen fixed? Smiley Sad____ Brightness Fixed Smiley Happy, Backup? Root neededSmiley Indifferent__LenovoappshopSmiley Sad_____
______(Did you know that you can form " no love " out of "lenovo" ?)________

Paper Tape
Posts: 2
Registered: ‎10-11-2011
Location: Canada
Message 5 of 416 (8,585 Views)

Re: GPS - TPT Acquiring Satellites Bug

You mentioned a work around in your post.  I'm having the same problem.  would you be willing to send me the URL of the work around?

Posts: 64
Registered: ‎09-19-2011
Location: Raleigh, NC - United States
Message 6 of 416 (8,569 Views)

Re: GPS - TPT Acquiring Satellites Bug

The "fix" I mentioned is here:


Although I am grateful to the forum user for posting the workaround, please note that this IS NOT a "fix". The apps needed to perform this even state that the procedure has to be performed periodically and personally I didn't see any performance improvement especially in "cold locations" (a new location where the GPS hasn't aquired satelittes before).


Not trying to hate on the "fix", just want to make it clear that it's not very useful for people that use their TPT as a GPS for navigation daily and I would like to keep up the pressure for Lenovo to acknowledge and fix this issue on their "Business Class" Android tablet


The last thing we need is Lenovo thinking this is low priority because there is a "workaround", because there isn't.

Punch Card
Posts: 23
Registered: ‎09-28-2011
Location: Michigan
Message 7 of 416 (8,463 Views)

Re: GPS - TPT Acquiring Satellites Bug

I think I may have found a contributing factor to the long lock on times.


Looking at gps.conf in /system/etc, it can be seen that the NTP_SERVER is set to

Looking at other android devices, faster lockon time can be achieved by setting this to the closest ntp server found on this site:


Unfortunately there is no way to change this file without root access...


For reference, my TPT is running firmware build ThinkPadTablet_A310_02_0024_0065_US.

Posts: 64
Registered: ‎09-19-2011
Location: Raleigh, NC - United States
Message 8 of 416 (8,367 Views)

Re: GPS - TPT Acquiring Satellites Bug

[ Edited ]

Looking at other android devices, faster lockon time can be achieved by setting this to the closest ntp server found on this site:

I think I may have found a contributing factor to the long lock on times.


Looking at gps.conf in /system/etc, it can be seen that the NTP_SERVER is set to




Is anyone at Lenovo listening? I don't know if this is the answer, but it is at least a place to start. This is a definite, reproducable issue that needs to be fixed.



Token Ring
Posts: 153
Registered: ‎09-04-2011
Location: USA
Message 9 of 416 (8,324 Views)

Re: GPS - TPT Acquiring Satellites Bug

Lenovo hasn't responded to any of the specific issue threads with acknowledgement of the bugs or timelines for a fix. I think we need to be more demanding in this area, as it seems like they need a prod. The other thinkpad forums have Lenovo engineering responses...


The software workaround requires "gps fix" which spams the notifications bar in free mode.

Posts: 181
Registered: ‎08-25-2011
Location: Kansas
Message 10 of 416 (8,316 Views)

Re: GPS - TPT Acquiring Satellites Bug

I actually use GPS Status which does not spam.


I used GPS fix once and have not used it since.


FYI - I just did a test without wifi and was able to get a fix on 8 satellites in less than one minute.

Top kudoed Authors