Showing results for 
Search instead for 
Do you mean 
Posts: 179
Registered: ‎06-02-2009
Location: California
Message 261 of 416 (714 Views)

Re: GPS - TPT Acquiring Satellites Bug



at first the gps would not work on a fresh reset. i downloaded gps toolbox and gps fix to no avail. but after i turn on location by wireless network, let gps fix, then turn it off so its just gps enabled in settings, it is able to get a good lock within 5 meters.


now i am at a friends and gps wont get a fix. enabled location by wireless network, let it lock in maps, disabled it, still no fix with only gps on... went outside for a smoke, took tablet with me, it fix right away.



Token Ring
Posts: 153
Registered: ‎09-04-2011
Location: USA
Message 262 of 416 (703 Views)

Re: GPS - TPT Acquiring Satellites Bug

bsnf, thanks for illuminating the GPS fix issue, obviously Lenovo needs more people like you in the support department, as this kind of honestly builds user trust (which is hovering around zero on my end at the moment). I second the request for serial numbers of affected units. It seems like Lenovo at least owes it's customers a notice informing them of those affected by a physically faulty GPS and offering expedited repair.
Token Ring
Posts: 153
Registered: ‎09-04-2011
Location: USA
Message 263 of 416 (699 Views)

Re: GPS - TPT Acquiring Satellites Bug

Just an update, Lenovo phone support in the US claims that there is no know GPS hardware defect, but oddly does offer to replace the GPS hardware if I send in the unit. This is why I have absolutely no faith in Lenovo support... they are either lying or incompetent or some mix of the two. If there is a problem, tell your support reps and have them tell the users. Don't play/be stupid.
Posts: 131
Registered: ‎12-12-2011
Location: Japan
Message 264 of 416 (697 Views)

Re: GPS - TPT Acquiring Satellites Bug

[ Edited ]

I asked here before, and others have tried too, about who has what type of unit (WWAN or WiFi only) and the state of their GPS. We could find no one with a WiFi only unit who had a functioning GPS.


Why don't one of you Lenovo reps just make a poll asking us? You keep saying you don't know the problem, and saying it is fixed, but you haven't even asked in an effective way.


We could make a poll, but this is your site. If you can't make a poll on this site, then we can find a workaround.


From the outside, this looks like stonewalling. No one had told us before that some early production runs had hardware problems that were later fixed. The secrecy is undermining our trust in Lenovo.

¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸ Lenovo ThinkPad Tablet 1838CTO (not rooted, from Lenovo Direct Japan); WiFi-only model (w/ Galaxy Note LTE as tether); 64GB system memory with Transcend 64GB Class 10 SDXC card; ThinkPadTablet_A310_02_0039_0090_JP rom; GPS works (slowly) after 2012/04 return (power button had broke); Camera will not focus. (note: I have not re-tested these since the ICS update 2012/06/21) ¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸

Punch Card
Posts: 36
Registered: ‎12-28-2011
Location: Switzerland
Message 265 of 416 (629 Views)

Re: GPS - TPT Acquiring Satellites Bug

[ Edited ]

Some days ago I had a clue that at least my GPS problems appear only after some time of usage of the TPT. Here the summary of my tests this weekend:


Friday evening:

I did a cold restart, started "GPS Status & Toolbox", waited ~10 minutes (it is important not putting the app in the background): GPS worked!


I cleared AGPS data, tested with Wifi on and off, used the tablet "as usual", started and closed every app I am frequently using: After 3 hours (!) of testing I have to admit "GPS works" as one would expect.


I was busy with different things, I just charged the TPT and did a quick check in the evening: GPS still worked!


I started "GPS Status & Toolbox" again. No chance to get GPS working - it is completely dead! Looking at the screen I noticed that the GPS icon is now missing in the honeybar (see picture below) and it does not appear in any other GPS related app (Google Maps, GPS Test, ...).


Summary: At least in my case the GPS problems appear only after some time. Now it makes sense to me why GPS was not working at all in my former tests: I never do cold restarts and usually avoid to turn the tablet completely off.


Edit: I forgot to say that after a restart GPS is working again... until?


(18382DG, 64GB WWAN, 0089_WE, never ever rooted, no SIM card installed)


Link to picture


Moderator note; picture(s) totalling >50K converted to link(s) Forum Rules

Lenovo Staff
Posts: 3,848
Registered: ‎10-29-2009
Location: NC
Message 266 of 416 (580 Views)

Re: GPS - TPT Acquiring Satellites Bug



Thank you for your very helpful post.  I think in your case your GPS hardware/antenna are fine.  There must be some software problem that causes your GPS to stop working over time.  We will investigate this.


If you could also please follow-up by checking your GPS function every couple of days and let us at what point it stops working (since you last cold-started on Friday night), that would also be very helpful.


Thanks again for your help.

Token Ring
Posts: 108
Registered: ‎06-30-2010
Location: Juneau, Alaska
Message 267 of 416 (557 Views)

Re: GPS - TPT Acquiring Satellites Bug

[ Edited ]

Here is an example of my TPT w/WWAN getting a GPS fix after a cache-cleared cold boot. 64 seconds, indoors, no AGPS, no wifi, no wwan, no cache.


Edit: 1838CTO, US 32GB wifi-only, Shipped Dec. 9, 2011, Gobi3000/WWAN added later, never serviced.

Token Ring
Posts: 130
Registered: ‎10-28-2011
Location: Colorado
Message 268 of 416 (509 Views)

Re: GPS - TPT Acquiring Satellites Bug

[ Edited ]

My experience with a TPT w/WWAN.  90 seconds to get a fix on 4 satellites, outdoors, no AGPS, no WWAN, no cache.  I got a fix on 10 satellites in about 4 minutes. My work location is about 6000 feet elevation.


Edit: 1838CTO, US edition, purchased on 29SEP2012, received mid-OCT2012.

Posts: 79
Registered: ‎07-21-2009
Location: DE
Message 269 of 416 (503 Views)

Re: GPS - TPT Acquiring Satellites Bug

Guys, thanks for your reports. I think it would be helpful, if you tell us, when you're hardware was purchased (if new), because someotherguy said that there were hardware changes in the past.


P.S. My tablet is from August 2011 and got a new mainboard in October 2011 due to a sd card slot mechanical failure
working with W541, T410 2537AF8, Tablet 1838-2CG, caring for R61 7732-NDG, T530 2924-GJ4, L512 4444-4NG, R61i 7650-D6G, X60s 1703-3JG, X40 2371-8EG
Posts: 1,773
Registered: ‎08-17-2011
Location: USA
Message 270 of 416 (434 Views)

Re: GPS - TPT Acquiring Satellites Bug

[ Edited ]

someotherguy wrote:


As I already explained to pghFL, if you can't obtain a fix no matter what you do, then that's not a software issue - it's a hardware issue.  If you think there is some software issue, then tell me how to reproduce it.

I am done. No is listening to what is being said by anyone who has reported problems. We have been reporting these problems from the beginning, only to be ignored. I have been a staunch supporter of the TPT all along, even recommending it. Today it ends. Not long from now it will go in the trash. I have ever seen such poor design, and such poor customer support. Shame on you Lenovo.
Don't get mad, get root.
Top kudoed Authors