Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Highlighted
Blue Screen Again
Posts: 7
Registered: ‎04-17-2011
Location: United States
0 Kudos
Accepted Solution

Cannot get Wireless to work

I have a brand new W520 for my company and we cannot get wireless to work. Here is what I tried.

  1. Clean install of Windows 7 Professional
  2. Installed the ThinkVantage tools, including Access Connections.
  3. Installed the drivers from the Lenvo Support site. Had to install manually as Lenovo System Update would not return anything for me to install, even when I had a ton of missing drivers.
  4. Installed the ThinkPad Wireless LAN drivers for the wireless card in my system. I have the ThinkPad b/g/n card.

 

  1. No wireless adapter is found for the wireless, just the Intel 82579LM Gigabit Network Connection which works fine for the wired connection.
  2. The wireless radio is on. I flipped the switch mutliple times. The screen seems to flicker when I flip it but nothing happens.
  3. ThinkVantage Access Connections says "No supported wireless adapters are installed on the system" when I click "Manage Wireless Radio".
  4. I verified the card is seated properly and the connections are all tight.
  5. I ran a PC Doctor scan (from boot disk) against the wireless card and it Passed.

In Device Manager I have two items remaining that show issues.

  1. Base System Device
  2. Network Controller

I can't seem to resolve those two items in device manager with any of the drivers I've found on the Lenovo support site.

 

Any suggestions?

Community SuperMod
Posts: 3,869
Registered: ‎04-25-2008
Location: San Francisco
0 Kudos

Re: Cannot get Wireless to work

Hi egregorich, and welcome to the Lenovo User Community!

 

The Lenovo ThinkVantage System Update servers are down for maintenance. Try again later.

 

15th April 2011

TVSU & TVUR update services is unavailable during scheduled server maintenance from Apr 16(11am) to Apr 17 (9am) EST. For more details, please refer to Lenovo Support Site.

I don't work for Lenovo. I'm a crazy volunteer!
Blue Screen Again
Posts: 7
Registered: ‎04-17-2011
Location: United States
0 Kudos

Re: Cannot get Wireless to work

Thanks. I realized that right after I submitted my post. I'm pretty sure I tried the System Update as early as Thursday afternoon. and it never returned any updates for me.  I'll give it another try tomorrow.

SCSI Port
Posts: 39
Registered: ‎11-03-2009
Location: Sacramento, CA
0 Kudos

Re: Cannot get Wireless to work

[ Edited ]

Try Fn-F5 and Select the Wireless Radio Tab and toggle the Radio on.

W540 20GBCTO, Ultra Dock, W520, 4270CTO, W510, 4318CTO; (2)T500, 2081CTO; Y560, 064657U, Y530, 405166U; T61p, 6465CTO, A31p, and L2461x Multi-touch Monitor, Mini Dock Plus Series 3
Blue Screen Again
Posts: 7
Registered: ‎04-17-2011
Location: United States
0 Kudos

Re: Cannot get Wireless to work

When I try Fn-F5 I get "No supported wireless adapters are installed on the system".
Posts: 3,220
Registered: ‎07-31-2008
Location: Pakistan
0 Kudos

Re: Cannot get Wireless to work

Hi egregorich,


Check in the BIOS whether it's enabled, F1 to enter the BIOS, it should be under Config -> Networks.


Also, can you let us know what does the sticker on the card say? Does it say Intel Wimax 5150 or 5350? 


Try the following driver, the one on this support page is incorrectly linked as ThinkPad driver when it's not (or unless the ThinkPad card in your system is from Intel which I highly doubt):- http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-76909


Keep us posted.


 

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Blue Screen Again
Posts: 7
Registered: ‎04-17-2011
Location: United States
0 Kudos

Re: Cannot get Wireless to work

[ Edited ]

When I go to the BIOS this is all I see under Config > Network

  • Wake on LAN [AC Only]
  • Ethernet LAN Option ROM [Enabled]

I browsed around and didn't find anything else related to a wireless radio.

 

My card is the the ThinkPad b/g/n card and it say's on the sticker it is Realtek.

 

I actually already installed the driver from the link you provided out of trial and error. I was thinking it seemed like the correct one. I uninstalled/reinstalled the driver just to be sure but still not difference.

 

Thanks for the quick responses! I'm still stumped.

Posts: 3,220
Registered: ‎07-31-2008
Location: Pakistan
0 Kudos

Re: Cannot get Wireless to work

I just downloaded the driver and ran it, I've noticed that they've used the old lenovo tradition where the driver needs to be run from C:\Drivers\ in order to be successfully installed. I suggest going to C:\DRIVERS\WIN\WLANRLTK and running the .exe setup for Win 7. 

 

Let us know how it goes.

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Posts: 3,220
Registered: ‎07-31-2008
Location: Pakistan
0 Kudos

Re: Cannot get Wireless to work

Oh well, you did uninstall and reinstall the driver, you can only do so when the driver is successfully installed. Scratch my above suggestion.


I think the card is faulty since it's not being detected by the BIOS. AFAIK when the card is detected, there is always an option in the BIOS to it turn off/on.


If I were you, my next step would be to call lenovo support.

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Blue Screen Again
Posts: 7
Registered: ‎04-17-2011
Location: United States
0 Kudos

Re: Cannot get Wireless to work

[ Edited ]

Thanks. I think Lenovo Support is the next step as well.