Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center

Setting W520 GPU in BIOS to Maximize Win7 GPU Performance Score

0 Kudos
Click ►
Started ‎07-21-2011 by
Modified ‎07-21-2011 by


I just bought a W520, i7-2620M, 4G, 2000M 2G, 320G

Win7 Performance Score as following:

CPU: 7.1

Memory: 5.9

Graphics: 4.6

Gaming Graphics: 6.9

Primary Hard Disk: 5.9


I feel that Graphics Score at 4.6 is less than expected, since I checked some test blog and Graphics Score should be 6.9, the same as Gaming Graphics Score.  I understand that this may due to the Optimus technology at work and as the benchmark runs it is returning different scores, but if I want to ensure I am getting 6.9 scores or maximum at all times, how can I configure?



When the GPU function in BIOS is set to Optimus, the system will automatically determine which card to use. The Desktop Graphics assessment is for Aero and normal productivity use, which uses the Intel GPU instead of the Nvidia GPU, which results in a lower score.  


This is as expected and reflective of the generally desired function to maximize battery life, while switching to the Nvidia dedicated GPU when under high graphic demand.  


If you wish to lock in high performance GPU all the time, at the expense of reduced run time on battery, Press F1 when booting to enter BIOS.


1) Under Display options, set the GPU to Discrete Graphics

2) Set the OS detection option under it to Disable

3) Save and Exit settings.

4) Reboot, let Windows install drivers


Run the assessment again. That should get you 6.9 on both graphics and gaming graphics although the battery run times will be much less than previously experienced.

by Neo_Ocelot on ‎05-14-2014 05:37 AM

Wow, Thank you!


I was trying to do exacly this to fix a glitch ive been having where when the graphics switch to the dedicated graphics card the brightnss would change.


Worked greatSmiley Very Happy


Thanks again!