Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
njb
Blue Screen Again
Posts: 72
Registered: ‎03-12-2012
Location: Guernsey
0 Kudos
Accepted Solution

System updater

After reading this post

 

http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/W520-and-ThinkVantage-System-Update/td-p/71091...

 

I have come to wonder which are worth installing using system update. I have a problem where something that lenovo installs blocks the use of a program I use regularly. On the out of the box W520 this program had to be started manually every time. When I did a windows install clean it worked perfectly, however when i did the update checking all boxes on the lenovo updater it once again started to become blocked and require manual install.

 

Should I just defer all updates and install them one by one to identify the prrogram causing the problem?

 

Has anyone got any lenovo updates that they consider I shouldnt be without?

 

Thanks

Guru
Posts: 8,730
Registered: ‎12-26-2009
Location: Vancouver
0 Kudos

Re: System updater

The basics you need are the Hotkey package and Power Management driver. Less critical ones include device drivers like wifi, BT, graphics card, etc. Various ThinkVantage tools aren't essential, but are nice.

Which program are you having a conflict with?
W520: i7-2720QM, Q2000M at 1080/688/1376, 21GB RAM, 500GB + 750GB HDD, FHD screen & MB168B+
X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
Y3P: 5Y70, 8GB RAM, 256GB SSD, QHD+ screen
njb
Blue Screen Again
Posts: 72
Registered: ‎03-12-2012
Location: Guernsey
0 Kudos

Re: System updater

It is a database program. I initially thought the MS SQL 2005 express server preloaded on the thinkpad was causing the issue. When I installed plain windows and updated windows the program worked, but when I installed every possible driver from lenovo using updater it once again stopped working properly.

 

The program will work, as in the database runs and the complementary program can use it, just it wont start the server automatically on boot, you have to do it manually every time which is annoying.


I now think it is one of the lenovo security programs so I am having to do another reinstall and then pick and choose the minimum amount of drivers through system update.

Guru
Posts: 1,045
Registered: ‎04-20-2008
Location: Cary, NC
0 Kudos

Re: System updater

Remove RapidBoot and try again. It may be the cause of the issue.
W520, i7-2820QM, BIOS 1.42, 1920x1080 FHD, 32 GB RAM, 2000M NVIDIA GPU, Samsung 850 Pro 1TB SSD, Crucial M550 mSata 512GB, WD 2TB USB 3.0, eSata Plextor PX-LB950UE BluRay

W520, i7-2760QM, BIOS 1.42 1920x1080 FHD, 32 GB RAM, 1000M NVIDIA GPU, Crucial M550 512GB mSata SSD, Hitachi 500GB HDD, WD 2TB USB 3.0
njb
Blue Screen Again
Posts: 72
Registered: ‎03-12-2012
Location: Guernsey
0 Kudos

Re: System updater

Ah, yes that sounds like a good idea. I will have to factory install, again... At the moment I have only a clean copy of W7 installed.
Guru
Posts: 1,045
Registered: ‎04-20-2008
Location: Cary, NC
0 Kudos

Re: System updater

RapidBoot delays some automatic processes from starting at startup. You were installing RapidBoot 1.12?

W520, i7-2820QM, BIOS 1.42, 1920x1080 FHD, 32 GB RAM, 2000M NVIDIA GPU, Samsung 850 Pro 1TB SSD, Crucial M550 mSata 512GB, WD 2TB USB 3.0, eSata Plextor PX-LB950UE BluRay

W520, i7-2760QM, BIOS 1.42 1920x1080 FHD, 32 GB RAM, 1000M NVIDIA GPU, Crucial M550 512GB mSata SSD, Hitachi 500GB HDD, WD 2TB USB 3.0
njb
Blue Screen Again
Posts: 72
Registered: ‎03-12-2012
Location: Guernsey
0 Kudos

Re: System updater

I dont know. I just had problems with the lenovo I received and it had all the preloaded thinkvantage etc. When using plain W7 it worked perfectly so the problem is attributed to the Lenovo products.

Basically the "services" section of windows is set to automatic for said program, bu never actually starts. It really sounds like Rapid boot coule be the problem. I will check it as soon as I get home.

Do I just disable it through the BIOS?
Guru
Posts: 1,045
Registered: ‎04-20-2008
Location: Cary, NC
0 Kudos

Re: System updater

Just don't install RapidBoot. Alternatively, uninstall it from the Control Panel.

W520, i7-2820QM, BIOS 1.42, 1920x1080 FHD, 32 GB RAM, 2000M NVIDIA GPU, Samsung 850 Pro 1TB SSD, Crucial M550 mSata 512GB, WD 2TB USB 3.0, eSata Plextor PX-LB950UE BluRay

W520, i7-2760QM, BIOS 1.42 1920x1080 FHD, 32 GB RAM, 1000M NVIDIA GPU, Crucial M550 512GB mSata SSD, Hitachi 500GB HDD, WD 2TB USB 3.0
Highlighted
njb
Blue Screen Again
Posts: 72
Registered: ‎03-12-2012
Location: Guernsey
0 Kudos

Re: System updater

Thanks Harrisb.

Installation of RapidBoot did the trick.

Cheers
Nick
Guru
Posts: 1,045
Registered: ‎04-20-2008
Location: Cary, NC
0 Kudos

Re: System updater

Just for the record, you did not install RapidBoot which solved your issue, correct?

W520, i7-2820QM, BIOS 1.42, 1920x1080 FHD, 32 GB RAM, 2000M NVIDIA GPU, Samsung 850 Pro 1TB SSD, Crucial M550 mSata 512GB, WD 2TB USB 3.0, eSata Plextor PX-LB950UE BluRay

W520, i7-2760QM, BIOS 1.42 1920x1080 FHD, 32 GB RAM, 1000M NVIDIA GPU, Crucial M550 512GB mSata SSD, Hitachi 500GB HDD, WD 2TB USB 3.0