Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Blue Screen Again
Posts: 2
Registered: ‎12-05-2008
Location: Washington
0 Kudos

W500 Drivers Missing

I am running a W500 4063-A46 model running Windows Vista enterrpise 64 bit. It seems that ThinkVantage has not installed all of the drivers for this system. The 4 that are missing are:

 

Base System Device  - \Device\NTPNP_PCI0030

  • PCI\VEN_1180&DEV_0592&SUBSYS_20CA17AA&REV_11
    PCI\VEN_1180&DEV_0592&SUBSYS_20CA17AA
    PCI\VEN_1180&DEV_0592&CC_088000
    PCI\VEN_1180&DEV_0592&CC_0880


Base System Device  - \Device\NTPNP_PCI0029

  • PCI\VEN_1180&DEV_0843&SUBSYS_20C917AA&REV_11
    PCI\VEN_1180&DEV_0843&SUBSYS_20C917AA
    PCI\VEN_1180&DEV_0843&CC_088000
    PCI\VEN_1180&DEV_0843&CC_0880

PCI Serial Port - \Device\NTPNP_PCI0005

  •  PCI\VEN_8086&DEV_2A47&SUBSYS_20EC17AA&REV_07
    PCI\VEN_8086&DEV_2A47&SUBSYS_20EC17AA
    PCI\VEN_8086&DEV_2A47&CC_070002
    PCI\VEN_8086&DEV_2A47&CC_0700

PCI Simple Communications Controller - \Device\NTPNP_PCI0003

  •  
    •  
      • PCI\VEN_8086&DEV_2A44&SUBSYS_20E617AA&REV_07
        PCI\VEN_8086&DEV_2A44&SUBSYS_20E617AA
        PCI\VEN_8086&DEV_2A44&CC_078000
        PCI\VEN_8086&DEV_2A44&CC_0780
         

 

I would appreciate any suggestions on how to resolve these.

 

Thanks!

Mike

 

 

 

med
Punch Card
Posts: 19
Registered: ‎10-01-2008
Location: Minnesota
0 Kudos

Re: W500 Drivers Missing

[ Edited ]

The first device is the Ricoh Memory Stick Host Controller

Second is the Ricoh SD/MMC Host Controller

Download the 4in1 driver and extract to a folder.  Update the drivers from device manager and chose search specfic folder and point it to the 4in1 folder.  There are a couple folders that have drivers so it may take a couple shots to get the proper one. 

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-68053

 

I belive the 3rd and 4th devices are for Intel AMT, try these drivers

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-70317

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-70313

Message Edited by med on 12-06-2008 06:22 AM
Blue Screen Again
Posts: 2
Registered: ‎12-05-2008
Location: Washington
0 Kudos

Re: W500 Drivers Missing

Thanks for the help and such a complete reply it was great!

 

These links solved all 4 missing driver issues. The only thing I would add is that once I ran the .exe for each I had to then use Device manager search to find and implement all the drivers.

 

You rock!

 

What's DOS?
Posts: 1
Registered: ‎01-26-2009
Location: Oregon, USA
0 Kudos

Re: W500 Drivers Missing

[ Edited ]

Same problem for the last two PCI related devices.  But I am running Windows Server 2008 X64 (as a workstation).  After downloading and installing the two PCI related links that were provided, I get an error message on both that the operating system is not supported!  Any other suggestions?

 

Thanks!

Message Edited by JeffConeCpa on 01-26-2009 11:41 AM
Paper Tape
Posts: 2
Registered: ‎03-16-2010
Location: USA
0 Kudos

Re: W500 Drivers Missing

These drivers links really help me alot. I was stuck on this and just fixed it after go throwing these links.

williambush