Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Lenovo Staff
Posts: 3,570
Registered: ‎07-11-2010
Location: Malaysia
0 Kudos

Re: W510 - Cannot go into sleep mode


I am not sure how to disable the item you mentioned, therefore am unable to comment on your question, maybe other forumers can advice on this.

Also it could be your MB replacement was before the fix was released. If you were to check the WWAN issue thread there is an ongoing discussion of the WWAN issue and the phantom touch issue. Therefore my advice is to send your current laptop for service.


Check out the Community Knowledge Base for hints and tips.

Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

X240 | 8GB RAM | 512GB Samsung SSD

Token Ring
Posts: 224
Registered: ‎07-19-2010
Location: Colorado
0 Kudos

Re: W510 - Cannot go into sleep mode

Interesting update:


I turned "Hybrid Sleep" mode on in Power Manager, and now when the computer fails to go to sleep, it just essentially "wakes up" and shows the login screen. Before, it would crash completely, and Windows would say it wasn't shut down successfully.


So now i have a computer that goes to sleep more slowly with Hybrid Mode, but doesn't totally crash. I guess we're making progress...

Paper Tape
Posts: 2
Registered: ‎06-07-2011
Location: Zurich
0 Kudos

Re: W510 - Cannot go into sleep mode

Hello Guys


long time ago since the last post was written. We have the same Problem as well with the Sleep Mode on Lenovo w510¨.

is there a solution now available to fix this problem?

Hybernate does work , but the sleepmode doesen't !!?? in my case when i push de sleep button (FN and F4) the screen goes into dark, the harddisk is doing something (no idea what the system does at this moment) and then iam not able to get back my screen, i need to power off and power on to be able working again.

When i type in CMD powercfg -A , i get following results:


The following sleep states are available on this system: Standby ( S3 ) Hibernat
e Hybrid Sleep
The following sleep states are not available on this system:
Standby (S1)
        The system firmware does not support this standby state.
Standby (S2)
        The system firmware does not support this standby state.


I hope to find a solution who works, we also have allready the newest w520 modell in our company and it seems to work

Token Ring
Posts: 224
Registered: ‎07-19-2010
Location: Colorado
0 Kudos

Re: W510 - Cannot go into sleep mode

Just to let everyone know, I do believe I've solved this problem.


I figured out that putting the computer to hybrid sleep changes some things. Instead of the machine crashing once it's asleep, the machine would simply wake up. It seemed to be the same cause, but different results based on type of sleep.


I then queried Windows as to what just woke up the computer, and I found that the ThinkPad modem and my HID-compliant mouse woke the computer up just milliseconds after it went to sleep. I prevented these devices from waking the machine up in Device Manager, and put the computer to sleep dozens of times. No issue.


Now I have the machine going to normal sleep and I haven't had the crashing issue. The whole time, it was two devices immediately waking the computer, making it crash in the normal sleep mode. 

Fanfold Paper
Posts: 7
Registered: ‎08-01-2011
Location: Croatia
0 Kudos

Re: W510 - Cannot go into sleep mode

Hope this helps!

Mine BIOS is latest 1.38.


I have try

(osfh02ww.exe) and put "USBPMon.reg". 


Shut down lap and restart from cold boot-and this worked for me!


 This is Windows 7 also fix (AFAIK).


And of course have hiberfil.sys enabled "powercfg -h on".


All looks that sleep on W510 is not really working but hibernation way of sleep does. I'd like to be this confirmed from Lenovo.


What's DOS?
Posts: 1
Registered: ‎12-30-2011
Location: USA
0 Kudos

Re: W510 - Cannot go into sleep mode

I had the same exact issue, but the culprit was VirtualBox.  I'm running Windows 7 64 host, and an Ubuntu guest.  Apparently I enabled a USB Device filter that caused the problem.  After removing the filter, the computer sleeps as normal.