Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
eos
802.11n
Posts: 452
Registered: ‎06-30-2011
Location: gibraltar
0 Kudos

W520 Docking station not working with exterma DP monitors

It used to work.  Recently, however, if I reboot the thinkpad in the doc, I lose the two DP external monitors.

 

I.e. the machine boots on internal display, and if I go to windows "screen resolution" I can see the names of the two external monitors greyed out with the wrong resolution.

 

If I do a WINDOWS-P, then extend to the second one, then make the third the "main display", then disable the internal panel, Im back to where I should be.  If I sleep and wakeup, it keeps the arrangement.  If I dock the notebook while running, it automatically jumps to the correct arrangeement (i.e. internal panel off, two external displays extended).

 

Its only if I boot when in in the doc it fails, and I ahve to wait for 5 minutes fo tthe machine to boot, then faf about for another minute to get the displays working.  I have never had this problem with Dell laptops in docking stations with external displays.

 

I dont expect a solution - and I accept im probably the only person who gets this error.

 

The machine cant reboot (I can only shutdown and cold boot) since I enabled password protection for the HD in the bios, so I cant test that.

Bit Torrent
Posts: 2,401
Registered: ‎04-08-2011
Location: USA
0 Kudos

Re: W520 Docking station not working with exterma DP monitors

With Optimus enabled, the W520 and other Optimus machines lose their brains on a restart.  This is present in the T420 and the T420S, too.

 

I have just gotten used to doing shutdowns.