Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Ctrl-Alt-Del
Posts: 8
Registered: ‎01-26-2011
Location: Toronto
0 Kudos
Accepted Solution

w510 Video Driver Crashing - Is it ok to use the latest drivers from NVIDIA

About once per week my NVIDIA driver crashes and Windows recovers. The installed drivers are 257.38 which are the latest from Lenovo. But NVIDIA has 266.58 available and I would like to see if that fixes the problem. Is it ok to download and install a driver from NVIDIA?

Highlighted
WWAN
Posts: 386
Registered: ‎08-03-2009
Location: UK
0 Kudos

Re: w510 Video Driver Crashing - Is it ok to use the latest drivers from NVIDIA

It should work - give a try.

 

I'm using NVIDIA's 266.58 on my W701. It seems more stable than all previous 2xx releases.

Ctrl-Alt-Del
Posts: 8
Registered: ‎01-26-2011
Location: Toronto
0 Kudos

Re: w510 Video Driver Crashing - Is it ok to use the latest drivers from NVIDIA

Thanks hazart. I'll give it a try.
Ctrl-Alt-Del
Posts: 8
Registered: ‎01-26-2011
Location: Toronto
0 Kudos

Re: w510 Video Driver Crashing - Is it ok to use the latest drivers from NVIDIA

Installed NVIDIA 266.58 on my W510 and seems to be working fine. Don't know yet whether it has fixed the crashing issue.
Ctrl-Alt-Del
Posts: 8
Registered: ‎01-26-2011
Location: Toronto
0 Kudos

Re: w510 Video Driver Crashing - Is it ok to use the latest drivers from NVIDIA

I can report that after 4 weeks I have not experienced any more video crashes, so the new version seems to have fixed the problem!