cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
joseguillen
Paper Tape
Posts: 6
Registered: ‎09-04-2015
Location: España
Views: 5,305
Message 11 of 19

Re: 2103 detection error on ssd0 (m.2)

Many, many thanks mate! After flashing the new BIOS the laptop is working perfectly again Smiley LOL

 

Thank you so much for your prompt responses. I owe you, at least, 3 beers Smiley Happy

 

Best regards.

Community SeniorMod
Community SeniorMod
Posts: 11,878
Registered: ‎06-06-2011
Location: RU
Views: 5,301
Message 12 of 19

Re: 2103 detection error on ssd0 (m.2)

You are welcome!

Glad to see your success and good mood )))



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

unity303
Paper Tape
Posts: 1
Registered: ‎09-18-2015
Location: Palo Alto, CA
Views: 5,280
Message 13 of 19

Re: 2103 detection error on ssd0 (m.2)

SOLVED as well, Thanks x220forme! Smiley Very Happy

My error message was the same but due to a BIOS update so I needed different steps to fix.

What happened: Updated my X1 BIOS today

  1. Note: I am running a non-stock SSD (Crucial M500 480GB SATA 6Gbps M.2 Internal SSD)
  2. It was working fine for many months, until Lenovo System Update suggested the critical flash to the latest BIOS.
  3. After flashing the BIOS and rebooting, I also got the dreaded message: "2103: Detection error on SSD0 (M.2)"
  4. I could no longer boot to Windows 8. Again, same problem as OP, just different steps to reproduce.



Step-by-step details to resolve:

Since my configuration was different here is what I had to do:

 

  1. Enter BIOS > tab to [Security] > Secure Boot > select [Disabled]
  2. Tab to [Startup] >UEFI/Legacy Boot > select [Both]
  3. Tab to [Restart] (but don't restart yet!) > set [OS Optimized Defaults] to [Disabled] > Save Changes > Yes
  4. Tab to [Config] > Power > Disable Built-In Battery > Yes
  5. Notice laptop powers down.
  6. Disconnect the AC wall charger for 5 seconds
  7. Reconnect the AC wall charger
  8. Power on. At this point the Built-In Battery will be re-enabled
  9. Notice as your glorious OS logo appears on the screen
  10. Dance the the happy dance


If you still have problems with different scenarios, please reply and I'll try to help pinpoint why this happens with your specific config. I dealt with this issue many times, on many X1's after upgrading the SSD to Crucial and Transcend 512GB SSDs.

Good luck.


@x220forme wrote:

Disable the battery, charger.
Remove the drive. It's for the safety as I mentioned, to prevent the system to freeze during the flasing process. That'll save laptop to be breaked.

Once the flashing process will complete, laptop should be powered off itself.



 

redzlord
Paper Tape
Posts: 2
Registered: ‎09-30-2016
Location: PH
Views: 4,520
Message 14 of 19

Re: 2103 detection error on ssd0 (m.2)

Hello,

 

I got the same issue on my X1 Carbon 2nd Gen. I have tried to follow all the steps above but I am still getting the error.

 

Need to fix this issue asap. Please help.

 

Thank you.

 

redzlord

NZcarbon
What's DOS?
Posts: 1
Registered: ‎05-03-2017
Location: NZ
Views: 3,659
Message 15 of 19

Re: 2103 detection error on ssd0 (m.2)

I'm having the same issue too.  I've tried updating the bios but I just keep getting the message that a bios upgrade is not needed.

??

gabzor
Paper Tape
Posts: 1
Registered: ‎05-17-2017
Location: US
Views: 3,556
Message 16 of 19

Re: 2103 detection error on ssd0 (m.2)

I have done a BIOS update to 1.16 and it still boots up with the 2103: Detection error on SSD0 (m.2).

 

I've also done the steps of disabling things in the BIOS as previously posted, but it still boots into the same as above.

 

I'm using a brand new Samsung 960 m.2 SSD for a brand new installation for Windows 10 Pro.

 

The Laptop in question is a 3rd generation touchscreen version of the X1 Carbon series

 

Any help would be helpful

 

Thanks,

 

Gabzor.

 

LogJM
Paper Tape
Posts: 2
Registered: ‎06-02-2017
Location: FR
Views: 3,469
Message 17 of 19

Re: 2103 detection error on ssd0 (m.2)

Hi,

 

I'm in the same situation.. please help.

regards,

JM

g0g0br0wnchild
What's DOS?
Posts: 1
Registered: ‎09-01-2018
Location: PH
Views: 1,362
Message 18 of 19

Re: 2103 detection error on ssd0 (m.2)

Thank you very much sir!  Problem solved! Smiley Happy

TyllerD
What's DOS?
Posts: 1
Registered: ‎04-06-2019
Location: AT
Views: 439
Message 19 of 19

Re: 2103 detection error on ssd0 (m.2)

Hello,

I have a Lenovo ThinkPad Carbon X1 gen3 and received the 2103 SSD m.2 error.

I have installed a new SSD, updated the bios and receive the same message.

I boot Linux and windows from USB sticks install the operating system and after restart the same 2103 error.

Any ideas?

Check out current deals!


Shop current deals

Top Kudoed Authors