English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

4 Posts

03-29-2019

US

3 Signins

22 Page Views

  • Posts: 4
  • Registered: ‎03-29-2019
  • Location: US
  • Views: 22
  • Message 1 of 5

6th Gen X1 Thunderbolt App Crashes

2019-03-29, 19:00 PM

New 6th gen X1 with all updated drivers and latest TB software.

 

1. When booted, the thunderbolt application lanches then closes and repeats this as if in a loop (launch, close, launch, close)

2. Regardless if the TB dock is pluggeg in or the portable battery pack is plugged in, application still crashes

3. TB dock light is orange when plugged in (normally it would turn white if the app didn't crash)

4. Light on the USB-C port on the laptop is also orange when plugged in

 

Had this problem a couple days back when I did a PC reset and the way to get past it was to plug in the portable battery pack. The TB app would stay on and I could select options to accept all connections. Then I could plug in the TB dock and all was good. But today is the first time where this flip flop back and forth with the dock and the portable battery pack isn't working and the TB app is crashing regardless. Yes, I restarted my computer.

 

Help!

 

Thanks,

Tim

Reply
Options

4 Posts

03-29-2019

US

3 Signins

22 Page Views

  • Posts: 4
  • Registered: ‎03-29-2019
  • Location: US
  • Views: 22
  • Message 2 of 5

Re: 6th Gen X1 Thunderbolt App Crashes

2019-03-29, 19:02 PM

Just noticed that the battery settings in windows 10 show me plugged in but the battery is discharging instead of charging. So I wonder if I have a connection port issue.

Reply
Options

4 Posts

03-29-2019

US

3 Signins

22 Page Views

  • Posts: 4
  • Registered: ‎03-29-2019
  • Location: US
  • Views: 22
  • Message 3 of 5

Re: 6th Gen X1 Thunderbolt App Crashes

2019-03-29, 19:47 PM

Ok, so weird stuff here. I was seeing that the bettery was discharging eventhough the battery pack was pluged in. So I decided to turn off the laptop, unplug the USB-C, and was going to take off the back just to have a look under the hood. With the laptop off, I noticed that the light on the USB-C ort was still orange eventhough the laptop was powered off. So I saw that tiny little hole that has the reset button in it. I pressed it for 10 seconds, the light turned off. So I restarted my laptop and voila! everything is acting back to normal. 

 

So what happened?

Reply
Options

2 Posts

05-30-2019

DE

2 Signins

16 Page Views

  • Posts: 2
  • Registered: ‎05-30-2019
  • Location: DE
  • Views: 16
  • Message 4 of 5

Same here / 6th Gen X1 Thunderbolt App Crashes

2019-05-30, 11:19 AM

Hi,

 

I have exactly the same issue here.

 

I figured out, that there was maybe a power loss from the 230W a/c into the Dock.

To stop the app boot loop, I turned off the Tasks in SysInternals\autoruns.

 

The Dock seems bricked, even if ethernet and power charge is still working, but Thunderboldt is broken.

 

Any solution?

 

Best Pixel

Reply
Options

2 Posts

05-30-2019

DE

2 Signins

16 Page Views

  • Posts: 2
  • Registered: ‎05-30-2019
  • Location: DE
  • Views: 16
  • Message 5 of 5

Solution: 6th Gen X1 Thunderbolt App Crashes

2019-06-03, 14:36 PM

I have a solution now:

Today new Thunderbolt drivers from Lenovo Vantage appeared.

 

Further I experienced that my notebook was not loading the battery properly anymore. It was connected to the a/c but not loading.

 

I made a hard reset at bottom pin hole, and everyting is working again.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete