Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

19 Posts

08-16-2014

United Kingdom of Great Britain and Northern Ireland

56 Signins

260 Page Views

  • Posts: 19
  • Registered: ‎08-16-2014
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 260
  • Message 1 of 7

Battery saver mode stuck at 50% after changing to Linux.

2015-05-01, 14:34 PM

Hello,

 

When I had W7P installed on my X1/2G, I turned on the battery saver mode.

 

Later, I decided to change the OS to Linux and didn't change it back to normal

battery mode and Linux (Debian) only seems to charge the battery to 50%.

 

Firstly, is this in fact a Windows lagacy issue and secondly, is there a command

or BIOS option that will reset the battery mode to full charge?

 

TIA.

 

 

Reply
Answer
Options

19 Posts

08-16-2014

United Kingdom of Great Britain and Northern Ireland

56 Signins

260 Page Views

  • Posts: 19
  • Registered: ‎08-16-2014
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 260

Re: Battery saver mode stuck at 50% after changing to Linux.

2015-05-17, 3:11 AM

Additional...

 

TLP don't work on systems with sandtbridge or newer.

Which I believe includes the X1/2G. However, another

power manager exists that may work.

Reply

Replies(6)
Options

9644 Posts

12-27-2009

Canada

3314 Signins

95288 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95288
  • Message 2 of 7

Re: Battery saver mode stuck at 50% after changing to Linux.

2015-05-01, 15:57 PM
TLP can set charging thresholds. Give that a try?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

19 Posts

08-16-2014

United Kingdom of Great Britain and Northern Ireland

56 Signins

260 Page Views

  • Posts: 19
  • Registered: ‎08-16-2014
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 260
  • Message 3 of 7

Re: Battery saver mode stuck at 50% after changing to Linux.

2015-05-01, 22:18 PM

Thanks for reply.

 

Followed the instructions for the install as per website

but I can't get the tp-smapi and acpi-call kernel modules

to load.

 

Apparently TLP has been known to work on the first

generation of X1 according to the ThinkWiki website

and should also work on the 2G model but I can't

even force load the modules as per FAQ.

 

Any Ideas?

 

Reply
Options

9644 Posts

12-27-2009

Canada

3314 Signins

95288 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95288
  • Message 4 of 7

Re: Battery saver mode stuck at 50% after changing to Linux.

2015-05-03, 23:15 PM
Are you on systemd or sysvinit?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

19 Posts

08-16-2014

United Kingdom of Great Britain and Northern Ireland

56 Signins

260 Page Views

  • Posts: 19
  • Registered: ‎08-16-2014
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 260
  • Message 5 of 7

Re: Battery saver mode stuck at 50% after changing to Linux.

2015-05-04, 23:26 PM

Thanks for reply.

 

I'm using Kali Linux 1.1.0a / Debian and when I run the command

 

cat /proc/1/comm

 

I get the value 'init' which I'm guessing isn't systemd.

Hope this helps.

 

Reply
Options

19 Posts

08-16-2014

United Kingdom of Great Britain and Northern Ireland

56 Signins

260 Page Views

  • Posts: 19
  • Registered: ‎08-16-2014
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 260
  • Message 6 of 7

Re: Battery saver mode stuck at 50% after changing to Linux.

2015-05-09, 22:51 PM

Update...

 

Reinstalled the whole OS and selected wheezy as the disto version for TLP.

Additionally, I installed the packages following the Without systemd section

but still get the following not installed message.

 

 

+++ ThinkPad Extended Battery Functions
tp-smapi   = inactive (kernel module 'tp_smapi' not installed)
tpacpi-bat = inactive (kernel module 'acpi_call' not installed)

+++ Battery Status
/sys/class/power_supply/BAT0/manufacturer                   = SONY
/sys/class/power_supply/BAT0/model_name                     = 45N1701
/sys/class/power_supply/BAT0/cycle_count                    = (not supported)
/sys/class/power_supply/BAT0/energy_full_design             =  44850 [mWh]
/sys/class/power_supply/BAT0/energy_full                    =  44400 [mWh]
/sys/class/power_supply/BAT0/energy_now                     =  21980 [mWh]
/sys/class/power_supply/BAT0/power_now                      =      0 [mW]
/sys/class/power_supply/BAT0/status                         = Unknown

+++ Suggestions
* Install tp-smapi kernel modules for ThinkPad advanced battery functions

I've checked that the suggested kernel modules are installed and they are!

 

Any ideas anyone?

 

Reply
Answer
Options

19 Posts

08-16-2014

United Kingdom of Great Britain and Northern Ireland

56 Signins

260 Page Views

  • Posts: 19
  • Registered: ‎08-16-2014
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 260
  • Message 7 of 7

Re: Battery saver mode stuck at 50% after changing to Linux.

2015-05-17, 3:11 AM

Additional...

 

TLP don't work on systems with sandtbridge or newer.

Which I believe includes the X1/2G. However, another

power manager exists that may work.

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms