cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DoctorShtein
Paper Tape
Posts: 1
Registered: ‎12-26-2019
Location: US
Views: 116
Message 1 of 2

Carbon X1 6th Gen (20KH) - Thunderbolt, USB-C, HDMI, Charger not working.

Hi everybody,

I'm facing an issue with thunderbolt.

It started recently, after one of Vantage update runs.

 

I've read through the forum and tried almost everything, but still no luck.

 

Current state:

1. Thunderbolt controller is not in the list in Device Manager. (0x20B SDK_NO_CONTROLLERS)

2. USB-C devices (flash, camera) do not work

3. Charger only charges when laptop is powered down (when on, it barely maintains the battery level)

4. HDMI doesn't work either

 

What I've tried (several times now):

1. Running Vantage and installing all updates.

2. Flashing newest BIOS (1.44)

3. Installing the "critical thunderbolt update".

  - Software update went through.

  - Firmware update didn't happen cause controller is missing

4. Clean re-install of the Thunderbolt drivers, including

  - 'sc delete nhi'

  - deleting tbt* driver files under system32/driverstore/

5. Battery reset (pin at the bottom)

6. Toggling 'Thunderbolt assist mode' in BIOS.

 

Current system status:

1. BIOS version 1.44

2. OS version Win 10 Pro 17763 (1809)

3. Thunderbolt Software version 17.4.80.550

 

Nothing worked for me so far. Any ideas as to what I can try next?

 

 

Support Specialist
Posts: 2,020
Registered: ‎08-02-2018
Location: US
Views: 53
Message 2 of 2

Re: Carbon X1 6th Gen (20KH) - Thunderbolt, USB-C, HDMI, Charger not working.

Hi DoctorShtein!

 

Welcome to our forums community.

 

We can see that your machine is compatible to run the latest Windows 10 1909 version: https://support.lenovo.com/ph/en/solutions/ht509394. Install the update. Go to Settings --> Update & Security --> Check for Updates. Reset BIOS settings under the Restart tab in BIOS then save it. Let us know how it goes.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors