English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

1 Posts

08-14-2015

Oxford, England

3 Signins

37 Page Views

  • Posts: 1
  • Registered: ‎08-14-2015
  • Location: Oxford, England
  • Views: 37
  • Message 1 of 1

Carbon X1 - Odd Touchpad Failure

2015-08-14, 10:20 AM

Hi

 

I've read through the other 'related' touchpad issues but this one is slightly different.

 

A week or so ago, I updated Synaptics UltraNav driver for the touchpad from 18.1.27.14 (factory default) to 18.1.27.30.

Everything seemed fine.

 

I usually sleep my laptop at night. One one occassion after resuming I found that the touchpad stopped working. Motion, gestures and clicks. The trackpoint was still working.

 

I instantly rolled back the driver. No effect.

 

I noticed there were several things in play (maybe more).

1) Synaptics Pointing Device (In "Mice and other pointing devices" in Device Manager)

2) Synaptics Pointing Device Driver (Programs)

3) Synaptics WBF DDK 5011 (Programs)

4) Synaptics SMBus Driver (In "System Devices" in Device Manager)

 

I  updated all these - No effect

Re-installed these - No effect

 

However, I then disabled the Synaptics Pointing Device driver in Device Manager.

This instantly (without a restart), got the touchpad working again, The Trackpoint was also still working.

 

I slept the machine, restarted and all continued to work.

GREAT! I'd found a work around that I could live with.

WRONG.

 

The first night (and every subsequent night) that I left the laptop on sleep overnight, when resuming again in the morning, neither the trackpoint, nor trackpad worked!

 

After a restart they both worked (Synaptics Pointing Device Driver in Device Manager was still disabled)

Re-enabling this doesn't help either.

So I'm stuck in a perpetual cycle of having to reboot the machine after a sleep to get the touchpad working.

 

Ideally, I'd have the Synaptics Pointing Device Driver ENABLED and both would work.

 

Lenovo help centre took me through the ABC's of trying to fix it and I'd already done more than they had to troubleshoot.

 

They suggested re-formatting the whole machine! Nice one Lenovo! This I just can not do due to the amount of time it would take and hassle it would cause.

They have no idea of practicality or inconvenience when it comes to end users.

 

Does anyone here have ANY suggestions?

Thanks in frustration!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save