Showing results for 
Search instead for 
Do you mean 
Reply
Blue Screen Again
Posts: 1
Registered: ‎01-23-2015
Location: RU
Message 1 of 1 (229 Views)

Carbon x1 5th gen: Both Touchpad and Trackpoint not working

[ Edited ]

Recently got a new Carbon x1, and everything was working fine, but once I closed the laptop and when I woke it up neither TrackPoint nor touchpad was working. Reboots didn't help. Tried installing Synaptics drivers - it said there was no device for update. Device manager detects the touchpad as Microsoft mouse with corresponding drivers (screenshot attached).

4.PNG1.PNG2.PNG3.PNG

  Also tried installing update for TrackPoint from the drivers list, it said it needed a reboot to install, after reboot there was an error window that suggested trying once again, several times I saw this message.

Anyone have this? Are there any possible solutions?(Searched on the forum, but the solutions were not for my case or didn't work)

P.S. It would be kinda stupid for a $1500 laptop not to work because of a touchpad.

P.P.S. Tried ubuntu from usb flash drive - the same result, no trackpoint, no touchpad.

Top kudoed Authors