cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
X1-User
Blue Screen Again
Posts: 2
Registered: ‎05-26-2019
Location: DE
Views: 238
Message 1 of 5

Display of X1 Carbon 5 not working

Hello,

 

I tried to use Lenovo Vantage to fix my problem, make all necessary updates and tried to contact support.

Until now I could not find any useful information so any link to a page which can help me to narrow down the problem is highly appreciated!

 

My display stopped working from from standby mode to the next. I opened the laptop and could barely see the Lenovo sign but nothing else from that point on. I can connect a display through HDMI and can work with the laptop. As I could see "something" I tried to look into new drivers or any system information which might say there was a problem with an update.

 

Lenovo Vantage did not provide any information but I updated to the latest drivers as far as I can tell.

In a perfect world I could get some help from Lenovo to narrow down the problem before sending the laptop in.

If anybody else has a hint where to start to fix a X1 5th Generation display this would be much very helpful.

 

Thank you

 

Sven

Community Moderator
Community Moderator
Posts: 1,534
Registered: ‎12-13-2016
Location: US
Views: 222
Message 2 of 5

Re: Display of X1 Carbon 5 not working


@X1-User wrote:

 

My display stopped working from from standby mode to the next.

 


Sven..


Welcome to the Community.

 

I have a hard time understanding what you mean.  Do you mean it only fails when resuming from sleep or hibernate? Does this mean it works just fine if you boot from scratch?

 

Sounds as if the backlight for the display is off or malfunctioning. Windows Update has been known to reset the brightness slider to zero in the Power Plan settings. Depending on your WIndows version, you can attempt to change the brightness setting from Settings or from the Action Center. 

 

Doc


____________________________________
I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.
X1-User
Blue Screen Again
Posts: 2
Registered: ‎05-26-2019
Location: DE
Views: 178
Message 3 of 5

Re: Display of X1 Carbon 5 not working

Thank you for your reply. This is the kind of information I was looking for. I double checked all brightness settings but it did not change.

The problem first appeared after standby but no the display is black all the time. Reboots and update did not help.

I assume I have to check the hardware.

 

Thank you

Community Moderator
Community Moderator
Posts: 1,534
Registered: ‎12-13-2016
Location: US
Views: 174
Message 4 of 5

Re: Display of X1 Carbon 5 not working

If you don't even see the Lenovo splash screen before Windows boots, then something has possibly gone wrong with the backlighting. Could be as simple as a loose cable. Or you could need a whole panel. Time to send it in.


____________________________________
I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo. I love beer.
Carbon89
Paper Tape
Posts: 1
Registered: ‎05-28-2019
Location: GB
Views: 145
Message 5 of 5

Re: Display of X1 Carbon 5 not working

Hi Sven,

 

I've recently experienced a similar problem on my 6th Gen X1C. It's brand new and after a few days the monitor stopped working and I could only use the laptop through the HDMI. It wouldn't even show the Lenovo splash screen (although at one point after a day or so it did randomly start working again, but then stopped again after I tried rebooting. 

 

So Lenovo sent an engineer out to replace the LCD panel and it worked for a day or two...and then the same thing happened again. I can't get any image on the internal display at all. I have tried everything I can think of from a software perspective (full reset, system restore, uninstalling/reinstalling devices and drivers, checking BIOS, even tried booting off Ubuntu) but nothing works. It's a very strange problem and so I've asked Lenovo to come and pick it up and give me a refund. I'm really disappointed as I do like the look and feel of the laptop but I can't afford the lack of reliability when I'm using it for my business. Not sure on where to go next in terms of a laptop - maybe I'll try the 2019 model but this has definitely put me off unfortunately.

Check out current deals!


Shop current deals

Top Kudoed Authors