Showing results for 
Search instead for 
Do you mean 
What's DOS?
Posts: 1
Registered: ‎08-22-2011
Location: Boston, MA
Message 1 of 2 (662 Views)

Ethernet connection issue for X220

I tried to download the adapter driver for my ethernet cable to work: but for some reason, it does not install, or if it says it does install, the connection/ adapter still doesn't work (has the exclamation point in device manager).  I tried uninstalling the network connection adapter, then downloading and installing the driver, and then rebooting and it still does not work.  What can I do?  I have the X220 and have experienced many such problems, but this seems to be the most frustrating.


Thanks very much.

Former Employee
Posts: 2,437
Registered: ‎04-10-2011
Location: Malaysia
Message 2 of 2 (626 Views)

Re: Ethernet connection issue for X220

hey sarika116,

try uninstalling the ethernet drivers via Device Manager.

let windows install its generic drivers. restart your unit.

go back to Device Manager and check if the ( ! ) is still there.

test your ethernet and see if it works.

later, reinstall the driver from the link above.

WW Social Media
Important Note: If you need help, post your question in the forum, and include your system type, model number and OS. Do not post your serial number.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Follow @LenovoForums on Twitter!
Have you checked out the Community Knowledgebase yet?!
How to send a private message? --> Check out this article.
Top kudoed Authors