cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
prosen
Paper Tape
Posts: 1
Registered: ‎04-10-2017
Location: AU
Views: 566
Message 1 of 1

Gen 3 X1 Carbon unable to update BIOS version. "Secure Flash authentication failed"

Hi Everyone,

 

Sorry if this question has been hashed out before, I've had a pretty thorough look through the posts on here and haven't been able to find much meaninful information.

 

I have recently bought this X1 Carbon second hand (20BT) and ammongst other stuggles have been trying to get the fingerprint reader to work with win10. I have read in other posts that a large contributor to this can be an out of date bios. The BIOS version I am currently running is 1.06 (N14ET28W) dated March 2015. When trying to update the bios using the newest executable provided on the lenovo support site I receive a "Secure Flash Authentication Failed!" message then the laptop shuts down.

 

I have tried doing more incremental updates using older versions which do give me some different results, the embedded controller version will update but I still receive the same error message re: secure flash authentication.

 

So I ask, is there some kind of BIOS setting I have to change other than "allow end user acces to modify bios" to allow the secure flash authentication to proceed? Also how does on update the BIOS using the bootable disk option considering this laptop has no disk drive, I have tried using a USB with no success mounting the .iso so far.

 

Any assistance you could provide would be much appreciated.

 

Thanks,

 

Jeremy

Holiday Deals
HAPPENING NOW!

Get the best deals on PCs and tech now during the Holiday Sale
Shop the sale

Top Kudoed Authors