cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Dbarret1
Paper Tape
Posts: 3
Registered: ‎05-06-2019
Location: US
Views: 119
Message 1 of 5

HDMI not coming on x1c6 - solutions in other posts don't help

Hello,

HDMI output is not working for me on 

  • A fresh install of windows 10 with all drivers updated
  • Arch Linux with newest kernel
  • Ubuntu 18.04 installer

I have tried solutions suggested in other threads such as using the power reset button, changing bios assist mode, updating firmware (using fwupd).

In windows and Linux the Thunderbolt device is not listed. Not sure if this is related or not. Is it possible that this is bad hardware?

Thanks!

Social Support Agent
Social Support Agent
Posts: 533
Registered: ‎08-02-2018
Location: US
Views: 74
Message 2 of 5

Re: HDMI not coming on x1c6 - solutions in other posts don't help

Hi Dbarret1!

 

Welcome to the Community,

 

Another step to further isolate the problem would be using a different HDMI cable to output the video. It would be best to try this on Windows 10, since Ubuntu 18.04 is not compatible with X1 Carbon 6th Gen as per Linux Certification list,

 

https://support.lenovo.com/us/en/solutions/pd031426

 

If it's still the same, despite the Thunderbolt Firmware updated, we highly recommend contacting our support for warranty claim here,

 

https://pcsupport.lenovo.com/us/en/supportphonelist

 

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Dbarret1
Paper Tape
Posts: 3
Registered: ‎05-06-2019
Location: US
Views: 66
Message 3 of 5

Re: HDMI not coming on x1c6 - solutions in other posts don't help

Thank you for the reply,
Changing cables did not help, I changed monitors as well.
The thunderbolt software installs on windows but the firmware update says that it does not see a device, and it also does not show up in device manager. So I have not successfully updated the thunderbolt firmware. In the thunderbolt software it does not show any information about the thunderbolt controller as I have seen in other screenshots on this forum.
I have tried this in windows with both bios assist mode on and off.
I do not have any actual thunderbolt devices to try and test with either, but it seems that it is related to the hdmi functionality.
Thanks!
Social Support Agent
Social Support Agent
Posts: 533
Registered: ‎08-02-2018
Location: US
Views: 61
Message 4 of 5

Re: HDMI not coming on x1c6 - solutions in other posts don't help

I see. While these known working cables and monitors are connected, try pressing Windows key + P. If it still shows No Signal with these available option to project, likely there's an issue with the actual HDMI Port. It would be best as well to contact our support using the link mentioned above, so they can provide you repair options.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Dbarret1
Paper Tape
Posts: 3
Registered: ‎05-06-2019
Location: US
Views: 55
Message 5 of 5

Re: HDMI not coming on x1c6 - solutions in other posts don't help

Yes it still shows no signal, I will contact support like you suggest. 

Thanks!

Check out current deals!


Shop current deals

Top Kudoed Authors